CVE-2002-1394
CVSS7.5
发布时间 :2003-01-17 00:00:00
修订时间 :2016-10-17 22:26:46
NMCOS    

[原文]Apache Tomcat 4.0.5 and earlier, when using both the invoker servlet and the default servlet, allows remote attackers to read source code for server files or bypass certain protections, a variant of CAN-2002-1148.


[CNNVD]Apache Tomcat调用Servlet文件泄露漏洞(CNNVD-200301-017)

        
        Apache Tomcat是一款由Apache Foundation维护的免费开放源代码的Java Servlet和JSP服务程序。可运行在Unix、Linux和Windows操作系统下。
        Apache Tomcat不正确处理用户提交的恶意Servlet请求,远程攻击者可以利用这个漏洞获得JSP源代码或其他受保护资源信息。
        此漏洞允许攻击者提交恶意构建的URL,使Apache Tomcat返回未被处理的JSP页面代码,在某些特殊情况下,可以未授权获得受安全保护的页面信息。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:apache:tomcat:4.0.4Apache Software Foundation Tomcat 4.0.4
cpe:/a:apache:tomcat:4.0.5Apache Software Foundation Tomcat 4.0.5
cpe:/a:apache:tomcat:4.1.10Apache Software Foundation Tomcat 4.1.10
cpe:/a:apache:tomcat:4.0.0Apache Software Foundation Tomcat 4.0.0
cpe:/a:apache:tomcat:4.0.1Apache Software Foundation Tomcat 4.0.1
cpe:/a:apache:tomcat:4.1.0Apache Software Foundation Tomcat 4.1.0
cpe:/a:apache:tomcat:4.1.9:betaApache Software Foundation Tomcat 4.1.9 beta
cpe:/a:apache:tomcat:4.0.2Apache Software Foundation Tomcat 4.0.2
cpe:/a:apache:tomcat:4.1.3:betaApache Software Foundation Tomcat 4.1.3 beta
cpe:/a:apache:tomcat:4.0.3Apache Software Foundation Tomcat 4.0.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1394
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1394
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200301-017
(官方数据源) CNNVD

- 其它链接及资源

http://issues.apache.org/bugzilla/show_bug.cgi?id=13365
(UNKNOWN)  CONFIRM  http://issues.apache.org/bugzilla/show_bug.cgi?id=13365
http://marc.info/?l=bugtraq&m=103470282514938&w=2
(UNKNOWN)  GENTOO  GLSA-200210-001
http://marc.info/?l=tomcat-dev&m=103417249325526&w=2
(UNKNOWN)  CONFIRM  http://marc.info/?l=tomcat-dev&m=103417249325526&w=2
http://www.debian.org/security/2003/dsa-225
(UNKNOWN)  DEBIAN  DSA-225
http://www.redhat.com/support/errata/RHSA-2003-075.html
(UNKNOWN)  REDHAT  RHSA-2003:075
http://www.redhat.com/support/errata/RHSA-2003-082.html
(UNKNOWN)  REDHAT  RHSA-2003:082
http://www.securityfocus.com/bid/6562
(UNKNOWN)  BID  6562
http://xforce.iss.net/xforce/xfdb/10376
(VENDOR_ADVISORY)  XF  tomcat-invoker-source-code(10376)

- 漏洞信息

Apache Tomcat调用Servlet文件泄露漏洞
高危 输入验证
2003-01-17 00:00:00 2005-05-13 00:00:00
远程  
        
        Apache Tomcat是一款由Apache Foundation维护的免费开放源代码的Java Servlet和JSP服务程序。可运行在Unix、Linux和Windows操作系统下。
        Apache Tomcat不正确处理用户提交的恶意Servlet请求,远程攻击者可以利用这个漏洞获得JSP源代码或其他受保护资源信息。
        此漏洞允许攻击者提交恶意构建的URL,使Apache Tomcat返回未被处理的JSP页面代码,在某些特殊情况下,可以未授权获得受安全保护的页面信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 通过从Tomcat配置文件$CATALINA_HOME/conf/web.xml中删除如下行暂时修补此漏洞:
        
        invoker
        /servlet/*
        

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2003/dsa-225

        Apache
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Apache Software Foundation Tomcat 4.0:
        Apache Software Foundation Hotfix 13365.zip
        
        http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.0.5/bin/hotfix/13365.zip

        Apache Software Foundation Tomcat 4.0.1:
        Apache Software Foundation Hotfix 13365.zip
        
        http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.0.5/bin/hotfix/13365.zip

        Apache Software Foundation Tomcat 4.0.2:
        Apache Software Foundation Hotfix 13365.zip
        
        http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.0.5/bin/hotfix/13365.zip

        Apache Software Foundation Tomcat 4.0.3:
        Apache Software Foundation Hotfix 13365.zip
        
        http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.0.5/bin/hotfix/13365.zip

        Apache Software Foundation Tomcat 4.1:
        Apache Software Foundation Upgrade Jakarta Tomcat 4.1.12
        
        http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.1.12/

        Apache Software Foundation Tomcat 4.1.3 beta:
        Apache Software Foundation Upgrade Jakarta Tomcat 4.1.12
        
        http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.1.12/

        Apache Software Foundation Tomcat 4.1.9 beta:
        Apache Software Foundation Upgrade Jakarta Tomcat 4.1.12
        
        http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.1.12/

        Apache Software Foundation Tomcat 4.1.10:
        Apache Software Foundation Upgrade Jakarta Tomcat 4.1.12
        
        http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.1.12/

- 漏洞信息

9705
Apache Tomcat Invoker/Default Servlet Source Disclosure

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-10-09 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Apache Tomcat Invoker Servlet File Disclosure Vulnerability
Input Validation Error 6562
Yes No
2002-10-09 12:00:00 2008-09-05 06:51:00
This vulnerability was reported by the Tomcat development team.

- 受影响的程序版本

Sun Solaris 9_x86
Sun Solaris 9_sparc
Sun Solaris 9
Sun Solaris 10_x86
Sun Solaris 10_sparc
Sun Solaris 10
RedHat Stronghold 4.0
Apache Software Foundation Tomcat 4.1.10
Apache Software Foundation Tomcat 4.1.9 beta
Apache Software Foundation Tomcat 4.1.3 beta
Apache Software Foundation Tomcat 4.1
- BSDI BSD/OS 4.0
- Caldera OpenLinux 2.4
- Conectiva Linux 5.1
- Debian Linux 2.3
- Debian Linux 2.2
- Debian Linux 2.1
- Digital UNIX 4.0
- FreeBSD FreeBSD 5.0
- FreeBSD FreeBSD 4.5
- Mandriva Linux Mandrake 7.1
- Mandriva Linux Mandrake 7.0
- NetBSD NetBSD 1.4.2 x86
- NetBSD NetBSD 1.4.1 x86
- RedHat Linux 6.2 i386
- RedHat Linux 6.1 i386
- SGI IRIX 6.5
- SGI IRIX 6.4
- SGI IRIX 3.3
- Sun Solaris 8_sparc
- Sun Solaris 7.0
Apache Software Foundation Tomcat 4.0.5
+ RedHat Stronghold 4.0
Apache Software Foundation Tomcat 4.0.4
Apache Software Foundation Tomcat 4.0.3
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
Apache Software Foundation Tomcat 4.0.2
Apache Software Foundation Tomcat 4.0.1
- BSDI BSD/OS 4.0
- Caldera OpenLinux 2.4
- Conectiva Linux 5.1
- Debian Linux 2.2
- Debian Linux 2.1
- Digital UNIX 4.0
- FreeBSD FreeBSD 5.0
- FreeBSD FreeBSD 4.0
- Mandriva Linux Mandrake 7.1
- Mandriva Linux Mandrake 7.0
- NetBSD NetBSD 1.4.2 x86
- NetBSD NetBSD 1.4.1 x86
- RedHat Linux 6.2 i386
- RedHat Linux 6.1 i386
- SGI IRIX 6.5
- SGI IRIX 6.4
- SGI IRIX 3.3
- Sun Solaris 8_sparc
- Sun Solaris 7.0
Apache Software Foundation Tomcat 4.0
- BSDI BSD/OS 4.0
- Caldera OpenLinux 2.4
- Conectiva Linux 5.1
- Debian Linux 2.2
- Debian Linux 2.1
- Digital UNIX 4.0
- FreeBSD FreeBSD 5.0
- FreeBSD FreeBSD 4.0
- Mandriva Linux Mandrake 7.1
- Mandriva Linux Mandrake 7.0
- NetBSD NetBSD 1.4.2 x86
- NetBSD NetBSD 1.4.1 x86
- RedHat Linux 6.2 i386
- RedHat Linux 6.1 i386
- SGI IRIX 6.5
- SGI IRIX 6.4
- Sun Solaris 8_sparc
- Sun Solaris 7.0
Apache Software Foundation Tomcat 4.1.12

- 不受影响的程序版本

Apache Software Foundation Tomcat 4.1.12

- 漏洞讨论

An information-disclosure vulnerability has been reported to reside in Apache Tomcat. The vulnerability allows an attacker to cause Tomcat to return the unprocessed source of a JSP page or, in certain circumstances, a resource that would otherwise have been secured.

The vulnerability occurs when using the invoker servlet in conjunction with the default servlet.

NOTE: This issue is a variant of the vulnerability described in BID 5786.

- 漏洞利用

No exploit code is required.

- 解决方案

Fixes are available. Please see the references for details.


Sun Solaris 9

Sun Solaris 9_x86

Apache Software Foundation Tomcat 4.0

Apache Software Foundation Tomcat 4.0.1

Apache Software Foundation Tomcat 4.0.2

Apache Software Foundation Tomcat 4.0.3

Apache Software Foundation Tomcat 4.0.4

Apache Software Foundation Tomcat 4.0.5

Apache Software Foundation Tomcat 4.1

Apache Software Foundation Tomcat 4.1.10

Apache Software Foundation Tomcat 4.1.3 beta

Apache Software Foundation Tomcat 4.1.9 beta

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站