CVE-2002-1341
CVSS6.8
发布时间 :2002-12-18 00:00:00
修订时间 :2016-10-17 22:26:08
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in read_body.php for SquirrelMail 1.2.10, 1.2.9, and earlier allows remote attackers to insert script and HTML via the (1) mailbox and (2) passed_id parameters.


[CNNVD]SquirrelMail read_body.php跨站脚本漏洞(CNNVD-200212-034)

        用于SquirrelMail 1.2.10,1.2.9及其早期版本的read_body.php存在跨站脚本(XSS)漏洞。远程攻击者可以借助(1)mailbox和(2)passed_id参数插入脚本和HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:squirrelmail:squirrelmail:1.2.9
cpe:/a:squirrelmail:squirrelmail:1.2.6
cpe:/a:squirrelmail:squirrelmail:1.2.7
cpe:/a:squirrelmail:squirrelmail:1.2.8
cpe:/a:squirrelmail:squirrelmail:1.2.10

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1341
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1341
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-034
(官方数据源) CNNVD

- 其它链接及资源

http://f0kp.iplus.ru/bz/008.txt
(UNKNOWN)  MISC  http://f0kp.iplus.ru/bz/008.txt
http://marc.info/?l=bugtraq&m=103893844126484&w=2
(UNKNOWN)  BUGTRAQ  20021203 SquirrelMail v1.2.9 XSS bugs
http://marc.info/?l=bugtraq&m=103911130503272&w=2
(UNKNOWN)  BUGTRAQ  20021203 Re: SquirrelMail v1.2.9 XSS bugs
http://marc.info/?l=bugtraq&m=104004924002662&w=2
(UNKNOWN)  BUGTRAQ  20021215 GLSA: squirrelmail
http://www.debian.org/security/2002/dsa-220
(UNKNOWN)  DEBIAN  DSA-220
http://www.redhat.com/support/errata/RHSA-2003-042.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2003:042
http://www.securityfocus.com/bid/6302
(VENDOR_ADVISORY)  BID  6302
http://xforce.iss.net/xforce/xfdb/10754
(UNKNOWN)  XF  squirrelmail-readbody-xss(10754)

- 漏洞信息

SquirrelMail read_body.php跨站脚本漏洞
中危 跨站脚本
2002-12-18 00:00:00 2005-10-20 00:00:00
远程  
        用于SquirrelMail 1.2.10,1.2.9及其早期版本的read_body.php存在跨站脚本(XSS)漏洞。远程攻击者可以借助(1)mailbox和(2)passed_id参数插入脚本和HTML。

- 公告与补丁

        Gentoo Linux has released an advisory. Users who have installed net-mail/squirrelmail-1.2.9 and earlier are advised to update their systems by issuing the following commands:
        emerge rsync
        emerge squirrelmail
        emerge clean
        SquirrelMail SquirrelMail 1.2.6
        
        SquirrelMail SquirrelMail 1.2.7
        
        SquirrelMail SquirrelMail 1.2.8
        

- 漏洞信息

4266
SquirrelMail read_body.php XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown

- 漏洞描述

Squirrelmail contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate mailbox or passed_id variables upon submission to the read_body.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-12-02 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.4.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SquirrelMail read_body.php Cross Site Scripting Vulnerability
Input Validation Error 6302
Yes No
2002-12-03 12:00:00 2009-07-11 07:16:00
The discovery of this vulnerability is credited to "euronymous" <just-a-user@yandex.ru>.

- 受影响的程序版本

SquirrelMail SquirrelMail 1.2.10
SquirrelMail SquirrelMail 1.2.9
SquirrelMail SquirrelMail 1.2.8
+ Terra Soft Solutions Yellow Dog Linux 3.0
SquirrelMail SquirrelMail 1.2.7
+ RedHat Linux 8.0
SquirrelMail SquirrelMail 1.2.6
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Debian Linux 3.0

- 漏洞讨论

A vulnerability has been discovered in SquirrelMail. The read_body.php script fails to adequately sanitize user-supplied parameters, making it prone to cross site scripting attacks. An attacker may be able to exploit this vulnerability to execute embedded script code in an HTML email that is read by a vulnerable client.

- 漏洞利用

No exploit is required for this vulnerability.

- 解决方案

Gentoo Linux has released an advisory. Users who have installed net-mail/squirrelmail-1.2.9 and earlier are advised to update their systems by issuing the following commands:

emerge rsync
emerge squirrelmail
emerge clean


SquirrelMail SquirrelMail 1.2.6

SquirrelMail SquirrelMail 1.2.7

SquirrelMail SquirrelMail 1.2.8

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站