CVE-2002-1334
CVSS6.8
发布时间 :2002-12-11 00:00:00
修订时间 :2016-10-17 22:26:00
NMCOES    

[原文]Cross-site scripting (XSS) vulnerability in BizDesign ImageFolio 3.01 and earlier allows remote attackers to execute arbitrary web script as other users via (1) the direct parameter in imageFolio.cgi, or (2) nph-build.cgi.


[CNNVD]BizDesign ImageFolio跨站脚本漏洞(CNNVD-200212-007)

        BizDesign ImageFolio 3.01及其早期版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助(1)imageFolio.cgi中的direct参数或(2)nph-build.cgi像其他使用者一样执行任意web脚本。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:bizdesign:imagefolio:2.23
cpe:/a:bizdesign:imagefolio:2.26
cpe:/a:bizdesign:imagefolio:2.24
cpe:/a:bizdesign:imagefolio:3.0.1
cpe:/a:bizdesign:imagefolio:2.27

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1334
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1334
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200212-007
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=103842773205148&w=2
(UNKNOWN)  BUGTRAQ  20021127 Cross-site Scripting Vulnerability in ImageFolio Image Gallery Software
http://securitytracker.com/id?1005681
(UNKNOWN)  SECTRACK  1005681
http://www.securityfocus.com/bid/6265
(UNKNOWN)  BID  6265
http://xforce.iss.net/xforce/xfdb/10718
(UNKNOWN)  XF  imagefolio-imagefolio-nphbuild-xss(10718)

- 漏洞信息

BizDesign ImageFolio跨站脚本漏洞
中危 跨站脚本
2002-12-11 00:00:00 2005-10-20 00:00:00
远程  
        BizDesign ImageFolio 3.01及其早期版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助(1)imageFolio.cgi中的direct参数或(2)nph-build.cgi像其他使用者一样执行任意web脚本。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (22050)

BizDesign ImageFolio 2.x/3.0.1 imageFolio.cgi direct Parameter XSS (EDBID:22050)
cgi webapps
2002-11-27 Verified
0 SecurityTracker.com
N/A [点击下载]
source: http://www.securityfocus.com/bid/6265/info

Reportedly, ImageFolio is prone to cross site scripting attacks due to insufficient sanitization of user-supplied input. The vulnerability exists in various cgi scripts included with ImageFolio.

As a result, it is possible for a remote attacker to create a malicious link containing script code which will be executed in the browser of a legitimate user, in the context of the website running Bugzilla.

This issue may be exploited to steal cookie-based authentication credentials from legitimate users of the website running the vulnerable software.

/cgi-bin/imageFolio.cgi?direct=<script>alert("SecurityHole")</script>		

- 漏洞信息 (22051)

BizDesign ImageFolio 2.x/3.0.1 nph-build.cgi XSS (EDBID:22051)
cgi webapps
2002-11-27 Verified
0 SecurityTracker.com
N/A [点击下载]
source: http://www.securityfocus.com/bid/6265/info
 
Reportedly, ImageFolio is prone to cross site scripting attacks due to insufficient sanitization of user-supplied input. The vulnerability exists in various cgi scripts included with ImageFolio.
 
As a result, it is possible for a remote attacker to create a malicious link containing script code which will be executed in the browser of a legitimate user, in the context of the website running Bugzilla.
 
This issue may be exploited to steal cookie-based authentication credentials from legitimate users of the website running the vulnerable software.

/cgi-bin/if/admin/nph-build.cgi?step=<script>alert("SecurityHole")</script>		

- 漏洞信息

4572
ImageFolio imageFolio.cgi direct Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

ImageFolio contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "direct" variables upon submission to the "imageFolio.cgi" script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-11-22 2002-06-09
2002-11-22 Unknow

- 解决方案

Upgrade to version 3.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

BizDesign ImageFolio Cross Site Scripting Vulnerability
Input Validation Error 6265
Yes No
2002-11-27 12:00:00 2009-07-11 07:16:00
Discovery of this vulnerability is credited to SecurityTracker.com.

- 受影响的程序版本

BizDesign ImageFolio 3.0.1
BizDesign ImageFolio 2.27
BizDesign ImageFolio 2.26
BizDesign ImageFolio 2.24
BizDesign ImageFolio 2.23

- 漏洞讨论

Reportedly, ImageFolio is prone to cross site scripting attacks due to insufficient sanitization of user-supplied input. The vulnerability exists in various cgi scripts included with ImageFolio.

As a result, it is possible for a remote attacker to create a malicious link containing script code which will be executed in the browser of a legitimate user, in the context of the website running Bugzilla.

This issue may be exploited to steal cookie-based authentication credentials from legitimate users of the website running the vulnerable software.

- 漏洞利用

The following proof of concept was provided:

/cgi-bin/imageFolio.cgi?direct=&lt;script&gt;alert("SecurityHole")&lt;/script&gt;

/cgi-bin/if/admin/nph-build.cgi?step=&lt;script&gt;alert("SecurityHole")&lt;/script&gt;

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站