CVE-2002-1312
CVSS5.0
发布时间 :2002-11-20 00:00:00
修订时间 :2008-09-05 16:30:16
NMCOS    

[原文]Buffer overflow in the Web management interface in Linksys BEFW11S4 wireless access point router 2 and BEFSR11, BEFSR41, and BEFSRU31 EtherFast Cable/DSL routers with firmware before 1.43.3 with remote management enabled allows remote attackers to cause a denial of service (router crash) via a long password.


[CNNVD]多个Linksys设备密码字段缓冲区溢出漏洞(CNNVD-200211-037)

        
        Linksys开发了多种宽带路有器设备,包括了BEFW11S4、BEFSRU31等,其中都包含WEB管理接口。
        路由器的WEB管理接口对超长密码处理不正确,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击,使设备崩溃。
        攻击者可以提交密码字段包含超长字符串的请求给路由器的WEB管理接口系统,当设备尝试处理此畸形输入请求时,可导致设备崩溃。需要重新启动恢复正常功能。
        默认情况下远程管理接口不启用。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/h:linksys:befsr11:1.42.7Linksys BEFSR11 1.42.7
cpe:/h:linksys:befw11s4:1.4.3
cpe:/h:linksys:befsr41:1.43Linksys EtherFast BEFSR41 Router 1.43
cpe:/h:linksys:befsx41:1.42.7Linksys BEFSX41 1.42.7
cpe:/h:linksys:befsru31:1.42.7Linksys BEFSRU31 1.42.7
cpe:/h:linksys:befsru31:1.43Linksys EtherFast BEFSRU31 Router 1.43
cpe:/h:linksys:befsr41:1.42.7Linksys BEFSR41 1.42.7
cpe:/h:linksys:befsr11:1.43Linksys EtherFast BEFSR11 Router 1.43
cpe:/h:linksys:befn2ps4:1.42.7Linksys BEFN2PS4 1.42.7
cpe:/h:linksys:hpro200:1.42.7Linksys HPRO200 1.42.7
cpe:/h:linksys:befsr81:2.42.7.1Linksys EtherFast BEFSR81 Router 2.42.7
cpe:/h:linksys:befvp41:1.42.7Linksys BEFVP41 1.42.7
cpe:/h:linksys:befw11s4:1.4.2.7Linksys BEFW11S4 1.4.2.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1312
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1312
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200211-037
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/6208
(PATCH)  BID  6208
http://xforce.iss.net/xforce/xfdb/10654
(UNKNOWN)  XF  linksys-etherfast-password-dos(10654)
http://archives.neohapsis.com/archives/bugtraq/2002-12/0022.html
(UNKNOWN)  BUGTRAQ  20021202 CORE-20021005: Vulnerability Report For Linksys Devices
http://www1.corest.com/common/showdoc.php?idx=276&idxseccion=10
(UNKNOWN)  MISC  http://www1.corest.com/common/showdoc.php?idx=276&idxseccion=10
http://www.securityfocus.com/bid/6301
(UNKNOWN)  BID  6301
http://www.idefense.com/application/poi/display?id=36&type=vulnerabilities&flashstatus=true
(UNKNOWN)  IDEFENSE  20021119 Denial of Service Vulnerability in Linksys Cable/DSL Routers

- 漏洞信息

多个Linksys设备密码字段缓冲区溢出漏洞
中危 边界条件错误
2002-11-20 00:00:00 2005-10-20 00:00:00
本地  
        
        Linksys开发了多种宽带路有器设备,包括了BEFW11S4、BEFSRU31等,其中都包含WEB管理接口。
        路由器的WEB管理接口对超长密码处理不正确,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击,使设备崩溃。
        攻击者可以提交密码字段包含超长字符串的请求给路由器的WEB管理接口系统,当设备尝试处理此畸形输入请求时,可导致设备崩溃。需要重新启动恢复正常功能。
        默认情况下远程管理接口不启用。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 关闭远程管理接口。
        厂商补丁:
        Linksys
        -------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        固件下载:
        Linksys BEFW11S4 1.4.2 .7:
        Linksys Upgrade Firmware 1.43.3
        
        http://www.linksys.com/download/

        Linksys BEFW11S4 1.4.3:
        Linksys Upgrade Firmware 1.43.3
        
        http://www.linksys.com/download/

        Linksys EtherFast BEFSR41 Router 1.42.7:
        Linksys Upgrade Firmware 1.43.3
        
        http://www.linksys.com/download/

        Linksys EtherFast BEFSR11 Router 1.42.7:
        Linksys Upgrade Firmware 1.43.3
        
        http://www.linksys.com/download/

        Linksys EtherFast BEFSRU31 Router 1.42.7:
        Linksys Upgrade Firmware 1.43.3
        
        http://www.linksys.com/download/

        Linksys BEFVP41 1.42.7:
        Linksys BEFSX41 1.42.7:
        Linksys BEFN2PS4 1.42.7:
        Linksys HPRO200 1.42.7:
        Linksys EtherFast BEFSR41 Router 1.43:
        Linksys Upgrade Firmware 1.43.3
        
        http://www.linksys.com/download/

        Linksys EtherFast BEFSR11 Router 1.43:
        Linksys Upgrade Firmware 1.43.3
        
        http://www.linksys.com/download/

        Linksys EtherFast BEFSRU31 Router 1.43:
        Linksys Upgrade Firmware 1.43.3
        
        http://www.linksys.com/download/

- 漏洞信息

18470
Linksys Multiple Router Web Management Interface Password Field Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

- 时间线

2002-12-02 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Multiple Linksys Devices Password Field Buffer Overflow Vulnerability
Boundary Condition Error 6208
No Yes
2002-11-20 12:00:00 2009-07-11 07:16:00
Discovery of this vulnerability credited to Alex S. Harasic (aharasic@terra.cl).

- 受影响的程序版本

Linksys HPRO200 1.42.7
Linksys EtherFast BEFSRU31 Router 1.43
Linksys EtherFast BEFSRU31 Router 1.42.7
Linksys EtherFast BEFSRU31 Router 1.42.3
Linksys EtherFast BEFSR81 Router 2.42.7
Linksys EtherFast BEFSR41 Router 1.43
Linksys EtherFast BEFSR41 Router 1.42.7
Linksys EtherFast BEFSR41 Router 1.42.3
Linksys EtherFast BEFSR11 Router 1.43
Linksys EtherFast BEFSR11 Router 1.42.7
Linksys EtherFast BEFSR11 Router 1.42.3
Linksys BEFW11S4 1.4.3
Linksys BEFW11S4 1.4.2 .7
Linksys BEFVP41 1.42.7
Linksys BEFSX41 1.42.7
Linksys BEFN2PS4 1.42.7
Linksys EtherFast BEFSRU31 Router 1.43.3
Linksys EtherFast BEFSR41 Router 1.43.3
Linksys EtherFast BEFSR11 Router 1.43.3
Linksys BEFW11S4 1.43.3

- 不受影响的程序版本

Linksys EtherFast BEFSRU31 Router 1.43.3
Linksys EtherFast BEFSR41 Router 1.43.3
Linksys EtherFast BEFSR11 Router 1.43.3
Linksys BEFW11S4 1.43.3

- 漏洞讨论

Several Linksys Broadband Router devices are prone to a buffer overflow condition.

An attacker can exploit this vulnerability by issuing an overly long string for the Password field. When the device attempts to process the malformed input, it will crash. Remote exploitation is possible if the device is configured for remote management. However, remote management is disabled by default.

Rebooting the device is necessary to restore functionality.

- 漏洞利用

There is no exploit code required.

- 解决方案

The following information has been reported as being from the vendor:

Until the updated firmware is released, we recommend that users downgrade the firmware to an earlier release, or minimize the risk of an attack by disabling remote management of the device.

Reports that fixed firmware for the v1 version of the BEFW11S4 router will not be released have been received.

This information has not been confirmed.

A new firmware revision is available:


Linksys BEFW11S4 1.4.2 .7

Linksys BEFW11S4 1.4.3

Linksys EtherFast BEFSR41 Router 1.42.7

Linksys EtherFast BEFSR11 Router 1.42.7

Linksys EtherFast BEFSRU31 Router 1.42.7

Linksys EtherFast BEFSR41 Router 1.43

Linksys EtherFast BEFSR11 Router 1.43

Linksys EtherFast BEFSRU31 Router 1.43

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站