CVE-2002-1264
CVSS7.5
发布时间 :2002-11-12 00:00:00
修订时间 :2016-10-17 22:25:18
NMCOS    

[原文]Buffer overflow in Oracle iSQL*Plus web application of the Oracle 9 database server allows remote attackers to execute arbitrary code via a long USERID parameter in the isqlplus URL.


[CNNVD]Oracle 9i数据库服务器iSQL Plus畸形USERID缓冲区溢出漏洞(CNNVD-200211-021)

        Oracle 9版本数据库服务器Oracle iSQL*Plus web应用程序存在缓冲区溢出漏洞。远程攻击者可以借助isqlplus URL的超长USERID参数执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:oracle:oracle9i:9.0.2
cpe:/a:oracle:oracle9i:9.0.1
cpe:/a:oracle:oracle9i:9.0.1.2
cpe:/a:oracle:oracle9i:9.0.1.3
cpe:/a:oracle:oracle9i:release_2_9.2.1
cpe:/a:oracle:oracle9i:9.0
cpe:/a:oracle:oracle9i:release_2_9.2.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1264
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1264
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200211-021
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/vulnwatch/2002-q4/0060.html
(UNKNOWN)  VULNWATCH  20021104 Oracle iSQL*Plus buffer overflow vulnerability (#NISR04112002)
http://marc.info/?l=bugtraq&m=103643298712284&w=2
(UNKNOWN)  BUGTRAQ  20021104 Oracle iSQL*Plus buffer overflow vulnerability (#NISR04112002)
http://technet.oracle.com/deploy/security/pdf/2002alert46rev1.pdf
(UNKNOWN)  CONFIRM  http://technet.oracle.com/deploy/security/pdf/2002alert46rev1.pdf
http://www.iss.net/security_center/static/10524.php
(VENDOR_ADVISORY)  XF  oracle-isqlplus-userid-bo(10524)
http://www.securityfocus.com/bid/6085
(UNKNOWN)  BID  6085

- 漏洞信息

Oracle 9i数据库服务器iSQL Plus畸形USERID缓冲区溢出漏洞
高危 缓冲区溢出
2002-11-12 00:00:00 2005-05-13 00:00:00
远程  
        Oracle 9版本数据库服务器Oracle iSQL*Plus web应用程序存在缓冲区溢出漏洞。远程攻击者可以借助isqlplus URL的超长USERID参数执行任意代码。

- 公告与补丁

        Oracle has released an alert for this vulnerability. Further details may be found in the referenced advisory.
        Oracle Oracle9i Standard Edition 9.0
        
        Oracle Oracle9i Standard Edition 9.0.1
        
        Oracle Oracle9i Standard Edition 9.0.1 .2
        
        Oracle Oracle9i Standard Edition 9.0.1 .3
        
        Oracle Oracle9i Standard Edition 9.0.2
        
        Oracle Oracle9i Standard Edition 9.2 .0.1
        
        Oracle Oracle9i Standard Edition 9.2 .0.2
        

- 漏洞信息

4013
Oracle iSQL*Plus isqlplus URL USERID Parameter Remote Overflow
Remote / Network Access Input Manipulation, Other
Loss of Confidentiality, Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

A remote overflow exists in Oracle Database 9i. Oracle Database 9i fails to handle an overly long user ID parameter resulting in a buffer overflow. With a specially crafted request, an attacker can cause arbitrary code to run in the security context of the web server resulting in a loss of confidentiality, integrity, and/or availability.

- 时间线

2002-10-31 2001-08-18
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Oracle has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Oracle 9i Database Server iSQL Plus Malformed USERID Buffer Overflow Vulnerability
Boundary Condition Error 6085
Yes No
2002-10-31 12:00:00 2009-07-11 06:06:00
Discovery of this vulnerability credited to David Litchfield of Next Generation Security Software.

- 受影响的程序版本

Oracle Oracle9i Standard Edition 9.2 .2
Oracle Oracle9i Standard Edition 9.2 .1
Oracle Oracle9i Standard Edition 9.2 .0.2
Oracle Oracle9i Standard Edition 9.2 .0.1
Oracle Oracle9i Standard Edition 9.0.2
Oracle Oracle9i Standard Edition 9.0.1 .3
Oracle Oracle9i Standard Edition 9.0.1 .2
Oracle Oracle9i Standard Edition 9.0.1
Oracle Oracle9i Standard Edition 9.0

- 漏洞讨论

A buffer overflow vulnerability has been reported for Oracle 9i Database Server. The vulnerability affects iSQL *Plus which is a web based interface to the Database Server.

The vulnerability is due to improper bounds checking of the USERID parameter.

An attacker can exploit this problem to overwrite sensitive stack variables, in an effort to execute arbitrary code. Code will be executed with the privileges of the underlying web server, typically the 'oracle' user or 'SYSTEM' user in Windows operating systems.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Oracle has released an alert for this vulnerability. Further details may be found in the referenced advisory.


Oracle Oracle9i Standard Edition 9.0

Oracle Oracle9i Standard Edition 9.0.1 .2

Oracle Oracle9i Standard Edition 9.0.1 .3

Oracle Oracle9i Standard Edition 9.0.1

Oracle Oracle9i Standard Edition 9.0.2

Oracle Oracle9i Standard Edition 9.2 .0.2

Oracle Oracle9i Standard Edition 9.2 .0.1

Oracle Oracle9i Standard Edition 9.2 .2

Oracle Oracle9i Standard Edition 9.2 .1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站