CVE-2002-1242
CVSS7.5
发布时间 :2002-11-12 00:00:00
修订时间 :2016-10-17 22:25:09
NMCOES    

[原文]SQL injection vulnerability in PHP-Nuke before 6.0 allows remote authenticated users to modify the database and gain privileges via the "bio" argument to modules.php.


[CNNVD]PHP-Nuke SQL插入修改任意用户信息漏洞(CNNVD-200211-025)

        PHP-Nuke是一个网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke对"bio"字段缺少正确的过滤,远程攻击者可以利用这个漏洞通过SQL注入攻击修改用户信息,包括密码。攻击者可以通过在"bio"字段插入'\',可以绕过引用,导致可以进行SQL注入,下面的操作可以修改任何PHP-NUKE用户密码为"1"。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1242
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1242
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200211-025
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/vulnwatch/2002-q4/0051.html
(UNKNOWN)  VULNWATCH  20021101 iDEFENSE Security Advisory 10.31.02c: PHP-Nuke SQL Injection Vulnerability
http://marc.info/?l=bugtraq&m=103616324103171&w=2
(UNKNOWN)  BUGTRAQ  20021101 iDEFENSE Security Advisory 10.31.02c: PHP-Nuke SQL Injection Vulnerability
http://www.idefense.com/advisory/10.31.02c.txt
(VENDOR_ADVISORY)  MISC  http://www.idefense.com/advisory/10.31.02c.txt
http://www.iss.net/security_center/static/10516.php
(UNKNOWN)  XF  phpnuke-accountmanager-sql-injection(10516)
http://www.securityfocus.com/bid/6088
(UNKNOWN)  BID  6088

- 漏洞信息

PHP-Nuke SQL插入修改任意用户信息漏洞
高危 输入验证
2002-11-12 00:00:00 2012-11-30 00:00:00
远程  
        PHP-Nuke是一个网站创建和管理工具,它可以使用很多数据库软件作为后端,比如MySQL、PostgreSQL、mSQL、Interbase、Sybase等。
        PHP-Nuke对"bio"字段缺少正确的过滤,远程攻击者可以利用这个漏洞通过SQL注入攻击修改用户信息,包括密码。攻击者可以通过在"bio"字段插入'\',可以绕过引用,导致可以进行SQL注入,下面的操作可以修改任何PHP-NUKE用户密码为"1"。

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时使用.htaccesss等访问控制授权限制对modules.php所在目录的访问。
        厂商补丁:
        Francisco Burzi
        ---------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Francisco Burzi Upgrade PHP-Nuke 6.0
        
        http://www.phpnuke.org./modules.php?name=Downloads&d_op=getit&lid=321

- 漏洞信息 (21977)

PHP-Nuke 5.6 Modules.PHP SQL Injection Vulnerability (EDBID:21977)
php webapps
2002-11-01 Verified
0 kill9
N/A [点击下载]
source: http://www.securityfocus.com/bid/6088/info

A SQL injection vulnerability has been reported for PHP-Nuke 5.6.

The vulnerability is due to insufficient sanitization of variables used to construct SQL queries in some scripts. It is possible to modify the logic of SQL queries through malformed query strings in requests for the vulnerable script.

By injecting SQL code into variables, it may be possible for an attacker to corrupt database information. 

modules.php?name=Your_Account&op=saveuser&uid=2&bio=%5c&EditedMessage=
no&pass=xxxxx&vpass=xxxxx&newsletter=,+bio=0,+pass=md5(1)/* 		

- 漏洞信息

6244
PHP-Nuke modules.php bio Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

PHP-Nuke contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the bio variable in the administrative module is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2002-10-31 Unknow
2002-10-31 Unknow

- 解决方案

Upgrade to version 6.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PHP-Nuke 5.6 Modules.PHP SQL Injection Vulnerability
Input Validation Error 6088
Yes No
2002-11-01 12:00:00 2009-07-11 06:06:00
Discovery of this vulnerability credited to kill9 (kill9@hackers.com).

- 受影响的程序版本

Francisco Burzi PHP-Nuke 5.6
Francisco Burzi PHP-Nuke 6.0

- 不受影响的程序版本

Francisco Burzi PHP-Nuke 6.0

- 漏洞讨论

A SQL injection vulnerability has been reported for PHP-Nuke 5.6.

The vulnerability is due to insufficient sanitization of variables used to construct SQL queries in some scripts. It is possible to modify the logic of SQL queries through malformed query strings in requests for the vulnerable script.

By injecting SQL code into variables, it may be possible for an attacker to corrupt database information.

- 漏洞利用

The following proof of concept was provided:

modules.php?name=Your_Account&op=saveuser&uid=2&bio=%5c&EditedMessage=
no&pass=xxxxx&vpass=xxxxx&newsletter=,+bio=0,+pass=md5(1)/*

- 解决方案

Fixes are available:


Francisco Burzi PHP-Nuke 5.6

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站