CVE-2002-1225
CVSS10.0
发布时间 :2002-10-28 00:00:00
修订时间 :2016-10-17 22:24:55
NMCOS    

[原文]Multiple buffer overflows in Heimdal before 0.5, possibly in both the (1) kadmind and (2) kdc servers, may allow remote attackers to gain root access.


[CNNVD]Heimdal Kerberos转发守护程序文件覆盖漏洞(CNNVD-200210-290)

        Heimdal 0.5之前版本可能在(1)kadmind以及(2)kdc服务器中都存在多个缓冲区溢出漏洞。远程攻击者可能获得根使用权。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:kth:heimdal:0.4d
cpe:/a:kth:heimdal:0.4a
cpe:/a:kth:heimdal:0.3e
cpe:/a:kth:heimdal:0.4c
cpe:/a:kth:heimdal:0.4e
cpe:/a:kth:heimdal:0.4b

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1225
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1225
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200210-290
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=103341355708817&w=2
(UNKNOWN)  SUSE  SuSE-SA:2002:034
http://marc.info/?l=bugtraq&m=103462479621246&w=2
(UNKNOWN)  BUGTRAQ  20021014 GLSA: heimdal
http://www.debian.org/security/2002/dsa-178
(VENDOR_ADVISORY)  DEBIAN  DSA-178
http://www.iss.net/security_center/static/10116.php
(VENDOR_ADVISORY)  XF  heimdal-kf-kfd-bo(10116)
http://www.securityfocus.com/bid/5729
(VENDOR_ADVISORY)  BID  5729

- 漏洞信息

Heimdal Kerberos转发守护程序文件覆盖漏洞
危急 缓冲区溢出
2002-10-28 00:00:00 2005-10-20 00:00:00
远程  
        Heimdal 0.5之前版本可能在(1)kadmind以及(2)kdc服务器中都存在多个缓冲区溢出漏洞。远程攻击者可能获得根使用权。

- 公告与补丁

        NetBSD has released an advisory addressing this issue. All versions of NetBSD, including NetBSD-current source prior to September 10, 2002, contain the vulnerable binary, though the service is not enabled by default. NetBSD has fixed this version vulnerability in the 1.5 version of the source, and the 1.6 branch fix is pending. NetBSD Security has advised users of 1.6 to manually remove the vulnerable binaries after completing a "make build."
        Users of Gentoo Linux are advised to upgrade using the following commands:
        emerge rsync
        emerge heimdal
        emerge clean
        Updated versions available:
        KTH Heimdal 0.3 e
        
        KTH Heimdal 0.4 d
        
        KTH Heimdal 0.4 b
        
        KTH Heimdal 0.4 c
        
        KTH Heimdal 0.4 e
        
        KTH Heimdal 0.4 a
        

- 漏洞信息

4899
Heimdal Kerberos Forwarding Daemon Arbitrary File Overwrite
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

The Heimdal Kerberos Forwarding Daemon contains a flaw that may allow a malicious user to gain access to unauthorized resources, such as accessing and overwriting files accessible via the authenticated user's id. The issue exists due to lack of protection aplied to the information sent from a client to a server. This flaw may lead to a loss of Confidentiality, Integrity and/or Availability.

- 时间线

2002-09-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Heimdal Kerberos Forwarding Daemon File Overwriting Vulnerability
Access Validation Error 5729
Yes No
2002-09-17 12:00:00 2009-07-11 05:06:00
Vulnerability announced by KTH.

- 受影响的程序版本

KTH Heimdal 0.4 e
+ FreeBSD FreeBSD 4.6 -RELEASE
+ FreeBSD FreeBSD 4.6
- FreeBSD FreeBSD 4.4
- FreeBSD FreeBSD 4.3
- FreeBSD FreeBSD 4.2
- FreeBSD FreeBSD 4.1.1
- FreeBSD FreeBSD 4.1
- FreeBSD FreeBSD 4.0
+ S.u.S.E. Linux 8.0
KTH Heimdal 0.4 d
+ S.u.S.E. Linux 7.3
KTH Heimdal 0.4 c
KTH Heimdal 0.4 b
KTH Heimdal 0.4 a
KTH Heimdal 0.3 e
+ S.u.S.E. Linux 7.2
Keware Technologies HomeSeer 0.4 e
KTH Heimdal 0.5
- Gentoo Linux 1.4 _rc1
- Gentoo Linux 1.2

- 不受影响的程序版本

KTH Heimdal 0.5
- Gentoo Linux 1.4 _rc1
- Gentoo Linux 1.2

- 漏洞讨论

The Heimdal Kerberos Forwarding Daemon does not properly protect some information sent from a client to a server. Because of this, it may be possible to overwrite files accessible via the authenticated user's id. This could result in a denial of service, or potential loss of data.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

NetBSD has released an advisory addressing this issue. All versions of NetBSD, including NetBSD-current source prior to September 10, 2002, contain the vulnerable binary, though the service is not enabled by default. NetBSD has fixed this version vulnerability in the 1.5 version of the source, and the 1.6 branch fix is pending. NetBSD Security has advised users of 1.6 to manually remove the vulnerable binaries after completing a "make build."

Users of Gentoo Linux are advised to upgrade using the following commands:

emerge rsync
emerge heimdal
emerge clean

Updated versions available:


KTH Heimdal 0.3 e

KTH Heimdal 0.4 d

Keware Technologies HomeSeer 0.4 e

KTH Heimdal 0.4 b

KTH Heimdal 0.4 c

KTH Heimdal 0.4 e

KTH Heimdal 0.4 a

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站