CVE-2002-1224
CVSS5.0
发布时间 :2002-10-28 00:00:00
修订时间 :2008-09-05 16:30:05
NMCOES    

[原文]Directory traversal vulnerability in kpf for KDE 3.0.1 through KDE 3.0.3a allows remote attackers to read arbitrary files as the kpf user via a URL with a modified icon parameter.


[CNNVD]KDE KPF Icon选项文件泄露漏洞(CNNVD-200210-283)

        KDE 3.0.1版本到KDE 3.0.3a版本的kpf存在目录遍历漏洞。远程攻击者可以借助带修改的icon参数的URL作为kpf用户读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:kde:kde:3.0.1
cpe:/o:kde:kde:3.0.3a
cpe:/o:kde:kde:3.0.2
cpe:/o:kde:kde:3.0.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1224
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1224
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200210-283
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5951
(VENDOR_ADVISORY)  BID  5951
http://www.kde.org/info/security/advisory-20021008-2.txt
(VENDOR_ADVISORY)  CONFIRM  http://www.kde.org/info/security/advisory-20021008-2.txt
http://archives.neohapsis.com/archives/bugtraq/2002-10/0164.html
(VENDOR_ADVISORY)  BUGTRAQ  20021009 KDE Security Advisory: kpf Directory traversal
http://www.iss.net/security_center/static/10347.php
(VENDOR_ADVISORY)  XF  kpf-icon-view-files(10347)
http://www.redhat.com/support/errata/RHSA-2002-220.html
(UNKNOWN)  REDHAT  RHSA-2002:220
http://online.securityfocus.com/archive/1/294991
(UNKNOWN)  BUGTRAQ  20021011 Security hole in kpf - KDE personal fileserver.

- 漏洞信息

KDE KPF Icon选项文件泄露漏洞
中危 路径遍历
2002-10-28 00:00:00 2005-05-13 00:00:00
远程  
        KDE 3.0.1版本到KDE 3.0.3a版本的kpf存在目录遍历漏洞。远程攻击者可以借助带修改的icon参数的URL作为kpf用户读取任意文件。

- 公告与补丁

        RedHat has released an advisory, RHSA-2002:220-40, that contains many fixes. Information about obtaining and applying fixes are available in the referenced advisory.
        A patch is available and the issue has been addressed in the latest KDE release:
        KDE KDE 3.0.1
        
        KDE KDE 3.0.2
        
        KDE KDE 3.0.3
        
        KDE KDE 3.0.3 a
        

- 漏洞信息 (21934)

KDE 3.0.x KPF Icon Option File Disclosure Vulnerability (EDBID:21934)
linux remote
2002-10-11 Verified
0 Ajay R Ramjatan
N/A [点击下载]
source: http://www.securityfocus.com/bid/5951/info

A vulnerability has been discovered in the kpf file sharing utility. KDE is available for the Linux operating system.

It has been reported that by passing a malicious file request to kpf, it is possible for a remote attacker to access files outside of the 'shared directory' root. The ability to read files outside of the shared root directory would be dependent upon the privileges of the kpf process. 

http://127.0.0.1:8001/?icon=/usr/local/kde/share/icons/hicolor/32x32/mimetypes/image.png 		

- 漏洞信息

8945
KDE kpf Modified Icon Parameter Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-10-11 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.0.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

KDE KPF Icon Option File Disclosure Vulnerability
Input Validation Error 5951
Yes No
2002-10-11 12:00:00 2009-07-11 06:06:00
Vulnerability announced by KDE.

- 受影响的程序版本

KDE KDE 3.0.3 a
KDE KDE 3.0.3
+ Conectiva Linux 8.0
+ Conectiva Linux 8.0
+ Conectiva Linux Enterprise Edition 1.0
+ FreeBSD FreeBSD 4.7 -STABLE
+ FreeBSD FreeBSD 4.7 -STABLE
+ Mandriva Linux Mandrake 9.0
+ Mandriva Linux Mandrake 9.0
KDE KDE 3.0.2
+ Mandriva Linux Mandrake 8.2
KDE KDE 3.0.1
KDE KDE 3.0.4
+ Conectiva Linux 8.0
+ Gentoo Linux 1.4 _rc1
+ Gentoo Linux 1.2
+ Gentoo Linux 1.2

- 不受影响的程序版本

KDE KDE 3.0.4
+ Conectiva Linux 8.0
+ Gentoo Linux 1.4 _rc1
+ Gentoo Linux 1.2
+ Gentoo Linux 1.2

- 漏洞讨论

A vulnerability has been discovered in the kpf file sharing utility. KDE is available for the Linux operating system.

It has been reported that by passing a malicious file request to kpf, it is possible for a remote attacker to access files outside of the 'shared directory' root. The ability to read files outside of the shared root directory would be dependent upon the privileges of the kpf process.

- 漏洞利用

This vulnerability may be exploited with a web browser.

The following proof of concept was supplied by Ajay R Ramjatan <simpleguy@simpleguy.com>:

http://127.0.0.1:8001/?icon=/usr/local/kde/share/icons/hicolor/32x32/mimetypes/image.png

- 解决方案

RedHat has released an advisory, RHSA-2002:220-40, that contains many fixes. Information about obtaining and applying fixes are available in the referenced advisory.

A patch is available and the issue has been addressed in the latest KDE release:


KDE KDE 3.0.1

KDE KDE 3.0.2

KDE KDE 3.0.3

KDE KDE 3.0.3 a

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站