CVE-2002-1166
CVSS7.5
发布时间 :2002-10-11 00:00:00
修订时间 :2016-10-17 22:24:18
NMCOS    

[原文]Buffer overflow in John Franks WN Server 1.18.2 through 2.0.0 allows remote attackers to execute arbitrary code via a long GET request.


[CNNVD]WN Server畸形GET请求缓冲区溢出漏洞(CNNVD-200210-262)

        John Franks WN Server 1.18.2版本到2.0.0版本存在缓冲区溢出漏洞。远程攻击者可以借助超长GET请求执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:john_franks:wn_server:1.18.4
cpe:/a:john_franks:wn_server:1.19.3
cpe:/a:john_franks:wn_server:1.18.5
cpe:/a:john_franks:wn_server:1.19.4
cpe:/a:john_franks:wn_server:2.0.0
cpe:/a:john_franks:wn_server:1.19.0
cpe:/a:john_franks:wn_server:1.18.6
cpe:/a:john_franks:wn_server:1.19.5
cpe:/a:john_franks:wn_server:1.18.7
cpe:/a:john_franks:wn_server:1.19.6
cpe:/a:john_franks:wn_server:1.19.7
cpe:/a:john_franks:wn_server:1.19.8
cpe:/a:john_franks:wn_server:1.18.2
cpe:/a:john_franks:wn_server:1.19.1
cpe:/a:john_franks:wn_server:1.18.3
cpe:/a:john_franks:wn_server:1.19.2
cpe:/a:john_franks:wn_server:1.19.9

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1166
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1166
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200210-262
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/vulnwatch/2002-q3/0138.html
(UNKNOWN)  VULNWATCH  20020930 iDEFENSE Security Advisory 09.30.2002: Buffer Overflow in WN Server
http://marc.info/?l=bugtraq&m=103340145725050&w=2
(UNKNOWN)  BUGTRAQ  20020930 iDEFENSE Security Advisory 09.30.2002: Buffer Overflow in WN Server
http://www.iss.net/security_center/static/10223.php
(VENDOR_ADVISORY)  XF  wn-server-get-bo(10223)
http://www.securityfocus.com/bid/5831
(UNKNOWN)  BID  5831

- 漏洞信息

WN Server畸形GET请求缓冲区溢出漏洞
高危 缓冲区溢出
2002-10-11 00:00:00 2005-10-20 00:00:00
远程  
        John Franks WN Server 1.18.2版本到2.0.0版本存在缓冲区溢出漏洞。远程攻击者可以借助超长GET请求执行任意代码。

- 公告与补丁

        This issue has been reportedly addressed in WN Server 2.4.4. Those affected by this vulnerability are advised to upgrade.
        WN Server WN Server 1.18.2
        
        WN Server WN Server 1.18.3
        
        WN Server WN Server 1.18.4
        
        WN Server WN Server 1.18.5
        
        WN Server WN Server 1.18.6
        
        WN Server WN Server 1.18.7
        
        WN Server WN Server 1.19 .0
        
        WN Server WN Server 1.19.1
        
        WN Server WN Server 1.19.2
        
        WN Server WN Server 1.19.3
        
        WN Server WN Server 1.19.4
        
        WN Server WN Server 1.19.5
        
        WN Server WN Server 1.19.6
        
        WN Server WN Server 1.19.7
        
        WN Server WN Server 1.19.8
        
        WN Server WN Server 1.19.9
        
        WN Server WN Server 2.0 .0
        

- 漏洞信息

9836
John Franks WN Server Long GET Request Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

A remote overflow exists in John Frank's WN Server. The application fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted GET request containing 1,600 or more characters, a remote attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2002-12-30 2002-08-22
2002-12-30 Unknow

- 解决方案

Upgrade to version 2.4.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

WN Server Malformed GET Request Buffer Overflow Vulnerability
Boundary Condition Error 5831
Yes No
2002-09-30 12:00:00 2009-07-11 05:06:00
Discovery of this issue is credited to badc0ded <badc0ded@badc0ded.com>.

- 受影响的程序版本

WN Server WN Server 2.0 .0
WN Server WN Server 1.19.9
WN Server WN Server 1.19.8
WN Server WN Server 1.19.7
WN Server WN Server 1.19.6
WN Server WN Server 1.19.5
WN Server WN Server 1.19.4
WN Server WN Server 1.19.3
WN Server WN Server 1.19.2
WN Server WN Server 1.19.1
WN Server WN Server 1.19 .0
WN Server WN Server 1.18.7
WN Server WN Server 1.18.6
WN Server WN Server 1.18.5
WN Server WN Server 1.18.4
WN Server WN Server 1.18.3
WN Server WN Server 1.18.2
WN Server WN Server 2.4.4

- 不受影响的程序版本

WN Server WN Server 2.4.4

- 漏洞讨论

WN Server is prone to a remotely exploitable buffer overflow. This is due to insufficient bounds checking of data received in HTTP GET requests. It is possible to send an overly long request to the server and cause process memory to be corrupted with attacker-supplied data.

This condition may be exploited to execute arbitrary code with the privileges of the webserver process.

This issue is reported to be present in WN Server version 1.18.2 through 2.0.0. It is possible that other versions may also be affected by this vulnerability.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

This issue has been reportedly addressed in WN Server 2.4.4. Those affected by this vulnerability are advised to upgrade.


WN Server WN Server 1.18.2

WN Server WN Server 1.18.3

WN Server WN Server 1.18.4

WN Server WN Server 1.18.5

WN Server WN Server 1.18.6

WN Server WN Server 1.18.7

WN Server WN Server 1.19 .0

WN Server WN Server 1.19.1

WN Server WN Server 1.19.2

WN Server WN Server 1.19.3

WN Server WN Server 1.19.4

WN Server WN Server 1.19.5

WN Server WN Server 1.19.6

WN Server WN Server 1.19.7

WN Server WN Server 1.19.8

WN Server WN Server 1.19.9

WN Server WN Server 2.0 .0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站