CVE-2002-1090
CVSS7.5
发布时间 :2002-10-04 00:00:00
修订时间 :2008-09-05 16:29:45
NMCOS    

[原文]Buffer overflow in read_smtp_response of protocol.c in libesmtp before 0.8.11 allows a remote SMTP server to (1) execute arbitrary code via a certain response or (2) cause a denial of service via long server responses.


[CNNVD]libesmtp read_smtp_response远程缓冲区溢出漏洞(CNNVD-200210-164)

        
        libesmtp是一款SMTP库,balsa邮件客户端使用了这个库。
        libesmtp对部分应答缺少正确缓冲区边界检查,远程攻击者可以利用这个漏洞通过构建超长服务器应答对使用libesmtp库的应用程序进行拒绝服务或执行任意指令攻击。
        目前没有详细漏洞细节。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1090
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1090
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200210-164
(官方数据源) CNNVD

- 其它链接及资源

http://www.stafford.uklinux.net/libesmtp/ChangeLog.txt
(UNKNOWN)  CONFIRM  http://www.stafford.uklinux.net/libesmtp/ChangeLog.txt

- 漏洞信息

libesmtp read_smtp_response远程缓冲区溢出漏洞
高危 边界条件错误
2002-10-04 00:00:00 2005-10-20 00:00:00
远程  
        
        libesmtp是一款SMTP库,balsa邮件客户端使用了这个库。
        libesmtp对部分应答缺少正确缓冲区边界检查,远程攻击者可以利用这个漏洞通过构建超长服务器应答对使用libesmtp库的应用程序进行拒绝服务或执行任意指令攻击。
        目前没有详细漏洞细节。
        

- 公告与补丁

        厂商补丁:
        RedHat
        ------
        RedHat已经为此发布了一个安全公告(RHSA-2003:109-03)以及相应补丁:
        RHSA-2003:109-03:Updated balsa and mutt packages fix vulnerabilities
        链接:https://www.redhat.com/support/errata/RHSA-2003-109.html
        补丁下载:
        Red Hat Linux 7.2:
        SRPMS:
        ftp://updates.redhat.com/7.2/en/os/SRPMS/balsa-1.2.4-7.7.2.src.rpm
        ftp://updates.redhat.com/7.2/en/os/SRPMS/libesmtp-0.8.12-0.7.x.src.rpm
        i386:
        ftp://updates.redhat.com/7.2/en/os/i386/balsa-1.2.4-7.7.2.i386.rpm
        ftp://updates.redhat.com/7.2/en/os/i386/libesmtp-0.8.12-0.7.x.i386.rpm
        ftp://updates.redhat.com/7.2/en/os/i386/libesmtp-devel-0.8.12-0.7.x.i386.rpm
        ia64:
        ftp://updates.redhat.com/7.2/en/os/ia64/balsa-1.2.4-7.7.2.ia64.rpm
        ftp://updates.redhat.com/7.2/en/os/ia64/libesmtp-0.8.12-0.7.x.ia64.rpm
        ftp://updates.redhat.com/7.2/en/os/ia64/libesmtp-devel-0.8.12-0.7.x.ia64.rpm
        Red Hat Linux 7.3:
        SRPMS:
        ftp://updates.redhat.com/7.3/en/os/SRPMS/balsa-1.2.4-7.7.3.src.rpm
        ftp://updates.redhat.com/7.3/en/os/SRPMS/libesmtp-0.8.12-0.7.x.src.rpm
        i386:
        ftp://updates.redhat.com/7.3/en/os/i386/balsa-1.2.4-7.7.3.i386.rpm
        ftp://updates.redhat.com/7.3/en/os/i386/libesmtp-0.8.12-0.7.x.i386.rpm
        ftp://updates.redhat.com/7.3/en/os/i386/libesmtp-devel-0.8.12-0.7.x.i386.rpm
        Red Hat Linux 8.0:
        SRPMS:
        ftp://updates.redhat.com/8.0/en/os/SRPMS/mutt-1.4.1-0.8.x.src.rpm
        ftp://updates.redhat.com/8.0/en/os/SRPMS/balsa-1.2.4-8.src.rpm
        i386:
        ftp://updates.redhat.com/8.0/en/os/i386/mutt-1.4.1-0.8.x.i386.rpm
        ftp://updates.redhat.com/8.0/en/os/i386/balsa-1.2.4-8.i386.rpm
        Red Hat Linux 9:
        SRPMS:
        ftp://updates.redhat.com/9/en/os/SRPMS/mutt-1.4.1-1.src.rpm
        ftp://updates.redhat.com/9/en/os/SRPMS/balsa-2.0.6-2.src.rpm
        i386:
        ftp://updates.redhat.com/9/en/os/i386/mutt-1.4.1-1.i386.rpm
        ftp://updates.redhat.com/9/en/os/i386/balsa-2.0.6-2.i386.rpm
        可使用下列命令安装补丁:
        rpm -Fvh [文件名]

- 漏洞信息

14489
libESMTP SMTP Response read_smtp_response Function Overflow
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-03-06 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.8.11 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

libesmtp read_smtp_response Buffer Overflow Vulnerability
Boundary Condition Error 7269
Yes No
2003-04-03 12:00:00 2009-07-11 09:06:00
This vulnerability was reported in the product changelog.

- 受影响的程序版本

RedHat Linux Advanced Work Station 2.1
RedHat Enterprise Linux WS 2.1
RedHat Enterprise Linux ES 2.1
Red Hat Enterprise Linux AS 2.1
libesmtp libesmtp 0.8.10 p1
libesmtp libesmtp 0.8.10
libesmtp libesmtp 0.8.9
libesmtp libesmtp 0.8.4
+ RedHat Linux 7.3 i686
+ RedHat Linux 7.3 i386
+ RedHat Linux 7.3
+ RedHat Linux 7.2 ia64
+ RedHat Linux 7.2 i686
+ RedHat Linux 7.2 i586
+ RedHat Linux 7.2 i386
+ RedHat Linux 7.2
+ Sun Linux 5.0
GNOME Balsa 2.0.6
+ RedHat Linux 9.0 i386
GNOME Balsa 1.2.4
+ Conectiva Linux 8.0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ RedHat Linux 8.0 i686
+ RedHat Linux 8.0 i386
+ RedHat Linux 8.0
+ RedHat Linux 7.3 i686
+ RedHat Linux 7.3 i386
+ RedHat Linux 7.3
+ Sun Linux 5.0
GNOME Balsa 1.1.7
+ RedHat Linux 7.2 i686
+ RedHat Linux 7.2 i586
+ RedHat Linux 7.2 i386
+ RedHat Linux 7.2 athlon
+ RedHat Linux 7.2
libesmtp libesmtp 1.0
libesmtp libesmtp 0.8.12
libesmtp libesmtp 0.8.11
GNOME Balsa 2.0.10
GNOME Balsa 1.4.3
GNOME Balsa 1.4

- 不受影响的程序版本

libesmtp libesmtp 1.0
libesmtp libesmtp 0.8.12
libesmtp libesmtp 0.8.11
GNOME Balsa 2.0.10
GNOME Balsa 1.4.3
GNOME Balsa 1.4

- 漏洞讨论

A buffer overflow vulnerability has been reported in libesmtp that may allow an attacker to execute code.

An attacker can exploit this vulnerability by enticing a victim user to connect to an attacker-controlled SMTP server and sending a specially crafted response.

Successful exploitation of this vulnerability will result in the execution of attacker-supplied code.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Red Hat Linux has released an advisory (RHSA-2003:109-03). Information about obtaining and applying fixes are available in the referenced advisory.

Conectiva has released a security advisory (CLA-2003:630) containg fixes which address this issue.

Red Hat has also released an advisory (RHSA-2003:111-08) which contains upgrade details for Enterprise distributions, which are available through the Red Hat Network.


libesmtp libesmtp 0.8.10

libesmtp libesmtp 0.8.10 p1

libesmtp libesmtp 0.8.4

libesmtp libesmtp 0.8.9

GNOME Balsa 1.1.7

GNOME Balsa 1.2.4

GNOME Balsa 2.0.6

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站