CVE-2002-1050
CVSS7.5
发布时间 :2002-10-04 00:00:00
修订时间 :2008-09-05 16:29:38
NMCO    

[原文]Buffer overflow in HylaFAX faxgetty before 4.1.3 allows remote attackers to cause a denial of service, and possibly execute arbitrary code, via a long line of image data.


[CNNVD]Hylafax超长扫描行远程缓冲区溢出漏洞(CNNVD-200210-205)

        
        Hylafax是一款设计用于处理传真通信的软件。
        Hylafax在处理图形数据的超长行时没有进行正确的边界缓冲区边界检查,远程攻击者可以利用此漏洞进行缓冲区溢出攻击。
        Hylafax在接收到图形数据的超长行时,由于缓冲区溢出,而导致faxgetty产生段错误,使Hylafax产生拒绝服务,由于faxgetty一般以root权限运行,攻击者可以精心构建图形数据发送给faxgetty处理可能以root用户的权限在系统中执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:hylafax:hylafax:4.1.2
cpe:/a:hylafax:hylafax:4.0_pl2
cpe:/a:hylafax:hylafax:4.0_pl1
cpe:/a:hylafax:hylafax:4.0_pl0
cpe:/a:hylafax:hylafax:4.1.1
cpe:/a:hylafax:hylafax:4.1_beta2
cpe:/a:hylafax:hylafax:4.0.2
cpe:/a:hylafax:hylafax:4.1_beta3
cpe:/a:hylafax:hylafax:4.1_beta1
cpe:/a:hylafax:hylafax:4.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1050
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1050
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200210-205
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5349
(VENDOR_ADVISORY)  BID  5349
http://www.iss.net/security_center/static/9729.php
(VENDOR_ADVISORY)  XF  hylafax-faxgetty-image-bo(9729)
http://www.debian.org/security/2002/dsa-148
(VENDOR_ADVISORY)  DEBIAN  DSA-148
http://bugs.hylafax.org/bugzilla/show_bug.cgi?id=312
(UNKNOWN)  CONFIRM  http://bugs.hylafax.org/bugzilla/show_bug.cgi?id=312
http://www.novell.com/linux/security/advisories/2002_035_hylafax.html
(UNKNOWN)  SUSE  SuSE-SA:2002:035
http://www.mandrakesoft.com/security/advisories?name=MDKSA-2002:055
(UNKNOWN)  MANDRAKE  MDKSA-2002:055
http://archives.neohapsis.com/archives/bugtraq/2002-07/0358.html
(UNKNOWN)  BUGTRAQ  20020729 HylaFAX - Various Vulnerabilities Fixed

- 漏洞信息

Hylafax超长扫描行远程缓冲区溢出漏洞
高危 未知
2002-10-04 00:00:00 2005-05-02 00:00:00
远程  
        
        Hylafax是一款设计用于处理传真通信的软件。
        Hylafax在处理图形数据的超长行时没有进行正确的边界缓冲区边界检查,远程攻击者可以利用此漏洞进行缓冲区溢出攻击。
        Hylafax在接收到图形数据的超长行时,由于缓冲区溢出,而导致faxgetty产生段错误,使Hylafax产生拒绝服务,由于faxgetty一般以root权限运行,攻击者可以精心构建图形数据发送给faxgetty处理可能以root用户的权限在系统中执行任意指令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时没有合适的临时解决方法。
        厂商补丁:
        Hylafax
        -------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Hylafax Upgrade hylafax-4.1.3.tar.gz
        ftp://ftp.hylafax.org/source/hylafax-4.1.3.tar.gz

- 漏洞信息

4630
HylaFAX faxgetty Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-10-07 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站