CVE-2002-1035
CVSS5.0
发布时间 :2002-10-04 00:00:00
修订时间 :2008-09-05 16:29:36
NMCO    

[原文]Omnicron OmniHTTPd 2.09 allows remote attackers to cause a denial of service (crash) via an HTTP request with a long, malformed HTTP 1version number.


[CNNVD]OmniHTTPD超长HEAD请求远程缓冲区溢出漏洞(CNNVD-200210-143)

        
        OmniHTTPd是一款小型的WEB服务程序。
        OmniHTTPd在处理超长HTTP HEAD信息请求时存在问题,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击。
        攻击者可以发送使用包含4096或者更多字节的字符串代替HTTP版本的HEAD畸形请求,可导致HTTPD崩溃。精心提交HTTP协议字段的字符串数据HEAD请求可导致可能以OmniHTTPd进程的权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1035
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1035
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200210-143
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5136
(VENDOR_ADVISORY)  BID  5136
http://www.iss.net/security_center/static/9457.php
(VENDOR_ADVISORY)  XF  omnihttpd-http-version-bo(9457)
http://www.osvdb.org/5000
(UNKNOWN)  OSVDB  5000
http://online.securityfocus.com/archive/1/280132
(UNKNOWN)  BUGTRAQ  20020701 BufferOverflow in OmniHTTPd 2.09

- 漏洞信息

OmniHTTPD超长HEAD请求远程缓冲区溢出漏洞
中危 未知
2002-10-04 00:00:00 2005-05-02 00:00:00
远程  
        
        OmniHTTPd是一款小型的WEB服务程序。
        OmniHTTPd在处理超长HTTP HEAD信息请求时存在问题,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击。
        攻击者可以发送使用包含4096或者更多字节的字符串代替HTTP版本的HEAD畸形请求,可导致HTTPD崩溃。精心提交HTTP协议字段的字符串数据HEAD请求可导致可能以OmniHTTPd进程的权限在系统上执行任意指令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时没有合适的临时解决方法。
        厂商补丁:
        Omnicron
        --------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.omnicron.ca

- 漏洞信息

5000
OmniHTTPd HTTP Version Overflow DoS
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Public Vendor Verified

- 漏洞描述

Omnicron OmniHTTPd contains a flaw that may allow a remote denial of service. The issue is triggered when a malformed HTTP request containing a version with 4096 or more characters will result in loss of availability for the service. This can be used with GET, POST, HEAD and other types of requests.

- 时间线

2002-07-01 2002-07-01
2002-07-01 Unknow

- 解决方案

Upgrade to version 2.10 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站