CVE-2002-1027
CVSS7.5
发布时间 :2002-10-04 00:00:00
修订时间 :2008-09-05 16:29:35
NMCOES    

[原文]Cross-site scripting vulnerability in the default HTTP 500 error script (500error.jsp) for Macromedia Sitespring 1.2.0 (277.1) allows remote attackers to execute arbitrary web script via a link to 500error.jsp with the script in 1the et parameter.


[CNNVD]Macromedia Sitespring默认出错页面跨站脚本漏洞(CNNVD-200210-226)

        Macromedia Sitespring 1.2.0 (277.1)版本的默认HTTP 500出错脚本(500error.jsp)存在跨站脚本漏洞。远程攻击者可以借助et参数中带脚本的500error.jsp的连接执行任意web脚本。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1027
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-1027
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200210-226
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5249
(VENDOR_ADVISORY)  BID  5249
http://www.iss.net/security_center/static/9588.php
(VENDOR_ADVISORY)  XF  sitespring-500error-xss(9588)
http://online.securityfocus.com/archive/1/282742
(UNKNOWN)  BUGTRAQ  20020717 KPMG-2002032: Macromedia Sitespring Cross Site Scripting
http://archives.neohapsis.com/archives/vulnwatch/2002-q3/0029.html
(UNKNOWN)  VULNWATCH  20020717 [VulnWatch] KPMG-2002032: Macromedia Sitespring Cross Site Scripting

- 漏洞信息

Macromedia Sitespring默认出错页面跨站脚本漏洞
高危 跨站脚本
2002-10-04 00:00:00 2005-10-20 00:00:00
远程  
        Macromedia Sitespring 1.2.0 (277.1)版本的默认HTTP 500出错脚本(500error.jsp)存在跨站脚本漏洞。远程攻击者可以借助et参数中带脚本的500error.jsp的连接执行任意web脚本。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.commailto:vuldb@securityfocus.com.

- 漏洞信息 (21621)

Macromedia Sitespring 1.2 Default Error Page Cross Site Scripting Vulnerability (EDBID:21621)
jsp webapps
2002-07-17 Verified
0 Peter Gründl
N/A [点击下载]
source: http://www.securityfocus.com/bid/5249/info

Macromedia Sitespring is a J2EE-compliant product for managing website production. The Macromedia Sitespring server runs on Microsoft Windows operating systems.

A cross-site scripting issue has been reported in the default error page used by Sitespring. When an HTTP 500 error is returned, some user-supplied data is included in the generated HTML. Since this data isn't properly sanitized, an attacker may be able to include arbitrary HTML, including JavaScript. 

http://server/error/500error.jsp?et=1<script>alert('KPMG')</script> 		

- 漏洞信息

9231
Macromedia Sitespring 500error.jsp et Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown
Exploit Public

- 漏洞描述

Macromedia Sitespring contains a flaw that allows a remote cross site scripting (XSS) attack. This flaw exists because the application does not validate the 'et' parameter upon submission to the '500error.jsp' script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2002-07-17 Unknow
2002-07-17 Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Macromedia Sitespring Default Error Page Cross Site Scripting Vulnerability
Input Validation Error 5249
Yes No
2002-07-17 12:00:00 2006-11-06 08:42:00
Discovered by Peter Gründl <pgrundl@kpmg.dk>.

- 受影响的程序版本

Macromedia Sitespring 1.2 .0

- 漏洞讨论

Macromedia Sitespring is a J2EE-compliant product for managing website production. The Macromedia Sitespring server runs on Microsoft Windows operating systems.

A cross-site scripting issue has been reported in the default error page used by Sitespring. When an HTTP 500 error is returned, some user-supplied data is included in the generated HTML. Since this data isn't properly sanitized, an attacker may be able to include arbitrary HTML, including JavaScript.

- 漏洞利用

No exploit is required. The following example has been provided by Peter Gründl <pgrundl@kpmg.dk>:

http://server/error/500error.jsp?et=1<script>alert('KPMG')</script>

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.commailto:vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站