CVE-2002-0983
CVSS5.0
发布时间 :2002-09-24 00:00:00
修订时间 :2008-09-05 16:29:27
NMCOS    

[原文]IRC client irssi in irssi-text before 0.8.4 allows remote attackers to cause a denial of service (crash) via an IRC channel that has a long topic followed by a certain string, possibly triggering a buffer overflow.


[CNNVD]IRSSI超长畸形主题服务拒绝漏洞(CNNVD-200209-059)

        irssi-text 0.8.4之前版本的IRC client irssi存在漏洞。远程攻击者借助有紧跟着某些字符串的超长主题的IRC通道导致服务拒绝(崩溃),该漏洞可能触发缓冲区溢出。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0983
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0983
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200209-059
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/5055
(VENDOR_ADVISORY)  BID  5055
http://www.debian.org/security/2002/dsa-157
(VENDOR_ADVISORY)  DEBIAN  DSA-157
http://xforce.iss.net/xforce/xfdb/9395
(UNKNOWN)  XF  irssi-long-topic-dos(9395)
ftp://ftp.freebsd.org/pub/FreeBSD/CERT/advisories/FreeBSD-SN-02%3A05.asc
(UNKNOWN)  FREEBSD  FreeBSD-SN-02:05

- 漏洞信息

IRSSI超长畸形主题服务拒绝漏洞
中危 缓冲区溢出
2002-09-24 00:00:00 2005-10-20 00:00:00
远程  
        irssi-text 0.8.4之前版本的IRC client irssi存在漏洞。远程攻击者借助有紧跟着某些字符串的超长主题的IRC通道导致服务拒绝(崩溃),该漏洞可能触发缓冲区溢出。

- 公告与补丁

        This issue does not appear to be present in versions earlier than 0.8.4. It has also been reported that only the text version of the client is affected, and irssi-gnome and irssi-gtk are unaffected.
        FreeBSD has released a Security Notice FreeBSD-SN-02:05. Users of FreeBSD
        systems are strongly urged to upgrade their ports tree to fix various
        reported issues. Further information can be found in the referenced
        Security Notice.
        Fixes are available:
        irssi irssi 0.8.4
        

- 漏洞信息

11814
irssi Channel Topic Overflow Remote DoS
Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability

- 漏洞描述

- 时间线

2002-06-19 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

IRSSI Long Malformed Topic Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 5055
Yes No
2002-06-19 12:00:00 2009-07-11 01:56:00
Credited to Ripe <ripe@7a69ezine.org>.

- 受影响的程序版本

irssi irssi 0.8.4
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 IA-32
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- Mandriva Linux Mandrake 8.2
- Mandriva Linux Mandrake 8.1 ia64
- Mandriva Linux Mandrake 8.1
- Mandriva Linux Mandrake 8.0 ppc
- Mandriva Linux Mandrake 8.0
- RedHat Linux 7.3 i386
- RedHat Linux 7.2 ia64
- RedHat Linux 7.2 i386
- RedHat Linux 7.1 i386
- S.u.S.E. Linux 8.0 i386
- S.u.S.E. Linux 7.3 i386
- S.u.S.E. Linux 7.2 i386

- 漏洞讨论

irssi is prone to a denial of service condition when a user joins a channel with a long, malformed topic. The vulnerability occurs when a user attempts to join a channel that has an overly long topic description. When a certain string is appended to the topic, irssi will crash resulting in a denial of service.

An attacker can cause irssi clients to crash by changing the topic of a channel while users are still online or by enticing users to join channels with malformed topic descriptions.

- 漏洞利用

There is no exploit code required.

An attacker only has to append the string, "\x1b\x5b\x30\x6d\x0d\x0a", to an overly long topic description to cause irssi clients to crash.

- 解决方案

This issue does not appear to be present in versions earlier than 0.8.4. It has also been reported that only the text version of the client is affected, and irssi-gnome and irssi-gtk are unaffected.

FreeBSD has released a Security Notice FreeBSD-SN-02:05. Users of FreeBSD
systems are strongly urged to upgrade their ports tree to fix various
reported issues. Further information can be found in the referenced
Security Notice.

Fixes are available:


irssi irssi 0.8.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站