发布时间 :2002-10-04 00:00:00
修订时间 :2008-09-05 16:29:24

[原文]SQL injection vulnerability in comment.php for GeekLog 1.3.5 and earlier allows remote attackers to obtain sensitive user information via the pid parameter.

[CNNVD]Geeklog pid CGI变量SQL注入漏洞(CNNVD-200210-022)

        GeekLog 1.3.5及其之前版本的comment.php存在SQL注入漏洞。远程攻击者可以借助pid参数获取用户敏感信息。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  geeklog-sql-injection(9311)
(UNKNOWN)  BUGTRAQ  20020610 [ARL02-A13] Multiple Security Issues in GeekLog

- 漏洞信息

Geeklog pid CGI变量SQL注入漏洞
中危 SQL注入
2002-10-04 00:00:00 2005-10-20 00:00:00
        GeekLog 1.3.5及其之前版本的comment.php存在SQL注入漏洞。远程攻击者可以借助pid参数获取用户敏感信息。

- 公告与补丁

        This issue has been addressed in Geeklog 1.3.5 sr1:
        Geeklog Geeklog 1.3.5

- 漏洞信息

Geeklog comment.php pid Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

GeekLog contains a flaw that will allow a remote attacker to inject arbitrary SQL code. The problem is that the 'pid' variable in the 'comment.php' script is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2002-08-16 2002-05-31
2002-08-16 Unknow

- 解决方案

Upgrade to version 1.3.5sr1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Geeklog pid CGI Variable SQL Injection Vulnerability
Input Validation Error 4968
Yes No
2002-06-10 12:00:00 2009-07-11 01:56:00
Discovered by Ahmet Sabri ALPER <>

- 受影响的程序版本

Geeklog Geeklog 1.3.5
Geeklog Geeklog 1.3.5 sr1

- 不受影响的程序版本

Geeklog Geeklog 1.3.5 sr1

- 漏洞讨论

Geeklog does not properly validate externally-supplied input used in SQL queries. As a result, attackers may be able to modify SQL queries performed by the application by including special characters and additional SQL commands in supplied input.

Exploitation of this vulnerability may result in data corruption, disclosure of sensitive information and intrusion into the database server.

This issue has been reported in version 1.3.5, earlier versions may be susceptible to this issue as well.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: &lt;;.

- 解决方案

This issue has been addressed in Geeklog 1.3.5 sr1:

Geeklog Geeklog 1.3.5

- 相关参考