CVE-2002-0917
CVSS7.5
发布时间 :2002-10-04 00:00:00
修订时间 :2008-09-05 16:29:17
NMCOS    

[原文]CGIScript.net csPassword.cgi stores .htpasswd files under the web document root, which could allow remote authenticated users to download the file and crack the passwords of other users.


[CNNVD]CGIScript.net csPassword.CGI htpasswd文件泄露漏洞(CNNVD-200210-033)

        
        CGIScript.net是由Mike Barone和Andy Angrick维护的WEB管理员相关的工具。
        CGIScript.net中的csPassword.cgi脚本存在漏洞,可导致远程攻击者访问脚本产生的.htpasswd文件。
        由于.htpasswd文件生成在同.htaccess文件相同的文件夹中,可导致拥有保护目录访问密码的用户下载.htpasswd文件,造成敏感信息泄露。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0917
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0917
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200210-033
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4885
(VENDOR_ADVISORY)  BID  4885
http://www.iss.net/security_center/static/9220.php
(VENDOR_ADVISORY)  XF  cgiscript-cspassword-htpasswd-access(9220)
http://online.securityfocus.com/archive/1/274727
(UNKNOWN)  BUGTRAQ  20020529 CGIscript.net - csPassword.cgi - Multiple Vulnerabilities

- 漏洞信息

CGIScript.net csPassword.CGI htpasswd文件泄露漏洞
高危 访问验证错误
2002-10-04 00:00:00 2005-10-20 00:00:00
远程  
        
        CGIScript.net是由Mike Barone和Andy Angrick维护的WEB管理员相关的工具。
        CGIScript.net中的csPassword.cgi脚本存在漏洞,可导致远程攻击者访问脚本产生的.htpasswd文件。
        由于.htpasswd文件生成在同.htaccess文件相同的文件夹中,可导致拥有保护目录访问密码的用户下载.htpasswd文件,造成敏感信息泄露。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 对csPassword.CGI所在目录实行访问控制,只允许可信用户访问。
        厂商补丁:
        CGISCRIPT.NET
        -------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.cgiscript.net

- 漏洞信息

14498
CGIScript.net csPassword.cgi .htpasswd File Disclosure

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-05-29 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

CGIScript.net csPassword.CGI HTPasswd File Disclosure Vulnerability
Access Validation Error 4885
Yes No
2002-05-30 12:00:00 2009-07-11 01:56:00
Credited to Steve Gustin <stegus1@yahoo.com>.

- 受影响的程序版本

CGISCRIPT.NET csPassword 1.0

- 漏洞讨论

CGIScript.net provides various webmaster related tools and is maintained by Mike Barone and Andy Angrick.

A vulnerability has been reported in the csPassword.cgi script developed by CGIScript.net. It is possible for a user to obtain access to the .htpasswd file generated by the script.

- 漏洞利用

There is no exploit code required.

- 解决方案

The vendor is aware of this problem; users are advised to contact the vendor for patch information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站