CVE-2002-0910
CVSS7.5
发布时间 :2002-10-04 00:00:00
修订时间 :2008-09-05 16:29:16
NMCOS    

[原文]Buffer overflows in netstd 3.07-17 package allows remote DNS servers to execute arbitrary code via a long FQDN reply, as observed in the utilities (1) linux-ftpd, (2) pcnfsd, (3) tftp, (4) traceroute, or (5) from/to.


[CNNVD]Debian GNU/Linux netstd工具包多个程序远程缓冲区溢出漏洞(CNNVD-200210-229)

        
        netstd工具包集合Debian GNU/Linux系统下一套网络工具和守护程序。
        netstd工具包中多个工具存在缓冲区溢出,可导致远程攻击者以运行工具的进程在目标系统上执行任意命令。
        netstd工具包中的下列程序存在漏洞:
        - linux-ftpd
        - pcnfsd
        - tftp
        - traceroute
        - from/to
        这些程序在处理解析主机名操作时,直接把回复得到的FQDN值拷贝到固定的缓冲区中,攻击者可以伪造DNS服务器信息,精心构建FQDN值可导致以运行工具的进程的权限在目标系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0910
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0910
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200210-229
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4816
(VENDOR_ADVISORY)  BID  4816
http://www.iss.net/security_center/static/9164.php
(VENDOR_ADVISORY)  XF  netstd-utilities-bo(9164)
http://online.securityfocus.com/archive/1/274143
(UNKNOWN)  BUGTRAQ  20020525 Re: Netstd 3.07-17 multiple remote buffer overflows
http://online.securityfocus.com/archive/1/273987
(UNKNOWN)  BUGTRAQ  20020524 Netstd 3.07-17 multiple remote buffer overflows

- 漏洞信息

Debian GNU/Linux netstd工具包多个程序远程缓冲区溢出漏洞
高危 边界条件错误
2002-10-04 00:00:00 2005-10-20 00:00:00
远程  
        
        netstd工具包集合Debian GNU/Linux系统下一套网络工具和守护程序。
        netstd工具包中多个工具存在缓冲区溢出,可导致远程攻击者以运行工具的进程在目标系统上执行任意命令。
        netstd工具包中的下列程序存在漏洞:
        - linux-ftpd
        - pcnfsd
        - tftp
        - traceroute
        - from/to
        这些程序在处理解析主机名操作时,直接把回复得到的FQDN值拷贝到固定的缓冲区中,攻击者可以伪造DNS服务器信息,精心构建FQDN值可导致以运行工具的进程的权限在目标系统上执行任意指令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 建议删除netstd 3.07-17工具包。
        厂商补丁:
        Debian
        ------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.debian.org/security/

- 漏洞信息

14450
netstd linux-ftpd Long FQDN Reply Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-05-22 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Debian GNU/Linux netstd Multiple Buffer Overflow Vulnerabilities
Boundary Condition Error 4816
Yes No
2002-05-24 12:00:00 2009-07-11 12:46:00
Credited to Spybreak <spybreak@host.sk>.

- 受影响的程序版本

Debian netstd 3.0 7
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 IA-32
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
+ Debian Linux 2.1
+ Debian Linux 2.0
+ Debian Linux 1.3.1

- 漏洞讨论

The netstd package, included with the Debian GNU/Linux distribution, is a collection of networking utilities and daemons. Reportedly, version 3.07 of netstd is vulnerable to a buffer overflow attack. The vulnerability affects multiple utilities included with netstd. The affected utilities are:

- linux-ftpd
- pcnfsd
- tftp
- traceroute
- from/to

The condition is believed to be related to handling of resolved hostnames.

Versions of Debian post-2.2 release do not include this program as a binary package. This program is however distributed as source code through the source tree. Versions pre-2.2 may have to binary package installed.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Debian versions later than 2.2 do not include this package as a binary. However, the source code for this package is available through the 2.2 source tree. Systems that have installed this package from source are advised to disable all vulnerable services.

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站