CVE-2002-0889
CVSS4.6
发布时间 :2002-10-04 00:00:00
修订时间 :2016-10-17 22:22:54
NMCO    

[原文]Buffer overflow in Qpopper (popper) 4.0.4 and earlier allows local users to cause a denial of service and possibly execute arbitrary code via a long bulldir argument in the user's .qpopper-options configuration file.


[CNNVD]Qualcomm QPopper公告名本地缓冲区溢出漏洞(CNNVD-200210-197)

        
        QPopper是一款由Qualcomm开发和维护免费开放源代码的软件,可使用在多种Linux和Unix操作系统下。
        QPopper没有对某些数据进行充分正确的边界检查,可导致本地攻击者以Qpoper进程的权限在系统上执行任意命令。
        攻击者可以在QPopper配置文件(.qpopper-options)中提供超过256字节的字符作为公告名,当Qpoper执行时,可导致进程内存被覆盖,包括堆栈中的返回地址,精心构造字符串数据可以使本地攻击者以Qpoper进程权限执行任意代码。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:qualcomm:qpopper:4.0.3
cpe:/a:qualcomm:qpopper:4.0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0889
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0889
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200210-197
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=vuln-dev&m=102003707432457&w=2
(UNKNOWN)  VULN-DEV  20020428 QPopper 4.0.4 buffer overflow
http://online.securityfocus.com/archive/1/269969
(UNKNOWN)  BUGTRAQ  20020428 QPopper 4.0.4 buffer overflow
http://www.iss.net/security_center/static/8949.php
(VENDOR_ADVISORY)  XF  qpopper-bulldir-bo(8949)
http://www.securityfocus.com/bid/4614
(VENDOR_ADVISORY)  BID  4614

- 漏洞信息

Qualcomm QPopper公告名本地缓冲区溢出漏洞
中危 未知
2002-10-04 00:00:00 2005-05-02 00:00:00
本地  
        
        QPopper是一款由Qualcomm开发和维护免费开放源代码的软件,可使用在多种Linux和Unix操作系统下。
        QPopper没有对某些数据进行充分正确的边界检查,可导致本地攻击者以Qpoper进程的权限在系统上执行任意命令。
        攻击者可以在QPopper配置文件(.qpopper-options)中提供超过256字节的字符作为公告名,当Qpoper执行时,可导致进程内存被覆盖,包括堆栈中的返回地址,精心构造字符串数据可以使本地攻击者以Qpoper进程权限执行任意代码。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在运行Qpoper的时候不使用-u参数。
        厂商补丁:
        Qualcomm
        --------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.qpopper.com/qpopper/

- 漏洞信息

5058
Qpopper .qpopper-options bulldir Variable Local Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-04-08 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站