CVE-2002-0844
CVSS4.6
发布时间 :2002-08-12 00:00:00
修订时间 :2016-10-17 22:22:32
NMCOS    

[原文]Off-by-one overflow in the CVS PreservePermissions of rcs.c for CVSD before 1.11.2 allows local users to execute arbitrary code.


[CNNVD]CVS Daemon RCS本地单字节缓冲区溢出漏洞(CNNVD-200208-120)

        
        CVS是一款免费开放源代码的版本控制系统,可使用在多种Linux和Unix操作系统下,也可以运行于Microsoft Windows操作系统。
        CVS中的rcs.c代码中对缓冲区边界缺少正确充分的检查,可导致本地攻击者以cvs进程的权限在系统中执行任意代码。
        cvs-1.11/src/rcs.c代码中的sscanf()实现存在典型的单字节缓冲区溢出漏洞,攻击者可以利用堆栈中的帧指针覆盖而以cvs进程的权限执行任意代码,由于info->data的数据由本地符号连接文件中获得,所以此漏洞只能本地进行利用。
        问题代码如下所示:
        cvs-1.11/src/rcs.c:
        info = findnode (vers->other_delta, "special");
         if (info != NULL)
         {
         /* If the size of `devtype' changes, fix the sscanf call also */
         char devtype[16]; <-- 16字节
         if (sscanf (info->data, "%16s %lu", <-- 应该为15,为不是16,导致单字节缓冲溢出
         devtype, &devnum_long) < 2)
         error (1, 0, "厂商补丁:
        Caldera
        -------
        Caldera已经为此发布了一个安全公告(CSSA-2002-035.0)以及相应补丁:
        CSSA-2002-035.0:Linux: local off by one in cvsd
        链接:
        http://www.caldera.com/support/security/advisories/CSSA-2002-035.0.txt

        补丁下载:
        . OpenLinux 3.1.1 Server
         软件包下载地址:
         ftp://ftp.caldera.com/pub/updates/OpenLinux/3.1.1/Server/CSSA-2002-035.0/RPMS
         软件包:
         446921ba85f2f865d698060ab344d189 cvs-1.11-8.i386.rpm
         11ddbffdbf9310b24364b2b91d851acc cvs-doc-ps-1.11-8.i386.rpm
         安装方法:
         rpm -Fvh cvs-1.11-8.i386.rpm
         rpm -Fvh cvs-doc-ps-1.11-8.i386.rpm
        . OpenLinux 3.1.1 Workstation
         软件包下载地址:
         ftp://ftp.caldera.com/pub/updates/OpenLinux/3.1.1/Workstation/CSSA-2002-035.0/RPMS
         软件包:
         d24451d87b1c7424f12bb41d4873c3df cvs-1.11-8.i386.rpm
         035d93df5ab69f025f7d08a583977658 cvs-doc-ps-1.11-8.i386.rpm
         安装方法:
         rpm -Fvh cvs-1.11-8.i386.rpm
         rpm -Fvh cvs-doc-ps-1.11-8.i386.rpm
        . OpenLinux 3.1 Server
         软件包下载地址:
         ftp://ftp.caldera.com/pub/updates/OpenLinux/3.1/Server/CSSA-2002-035.0/RPMS
         软件包:
         1f3a09e4fcc1a8a0d011a6e7fcd0d810 cvs-1.11-8.i386.rpm
         ff3e5b2acdd60e4b0492b212603a0d23 cvs-doc-ps-1.11-8.i386.rpm
         安装方法:
         rpm -Fvh cvs-1.11-8.i386.rpm
         rpm -Fvh cvs-doc-ps-1.11-8.i386.rpm
        . OpenLinux 3.1 Workstation
         软件包下载地址:
         ftp://ftp.caldera.com/pub/updates/OpenLinux/3.1/Workstation/CSSA-2002-035.0/RPMS
         软件包:
         cf5125e9586da6217df51051f66eb8d6 cvs-1.11-8.i386.rpm
         4bce0b96a28195c75878515b6a37777d cvs-doc-ps-1.11-8.i386.rpm
         安装方法:
         rpm -Fvh cvs-1.11-8.i386.rpm
         rpm -Fvh cvs-doc-ps-1.11-8.i386.rpm
        CVS
        ---
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        CVS Upgrade cvs-1.11.2.tar.gz
        
        http://ccvs.cvshome.org/servlets/ProjectDownloadList?action=download&dlID=115
: has bad `special' newphrase ",
         workfile, vers->version, info->data);
         devnum = devnum_long;
         if (STREQ (devtype, "character"))
         special_file = S_IFCHR;
         else if (STREQ (devtype, "block"))
         special_file = S_IFBLK;
         else
         error (0, 0, " is a special file of unsupported type `'",
         workfile, info->data);
         }
         }
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:11478Off-by-one overflow in the CVS PreservePermissions of rcs.c for CVSD before 1.11.2 allows local users to execute arbitrary code.
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0844
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0844
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-120
(官方数据源) CNNVD

- 其它链接及资源

ftp://ftp.caldera.com/pub/security/OpenLinux/CSSA-2002-035.0.txt
(VENDOR_ADVISORY)  CALDERA  CSSA-2002-035.0
ftp://patches.sgi.com/support/free/security/advisories/20040103-01-U.asc
(UNKNOWN)  SGI  20040103-01-U
http://archives.neohapsis.com/archives/vulnwatch/2002-q2/0081.html
(VENDOR_ADVISORY)  VULNWATCH  20020525 [DER ADV#8] - Local off by one in CVSD
http://marc.info/?l=bugtraq&m=102233767925177&w=2
(UNKNOWN)  BUGTRAQ  20020525 [DER ADV#8] - Local off by one in CVSD
http://www.redhat.com/support/errata/RHSA-2004-004.html
(UNKNOWN)  REDHAT  RHSA-2004:004
http://www.securityfocus.com/bid/4829
(VENDOR_ADVISORY)  BID  4829
http://xforce.iss.net/xforce/xfdb/9175
(VENDOR_ADVISORY)  XF  cvs-rcs-offbyone-bo(9175)

- 漏洞信息

CVS Daemon RCS本地单字节缓冲区溢出漏洞
中危 边界条件错误
2002-08-12 00:00:00 2005-09-14 00:00:00
本地  
        
        CVS是一款免费开放源代码的版本控制系统,可使用在多种Linux和Unix操作系统下,也可以运行于Microsoft Windows操作系统。
        CVS中的rcs.c代码中对缓冲区边界缺少正确充分的检查,可导致本地攻击者以cvs进程的权限在系统中执行任意代码。
        cvs-1.11/src/rcs.c代码中的sscanf()实现存在典型的单字节缓冲区溢出漏洞,攻击者可以利用堆栈中的帧指针覆盖而以cvs进程的权限执行任意代码,由于info->data的数据由本地符号连接文件中获得,所以此漏洞只能本地进行利用。
        问题代码如下所示:
        cvs-1.11/src/rcs.c:
        info = findnode (vers->other_delta, "special");
         if (info != NULL)
         {
         /* If the size of `devtype' changes, fix the sscanf call also */
         char devtype[16]; <-- 16字节
         if (sscanf (info->data, "%16s %lu", <-- 应该为15,为不是16,导致单字节缓冲溢出
         devtype, &devnum_long) < 2)
         error (1, 0, "厂商补丁:
        Caldera
        -------
        Caldera已经为此发布了一个安全公告(CSSA-2002-035.0)以及相应补丁:
        CSSA-2002-035.0:Linux: local off by one in cvsd
        链接:
        http://www.caldera.com/support/security/advisories/CSSA-2002-035.0.txt

        补丁下载:
        . OpenLinux 3.1.1 Server
         软件包下载地址:
         ftp://ftp.caldera.com/pub/updates/OpenLinux/3.1.1/Server/CSSA-2002-035.0/RPMS
         软件包:
         446921ba85f2f865d698060ab344d189 cvs-1.11-8.i386.rpm
         11ddbffdbf9310b24364b2b91d851acc cvs-doc-ps-1.11-8.i386.rpm
         安装方法:
         rpm -Fvh cvs-1.11-8.i386.rpm
         rpm -Fvh cvs-doc-ps-1.11-8.i386.rpm
        . OpenLinux 3.1.1 Workstation
         软件包下载地址:
         ftp://ftp.caldera.com/pub/updates/OpenLinux/3.1.1/Workstation/CSSA-2002-035.0/RPMS
         软件包:
         d24451d87b1c7424f12bb41d4873c3df cvs-1.11-8.i386.rpm
         035d93df5ab69f025f7d08a583977658 cvs-doc-ps-1.11-8.i386.rpm
         安装方法:
         rpm -Fvh cvs-1.11-8.i386.rpm
         rpm -Fvh cvs-doc-ps-1.11-8.i386.rpm
        . OpenLinux 3.1 Server
         软件包下载地址:
         ftp://ftp.caldera.com/pub/updates/OpenLinux/3.1/Server/CSSA-2002-035.0/RPMS
         软件包:
         1f3a09e4fcc1a8a0d011a6e7fcd0d810 cvs-1.11-8.i386.rpm
         ff3e5b2acdd60e4b0492b212603a0d23 cvs-doc-ps-1.11-8.i386.rpm
         安装方法:
         rpm -Fvh cvs-1.11-8.i386.rpm
         rpm -Fvh cvs-doc-ps-1.11-8.i386.rpm
        . OpenLinux 3.1 Workstation
         软件包下载地址:
         ftp://ftp.caldera.com/pub/updates/OpenLinux/3.1/Workstation/CSSA-2002-035.0/RPMS
         软件包:
         cf5125e9586da6217df51051f66eb8d6 cvs-1.11-8.i386.rpm
         4bce0b96a28195c75878515b6a37777d cvs-doc-ps-1.11-8.i386.rpm
         安装方法:
         rpm -Fvh cvs-1.11-8.i386.rpm
         rpm -Fvh cvs-doc-ps-1.11-8.i386.rpm
        CVS
        ---
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        CVS Upgrade cvs-1.11.2.tar.gz
        
        http://ccvs.cvshome.org/servlets/ProjectDownloadList?action=download&dlID=115
: has bad `special' newphrase ",
         workfile, vers->version, info->data);
         devnum = devnum_long;
         if (STREQ (devtype, "character"))
         special_file = S_IFCHR;
         else if (STREQ (devtype, "block"))
         special_file = S_IFBLK;
         else
         error (0, 0, " is a special file of unsupported type `'",
         workfile, info->data);
         }
         }
        

- 公告与补丁

        

- 漏洞信息

7409
CVS rcs.c PreservePermissions for CVSD Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-05-25 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

CVS Daemon RCS Off By One Local Buffer Overflow Vulnerability
Boundary Condition Error 4829
No Yes
2002-05-25 12:00:00 2009-07-11 01:56:00
Vulnerability discovery credited to david evlis reign <davidreign@hotmail.com>.

- 受影响的程序版本

SGI ProPack 2.4
SGI ProPack 2.3
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux WS 2.1 IA64
RedHat Enterprise Linux WS 2.1
RedHat Enterprise Linux ES 3
RedHat Enterprise Linux ES 2.1 IA64
RedHat Enterprise Linux ES 2.1
RedHat Advanced Workstation for the Itanium Processor 2.1 IA64
RedHat Advanced Workstation for the Itanium Processor 2.1
Red Hat Enterprise Linux AS 3
Red Hat Enterprise Linux AS 2.1 IA64
Red Hat Enterprise Linux AS 2.1
CVS CVS 1.11
+ Caldera OpenLinux Server 3.1.1
+ Caldera OpenLinux Server 3.1
+ Caldera OpenLinux Workstation 3.1.1
+ Caldera OpenLinux Workstation 3.1
+ Conectiva Linux 8.0
+ Conectiva Linux 7.0
+ Mandriva Linux Mandrake 8.0 ppc
+ Mandriva Linux Mandrake 8.0

- 漏洞讨论

CVS is the concurrent versioning system. CVS is a freely available, open source software development package for the Unix, Linux, and Microsoft Windows platforms.

Due to a boundry condition error, it may be possible for a local attacker to execute arbitrary code. The rcs.c file contains an off-by-one error that could result in an attacker overwriting portions of stack memory, and executing arbitrary code.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

SGI has released an advisory 20040202-01-U to address this and other issues in SGI ProPack 2.4. Please see the referenced advisory for more information. Fixes are available below.

RedHat has released an advisory RHSA-2004:004-05 with fixes to address this and other issues. Please see the referenced advisory for more information.

SGI has released an advisory 20040103-01-U with fixes to address this and other issues. Please see the referenced advisory for more information.

Fixes available:


CVS CVS 1.11

SGI ProPack 2.3

SGI ProPack 2.4

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站