CVE-2002-0826
CVSS7.5
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-10 15:12:58
NMCO    

[原文]Buffer overflow in WS_FTP FTP Server 3.1.1 allows remote authenticated users to execute arbitrary code via a long SITE CPWD command.


[CNNVD]Ipswitch WS_FTP Server CPWD远程缓冲区溢出漏洞(CNNVD-200208-134)

        
        Ipswitch WS_FTP是一款使用广泛的FTP服务器程序,可使用在Microsoft NT/2000/XP操作系统下。
        Ipswitch WS_FTP在处理site cpwd命令时对参数缺少正确检查,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击。
        Ipswitch WS_FTP允许用户通过"site cpwd"命令改变它们的密码,但服务代码没有对用户提交的参数进行正确的缓冲区边界检查,攻击者可以提交超长的字符串作为"site cpwd"命令参数可导致产生堆栈的缓冲区溢出,精心构建提交的字符串可能使攻击者以FTP进程的权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0826
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0826
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-134
(官方数据源) CNNVD

- 其它链接及资源

http://www.ipswitch.com/Support/WS_FTP-Server/patch-upgrades.html
(PATCH)  CONFIRM  http://www.ipswitch.com/Support/WS_FTP-Server/patch-upgrades.html
http://www.atstake.com/research/advisories/2002/a080802-1.txt
(VENDOR_ADVISORY)  ATSTAKE  A080802-1
http://www.securityfocus.com/bid/5427
(UNKNOWN)  BID  5427
http://www.iss.net/security_center/static/9794.php
(UNKNOWN)  XF  wsftp-site-cpwd-bo(9794)

- 漏洞信息

Ipswitch WS_FTP Server CPWD远程缓冲区溢出漏洞
高危 边界条件错误
2002-08-12 00:00:00 2005-05-02 00:00:00
远程  
        
        Ipswitch WS_FTP是一款使用广泛的FTP服务器程序,可使用在Microsoft NT/2000/XP操作系统下。
        Ipswitch WS_FTP在处理site cpwd命令时对参数缺少正确检查,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击。
        Ipswitch WS_FTP允许用户通过"site cpwd"命令改变它们的密码,但服务代码没有对用户提交的参数进行正确的缓冲区边界检查,攻击者可以提交超长的字符串作为"site cpwd"命令参数可导致产生堆栈的缓冲区溢出,精心构建提交的字符串可能使攻击者以FTP进程的权限在系统上执行任意指令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 管理员可以关闭使用CPWD命令以及其他不需要的特性。
        厂商补丁:
        Ipswitch
        --------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Ipswitch Upgrade ifs312.exe
        ftp://ftp.ipswitch.com/ipswitch/product_support/WS_FTP_Server/ifs312.exe
        要想了解更多的信息,请参看:
        
        http://www.ipswitch.com/Support/WS_FTP-Server/patch-upgrades.html

- 漏洞信息

860
WS_FTP Server SITE CPWD Command Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2002-08-08 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站