CVE-2002-0794
CVSS5.0
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:58
NMCO    

[原文]The accept_filter mechanism in FreeBSD 4 through 4.5 does not properly remove entries from the incomplete listen queue when adding a syncache, which allows remote attackers to cause a denial of service (network service availability) via a large number of connection attempts, which fills the queue.


[CNNVD]FreeBSD Accept Filter远程拒绝服务攻击漏洞(CNNVD-200208-153)

        
        FreeBSD是一款免费开放源代码的操作系统。
        FreeBSD中的accept_filter(9)机制存在设计漏洞,可导致远程攻击者填满连接队列,产生拒绝服务攻击。
        FreeBSD中的accept_filter(9)机制允许应用程序请求内核预处理进入的连接,如accf_http(9) accept filter可以导致accpet(2)调用只有在缓存了一个完全的HTTP请求后才让调用返回。
        accept filter机制默认不使用,系统管理员必须编辑内核使用ACCEPT_FILTER_HTTP选项或者使用kldload(8)来装载过滤器才能使用accept filter机制。
        通过持续发送重复的不完全请求(如类似CodeRed蠕虫的请求),由于这些URL请求不符合http accept filter的标准,而填满连接队列,造成其他客户端不能访问此服务,产生拒绝服务。
        系统只有在内核中使用这个accept filter并有应用程序配置利用这个工具才受到此漏洞影响,目前为止只有apache默认利用了此accept filter。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0794
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0794
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-153
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4879
(VENDOR_ADVISORY)  BID  4879
http://www.iss.net/security_center/static/9209.php
(VENDOR_ADVISORY)  XF  freebsd-accept-filter-dos(9209)
http://archives.neohapsis.com/archives/freebsd/2002-05/0349.html
(VENDOR_ADVISORY)  FREEBSD  FreeBSD-SA-02:26
http://www.osvdb.org/5081
(UNKNOWN)  OSVDB  5081

- 漏洞信息

FreeBSD Accept Filter远程拒绝服务攻击漏洞
中危 未知
2002-08-12 00:00:00 2005-05-02 00:00:00
远程  
        
        FreeBSD是一款免费开放源代码的操作系统。
        FreeBSD中的accept_filter(9)机制存在设计漏洞,可导致远程攻击者填满连接队列,产生拒绝服务攻击。
        FreeBSD中的accept_filter(9)机制允许应用程序请求内核预处理进入的连接,如accf_http(9) accept filter可以导致accpet(2)调用只有在缓存了一个完全的HTTP请求后才让调用返回。
        accept filter机制默认不使用,系统管理员必须编辑内核使用ACCEPT_FILTER_HTTP选项或者使用kldload(8)来装载过滤器才能使用accept filter机制。
        通过持续发送重复的不完全请求(如类似CodeRed蠕虫的请求),由于这些URL请求不符合http accept filter的标准,而填满连接队列,造成其他客户端不能访问此服务,产生拒绝服务。
        系统只有在内核中使用这个accept filter并有应用程序配置利用这个工具才受到此漏洞影响,目前为止只有apache默认利用了此accept filter。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 如果你编辑了内核使用accept filter,请编辑内核配置文件,删除以下选项:
        ACCEPT_FILTER_DATA和ACCEPT_FILTER_HTTP,并安装如下指示重新配置内核:
        
        http://www.freebsd.org/handbook/kernelconfig.html.

        * 如果使用可装载模块使用的filter,修改启动脚本不装载此模块,要判断是否使用,运行kldstat工具,查找是否存在这些模块名称:
        accf_http.ko和accf_data.ko.
        如果存在,表示使用了accept filter.
        厂商补丁:
        FreeBSD
        -------
        FreeBSD已经为此发布了一个安全公告(FreeBSD-SA-02:26)以及相应补丁:
        FreeBSD-SA-02:26:Remote denial-of-service when using accept filters
        链接:ftp://ftp.freebsd.org/pub/FreeBSD/CERT/advisories/FreeBSD-SA-02:26.accept.asc
        补丁下载:
        FreeBSD FreeBSD 4.5 -STABLE:
        FreeBSD Patch accept.patch
        ftp://ftp.FreeBSD.org/pub/FreeBSD/CERT/patches/SA-02:26/accept.patch
        a)下载相关补丁,并使用PGP工具验证PGP签名:
        # fetch ftp://ftp.FreeBSD.org/pub/FreeBSD/CERT/patches/SA-02:26/accept.patch
        # fetch ftp://ftp.FreeBSD.org/pub/FreeBSD/CERT/patches/SA-02:26/accept.patch.asc
        b)以ROOT权限执行如下命令:
        # cd /usr/src # patch < /path/to/patch
        c)重新编译内核并重新启动。

- 漏洞信息

5081
FreeBSD accept_filter Listen Queue DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Public

- 漏洞描述

FreeBSD accept_filter contains a flaw that may allow a remote denial of service. The issue is triggered when a malicious user sends repeated 'incomplete' requests (for example, partial HTTP requests), which fill the connection queue of the target system. This results in loss of availability for the platform.

- 时间线

2004-04-08 2002-05-29
2002-05-29 Unknow

- 解决方案

Upgrade to 4.5-STABLE or to 4.5-RELEASE-p6 security branch, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: either remove the ACCEPT_FILTER_DATA and ACCEPT_FILTER_HTTP options from the kernel or adjust system startup scripts to prevent kldload from loading these modules.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站