CVE-2002-0788
CVSS2.1
发布时间 :2002-08-12 00:00:00
修订时间 :2013-08-03 00:27:27
NMCO    

[原文]An interaction between PGP 7.0.3 with the "wipe deleted files" option, when used on Windows Encrypted File System (EFS), creates a cleartext temporary files that cannot be wiped or deleted due to strong permissions, which could allow certain local users or attackers with physical access to obtain cleartext information.


[CNNVD]多种PGP产品在Windows EFS环境下明文文件泄露漏洞(CNNVD-200208-136)

        
        Windows系统下的多种PGP产品包含对删除文件进行彻底清除功能,通过截取文件删除操作并执行相关数据磁盘清除操作来实现。
        多种PGP产品在Windows 2000下的加密文件系统(EFS)环境中清除操作存在漏洞,可导致本地攻击者查看加密文件内容。
        如果使用PGP的开启删除文件彻底清除功能,并在Windows 2000下的加密文件系统(EFS)环境中进行文件删除操作,PGP产品会对所有加密文件保留一份明文形式的拷贝,任何具有本地管理权限访问的用户可以通过查看这些文件获得敏感信息。
        此漏洞测试于Windows 2000系统下PGP Corporate Desktop 7.1.x版本, PGP Desktop Security 7.0.x版本, 和PGPfreeware Version 7.0.3。也存在于Windows XP NTFS系统中的加密文件夹。
        

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:pgp:personal_security:7.0.3PGP PGP Personal Security 7.0.3
cpe:/a:pgp:freeware:7.0.3PGP PGP Freeware 7.0.3
cpe:/a:pgp:corporate_desktop:7.1PGP PGP Corporate Desktop 7.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0788
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0788
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-136
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4702
(VENDOR_ADVISORY)  BID  4702
http://www.iss.net/security_center/static/9044.php
(VENDOR_ADVISORY)  XF  pgp-ntfs-reveal-data(9044)
http://archives.neohapsis.com/archives/bugtraq/2002-05/0052.html
(VENDOR_ADVISORY)  BUGTRAQ  20020508 NTFS and PGP interact to expose EFS encrypted data
http://download.nai.com/products/licensed/pgp/desktop_security/windows/version_7.1/hotfix/ReadMe.txt
(UNKNOWN)  CONFIRM  http://download.nai.com/products/licensed/pgp/desktop_security/windows/version_7.1/hotfix/ReadMe.txt
http://www.osvdb.org/4363
(UNKNOWN)  OSVDB  4363

- 漏洞信息

多种PGP产品在Windows EFS环境下明文文件泄露漏洞
低危 未知
2002-08-12 00:00:00 2006-09-22 00:00:00
本地  
        
        Windows系统下的多种PGP产品包含对删除文件进行彻底清除功能,通过截取文件删除操作并执行相关数据磁盘清除操作来实现。
        多种PGP产品在Windows 2000下的加密文件系统(EFS)环境中清除操作存在漏洞,可导致本地攻击者查看加密文件内容。
        如果使用PGP的开启删除文件彻底清除功能,并在Windows 2000下的加密文件系统(EFS)环境中进行文件删除操作,PGP产品会对所有加密文件保留一份明文形式的拷贝,任何具有本地管理权限访问的用户可以通过查看这些文件获得敏感信息。
        此漏洞测试于Windows 2000系统下PGP Corporate Desktop 7.1.x版本, PGP Desktop Security 7.0.x版本, 和PGPfreeware Version 7.0.3。也存在于Windows XP NTFS系统中的加密文件夹。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 当PGP产品使用于EFS系统中的时候关闭清除删除文件选项。
        厂商补丁:
        Network Associates
        ------------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Network Associates PGP Personal Security 7.0.3:
        Network Associates Hotfix PGPhotfix_EFSWipe.zip
        
        http://download.nai.com/products/licensed/pgp/desktop_security/windows/version_7.1/hotfix/PGPhotfix_EFSWipe.zip

        Network Associates PGP Freeware 7.0.3:
        Network Associates Hotfix PGPhotfix_EFSWipe.zip
        
        http://download.nai.com/products/licensed/pgp/desktop_security/windows/version_7.1/hotfix/PGPhotfix_EFSWipe.zip

        Network Associates PGP Corporate Desktop 7.1:
        Network Associates Hotfix PGPhotfix_EFSWipe.zip
        
        http://download.nai.com/products/licensed/pgp/desktop_security/windows/version_7.1/hotfix/PGPhotfix_EFSWipe.zip

- 漏洞信息

4363
NAI PGP NTFS EFS Data File Wiping Weakness
Local Access Required Misconfiguration
Loss of Confidentiality
Exploit Public

- 漏洞描述

PGP contains a flaw that allows a local attacker to obtain unencrypted contents of files typically protected by the Microsoft Encrypted File System (EFS). The issue is due to the native file wiping feature in PGP not interacting with Windows correctly and lacking permission to delete temporary files. These temporary files contain the unencrypted content of normally protected files and require elevated permission to delete, which PGP does not have.

- 时间线

2002-05-10 2002-03-10
2002-05-10 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Network Associates has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站