CVE-2002-0785
CVSS5.0
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:56
NMCO    

[原文]AOL Instant Messenger (AIM) allows remote attackers to cause a denial of service (crash) via an "AddBuddy" link with the ScreenName parameter set to a large number of comma-separated values, possibly triggering a buffer overflow.


[CNNVD]AOL Instant Messenger AddBuddy超链接拒绝服务攻击漏洞(CNNVD-200208-192)

        
        AOL Instant Messenger (AIM)是一款即时信息共享程序。
        AOL Instant Messenger (AIM)在处理aim:AddBuddy超链接时存在漏洞,可导致远程攻击者使AOL崩溃。
        攻击者可以通过构建包含多个逗号分隔的screenname数据的aim:AddBuddy超链接,当AOL用户浏览此恶意链接时,可导致用户系统中的OSCORE.DLL产生错误,使的AOL程序崩溃。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:aol:instant_messenger:4.3
cpe:/a:aol:instant_messenger:4.8.2646
cpe:/a:aol:instant_messenger:4.1.2010
cpe:/a:aol:instant_messenger:4.8.2616
cpe:/a:aol:instant_messenger:4.6
cpe:/a:aol:instant_messenger:4.2.1193
cpe:/a:aol:instant_messenger:4.3.2229
cpe:/a:aol:instant_messenger:4.4
cpe:/a:aol:instant_messenger:4.1
cpe:/a:aol:instant_messenger:4.2
cpe:/a:aol:instant_messenger:4.7.2480
cpe:/a:aol:instant_messenger:4.0
cpe:/a:aol:instant_messenger:4.5
cpe:/a:aol:instant_messenger:4.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0785
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0785
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-192
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/259435
(UNKNOWN)  CERT-VN  VU#259435
http://www.securityfocus.com/bid/4709
(VENDOR_ADVISORY)  BID  4709
http://www.iss.net/security_center/static/9058.php
(VENDOR_ADVISORY)  XF  aim-addbuddy-bo(9058)
http://archives.neohapsis.com/archives/bugtraq/2002-05/0086.html
(VENDOR_ADVISORY)  BUGTRAQ  20020508 Hole in AOL Instant Messenger
http://www.osvdb.org/5109
(UNKNOWN)  OSVDB  5109

- 漏洞信息

AOL Instant Messenger AddBuddy超链接拒绝服务攻击漏洞
中危 未知
2002-08-12 00:00:00 2005-10-12 00:00:00
远程  
        
        AOL Instant Messenger (AIM)是一款即时信息共享程序。
        AOL Instant Messenger (AIM)在处理aim:AddBuddy超链接时存在漏洞,可导致远程攻击者使AOL崩溃。
        攻击者可以通过构建包含多个逗号分隔的screenname数据的aim:AddBuddy超链接,当AOL用户浏览此恶意链接时,可导致用户系统中的OSCORE.DLL产生错误,使的AOL程序崩溃。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 不要用AOL Instant Messenger去浏览不可信的链接。
        厂商补丁:
        AOL
        ---
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.aol.com

- 漏洞信息

5109
AOL Instant Messenger (AIM) AddBuddy Link Long ScreenName Parameter Overflow DoS
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

AOL Instant Messenger contains a flaw that may allow a remote denial of service. The issue is triggered when a long add:AddBuddy hyperlink is clicked-on in a message, and will result in loss of availability for the AIM program.

- 时间线

2002-05-08 2002-05-08
2002-05-08 Unknow

- 解决方案

Upgrade to version 4.8.7290 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站