发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-10 15:12:51

[原文]OpenBSD 2.9 through 3.1 allows local users to cause a denial of service (resource exhaustion) and gain root privileges by filling the kernel's file descriptor table and closing file descriptors 0, 1, or 2 before executing a privileged process, which is not properly handled when OpenBSD fails to open an alternate descriptor.

[CNNVD]多个Vendor exec C库文件标准 I/O文件广义竞争条件漏洞(CNNVD-200208-199)

        OpenBSD 2.9至3.1版本存在漏洞。本地用户可以通过填写kernel's文件描述符表并在执行特权进程前关闭文件描述符0,1或2,OpenBSD打开候补描述失败时该进程不能正确处理。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:openbsd:openbsd:3.1OpenBSD 3.1
cpe:/o:openbsd:openbsd:2.9OpenBSD 2.9
cpe:/o:openbsd:openbsd:3.0OpenBSD 3.0

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  openbsd-file-descriptor-dos(9048)
(UNKNOWN)  BID  4708
(UNKNOWN)  OPENBSD  20020508 003: SECURITY FIX: May 8, 2002
(UNKNOWN)  BUGTRAQ  20020509 OpenBSD local DoS and root exploit

- 漏洞信息

多个Vendor exec C库文件标准 I/O文件广义竞争条件漏洞
高危 竞争条件
2002-08-12 00:00:00 2005-05-02 00:00:00
        OpenBSD 2.9至3.1版本存在漏洞。本地用户可以通过填写kernel's文件描述符表并在执行特权进程前关闭文件描述符0,1或2,OpenBSD打开候补描述失败时该进程不能正确处理。

- 公告与补丁

        Patches are available:
        OpenBSD OpenBSD 3.0
        OpenBSD OpenBSD 3.1
        OpenBSD OpenBSD 2.9
        SCO Unixware 7.1.1
        Caldera OpenUnix 8.0

- 漏洞信息

OpenBSD Kernel File Descriptor Table DoS
Local Access Required Denial of Service
Loss of Availability
Exploit Public

- 漏洞描述

OpenBSD contains a flaw that may allow a local denial of service. The issue is triggered when an attacker exhausts all the file descriptors in the kernel table, and will result in loss of availability for the platform.

- 时间线

2002-05-09 2002-05-09
2002-05-09 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, OpenBSD has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者