CVE-2002-0755
CVSS7.2
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:51
NMCO    

[原文]Kerberos 5 su (k5su) in FreeBSD 4.5 and earlier does not verify that a user is a member of the wheel group before granting superuser privileges, which could allow unauthorized users to execute commands as root.


[CNNVD]FreeBSD k5su Wheel组成员资格验证漏洞(CNNVD-200208-188)

        
        k5su是一款在FreeBSD系统下类似su的工具,在使用Kerberos 5或者本地passwd(5)文件验证后转换权限,k5su作为`krb5'工具包的一部分分发
        。
        k5su在验证wheel组成员时存在漏洞,可导致任意组的用户使用k5su工具。
        历史上BSD SU工具只允许本地属于`wheel' (group-ID 0)组的用户获得超级用户的权限,而k5su对用户进程的组属性没有进行充分检查,可导
        致任意组的用户在知道root的密码的情况下获得超级用户权限。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:freebsd:freebsd:4.4:release
cpe:/o:freebsd:freebsd:4.5:release

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0755
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0755
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-188
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4777
(VENDOR_ADVISORY)  BID  4777
http://www.iss.net/security_center/static/9125.php
(VENDOR_ADVISORY)  XF  freebsd-k5su-gain-privileges(9125)
ftp://ftp.freebsd.org/pub/FreeBSD/CERT/advisories/FreeBSD-SA-02:24.k5su.asc
(VENDOR_ADVISORY)  FREEBSD  FreeBSD-SA-02:24
http://www.osvdb.org/4893
(UNKNOWN)  OSVDB  4893

- 漏洞信息

FreeBSD k5su Wheel组成员资格验证漏洞
高危 未知
2002-08-12 00:00:00 2005-05-02 00:00:00
本地  
        
        k5su是一款在FreeBSD系统下类似su的工具,在使用Kerberos 5或者本地passwd(5)文件验证后转换权限,k5su作为`krb5'工具包的一部分分发
        。
        k5su在验证wheel组成员时存在漏洞,可导致任意组的用户使用k5su工具。
        历史上BSD SU工具只允许本地属于`wheel' (group-ID 0)组的用户获得超级用户的权限,而k5su对用户进程的组属性没有进行充分检查,可导
        致任意组的用户在知道root的密码的情况下获得超级用户权限。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 去掉k5su的S位:
        # chmod u-s /usr/bin/k5su
        厂商补丁:
        FreeBSD
        -------
        FreeBSD已经为此发布了一个安全公告(FreeBSD-SA-02:24)以及相应补丁:
        FreeBSD-SA-02:24:k5su utility does not honor `wheel' group
        链接:ftp://ftp.freebsd.org/pub/FreeBSD/CERT/advisories/FreeBSD-SA-02:24.k5su.asc
        k5su以krb5工具包方式安装,默认在当前FREEBSD-STABLE版本中不安装。

- 漏洞信息

4893
FreeBSD k5su Group Check Failure
Local Access Required Authentication Management
Loss of Confidentiality, Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

The k5su utility contains a flaw that may allow a local user to gain access to unauthorized privileges. The issue is triggered when a local user who does not have 'wheel' group membership executes k5su and enters the root password. This flaw results in complete control of the host by the attacker.

- 时间线

2002-05-20 Unknow
2002-05-20 Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to disable k5su by removing the suid bit. The suid for k5su is removed by default in subsequent releases as well as in the STABLE branch after 2002-05-15.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站