发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:48

[原文]Cross-site scripting vulnerability in thttpd 2.20 and earlier allows remote attackers to execute arbitrary script via a URL to a nonexistent page, which causes thttpd to insert the script into a 404 error message.

[CNNVD]ACME Labs thttpd跨站脚本执行漏洞(CNNVD-200208-238)


- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  thttpd-error-page-css(9029)
(VENDOR_ADVISORY)  VULNWATCH  20020417 Smalls holes on 5 products #1

- 漏洞信息

ACME Labs thttpd跨站脚本执行漏洞
高危 未知
2002-08-12 00:00:00 2006-08-03 00:00:00

- 公告与补丁

        * 关闭浏览器的javascript功能。

- 漏洞信息 (21422)

ACME Labs thttpd 2.20 Cross-Site Scripting Vulnerability (EDBID:21422)
linux remote
2002-04-25 Verified
0 frog
N/A [点击下载]

thttpd is a web server product maintained by ACME Labs. thttpd has been compiled for Linux, BSD and Solaris, as well as other Unix like operating systems.

Cross Site Scripting issues has been reported in some versions of thttpd. thttpd fails to check URLs for the presence of script commands when generating error pages, allowing the attacker-supplied code to execute within the context of the hosted site.

It should be noted that this issue was tested on 2.20b, other versions may also be affected by this issue.<script>[SCRIPT]</script> 		

- 漏洞信息

thttpd Error Page XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified, Third-party Verified

- 漏洞描述

thttp v2.20c and below contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate Script variables upon submission of the URL. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-04-17 Unknow
2002-04-17 Unknow

- 解决方案

Upgrade to version 2.24 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者