发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:47

[原文]Buffer overflow in the progressive reader for libpng 1.2.x before 1.2.4, and 1.0.x before 1.0.14, allows attackers to cause a denial of service (crash) via a PNG data stream that has more IDAT data than indicated by the IHDR chunk.



- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

中危 边界条件错误
2002-08-12 00:00:00 2006-09-20 00:00:00

- 公告与补丁

        * 不要使用有问题的浏览器访问不可信站点。

        Opera Software

- 漏洞信息

libpng Progressive Reader Malformed PNG Overflow
Context Dependent Input Manipulation
Loss of Integrity Upgrade
Exploit Unknown Vendor Verified

- 漏洞描述

libpng contains an overflow condition in the progressive reader function. The issue is due to the progressive reader function not sanitizing user-supplied input. With a specially crafted PNG data stream containing malformed IDAT data, a context-dependent attacker can cause a buffer overflow to cause a denial of service or potentially execute arbitrary code.

- 时间线

2002-08-01 Unknow
Unknow 2002-06-28

- 解决方案

It has been reported that this issue has been fixed. Upgrade to version 1.2.4beta3, or 1.0.14, or higher, to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

LibPNG Wide Image Processing Memory Corruption Vulnerability
Boundary Condition Error 5409
Yes No
2002-08-06 12:00:00 2009-07-11 02:56:00
Discovery of this issue is credited to Glenn Randers-Pehrson.

- 受影响的程序版本

libpng libpng 1.0.12
- Caldera OpenLinux Server 3.1.1
- Caldera OpenLinux Server 3.1
- Caldera OpenLinux Workstation 3.1.1
- Caldera OpenLinux Workstation 3.1
+ Debian Linux 3.0
+ Mandriva Linux Mandrake 8.1 ia64
+ Mandriva Linux Mandrake 8.1
+ S.u.S.E. Linux 8.0
+ S.u.S.E. Linux 7.3 sparc
+ S.u.S.E. Linux 7.3 ppc
+ S.u.S.E. Linux 7.3

- 漏洞讨论

libpng is reported to be prone to a security-related issue with regards to handling of overly wide images. It may be possible to corrupt memory with an overly wide PNG image. An attacker may be able to exploit this condition to execute arbitrary code with the privileges of an application or client which handles the overly wide image, though this possibility has not been confirmed.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

Fixes are available:

libpng libpng 1.0.12

- 相关参考