CVE-2002-0686
CVSS7.5
发布时间 :2002-07-23 00:00:00
修订时间 :2016-10-17 22:21:28
NMCOS    

[原文]Buffer overflow in the search component for iPlanet Web Server (iWS) 4.1 and Sun ONE Web Server 6.0 allows remote attackers to execute arbitrary code via a long argument to the NS-rel-doc-name parameter.


[CNNVD]iPlanet Web Server远程缓冲区溢出漏洞(CNNVD-200207-078)

        
        iPlanet Webserver是一款由Sun Microsystems公司提供的HTTP服务器产品。
        iPlanet Webserver存在漏洞,可导致远程攻击者进行缓冲区溢出攻击。
        iPlanet Webserver存在基于堆栈的缓冲区溢出,可导致恶意客户端发送恶意构建的数据使Web服务崩溃,精心构建发送数据可能使攻击者以Web进程权限在iPlanet主机上执行任意指令。
        在Sun Microsystems提供补丁之后,NGSSoftware将提供详细技术细节。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:iplanet:iplanet_web_server:4.1
cpe:/a:iplanet:iplanet_web_server:6.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0686
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0686
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200207-078
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=102622220416889&w=2
(UNKNOWN)  BUGTRAQ  20020709 Sun iPlanet Web Server Buffer Overflow (#NISR09072002)
http://www.iss.net/security_center/static/9506.php
(VENDOR_ADVISORY)  XF  iplanet-search-bo(9506)
http://www.kb.cert.org/vuls/id/612843
(UNKNOWN)  CERT-VN  VU#612843
http://www.nextgenss.com/vna/sun-iws.txt
(UNKNOWN)  MISC  http://www.nextgenss.com/vna/sun-iws.txt
http://www.securityfocus.com/bid/4851
(VENDOR_ADVISORY)  BID  4851

- 漏洞信息

iPlanet Web Server远程缓冲区溢出漏洞
高危 边界条件错误
2002-07-23 00:00:00 2005-10-20 00:00:00
远程  
        
        iPlanet Webserver是一款由Sun Microsystems公司提供的HTTP服务器产品。
        iPlanet Webserver存在漏洞,可导致远程攻击者进行缓冲区溢出攻击。
        iPlanet Webserver存在基于堆栈的缓冲区溢出,可导致恶意客户端发送恶意构建的数据使Web服务崩溃,精心构建发送数据可能使攻击者以Web进程权限在iPlanet主机上执行任意指令。
        在Sun Microsystems提供补丁之后,NGSSoftware将提供详细技术细节。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时没有合适的临时解决方法。
        厂商补丁:
        iPlanet E-Commerce Solutions
        ----------------------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.iplanet.com/

- 漏洞信息

11869
iPlanet Web Server Search Component NS-rel-doc-name Parameter Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-07-09 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

iPlanet Web Server Search Component Buffer Overflow Vulnerability
Boundary Condition Error 4851
Yes No
2002-05-27 12:00:00 2009-07-11 01:56:00
Vulnerability discovery credited to Next Generation Security Software.

- 受影响的程序版本

Sun ONE Web Server 6.0
Sun ONE Web Server 4.1
Sun iPlanet Web Server 6.0
- Compaq Tru64 4.0 d
- HP HP-UX 11.0
- HP HP-UX 11i v1
- IBM AIX 4.3.3
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows NT 4.0 SP6a
- Red Hat Linux 6.2
- Sun Solaris 8_sparc
- Sun Solaris 7.0
- Sun Solaris 2.6
Sun iPlanet Web Server 4.1
- HP HP-UX 11.0
- IBM AIX 4.3.3
- Linux kernel 2.2.12
- Microsoft Windows NT 4.0
Sun ONE Web Server 6.0 SP3
Sun ONE Web Server 4.1 SP10
HP VirtualVault 11.0.4

- 不受影响的程序版本

Sun ONE Web Server 6.0 SP3
Sun ONE Web Server 4.1 SP10
HP VirtualVault 11.0.4

- 漏洞讨论

iPlanet Webserver is an http server product offered by Sun Microsystems.

A stack-based overflow condition has been reported in versions of iPlanet Web Server. The vulnerability occurs in the Search component of iPlanet Web Server. An attacker is able to submit an overly long value to the 'NS-rel-doc-name' parameter to cause the buffer overflow condition. This could potentially allow for malicious clients to execute arbitrary code on (and gain control of) iPlanet hosts. Sending data not specially constructed to execute code could cause the server to crash.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

HP has released an advisory. Users of HP-UX 11.04, VirtualVault A.04.00, with patch PHSS_23215 installed are not vulnerable to this issue.

Fixes available:


Sun iPlanet Web Server 4.1

Sun ONE Web Server 4.1

Sun ONE Web Server 6.0

Sun iPlanet Web Server 6.0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站