CVE-2002-0685
CVSS7.5
发布时间 :2002-07-23 00:00:00
修订时间 :2016-10-17 22:21:27
NMCO    

[原文]Heap-based buffer overflow in the message decoding functionality for PGP Outlook Encryption Plug-In, as used in NAI PGP Desktop Security 7.0.4, Personal Security 7.0.3, and Freeware 7.0.3, allows remote attackers to modify the heap and gain privileges via a large, malformed mail message.


[CNNVD]PGP Outlook Plug-In堆腐烂漏洞(CNNVD-200207-066)

        用于NAI PGP Desktop Security 7.0.4版本、Personal Security 7.0.3版本以及Freeware 7.0.3版本中的PGP Outlook Encryption Plug-In的消息译码功能存在基于堆的缓冲区溢出漏洞。远程攻击者可以借助一个超大的畸形邮件消息修改堆以及提升特权。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:pgp:personal_security:7.0.3PGP PGP Personal Security 7.0.3
cpe:/a:pgp:desktop_security:7.0.4PGP PGP Desktop Security 7.0.4
cpe:/a:pgp:freeware:7.0.3PGP PGP Freeware 7.0.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0685
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0685
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200207-066
(官方数据源) CNNVD

- 其它链接及资源

http://download.nai.com/products/licensed/pgp/desktop_security/windows/version_7.04/hotfix/ReadMe.txt
(VENDOR_ADVISORY)  CONFIRM  http://download.nai.com/products/licensed/pgp/desktop_security/windows/version_7.04/hotfix/ReadMe.txt
http://marc.info/?l=bugtraq&m=102634756815773&w=2
(UNKNOWN)  BUGTRAQ  20020710 EEYE: Remote PGP Outlook Encryption Plug-in Vulnerability
http://marc.info/?l=ntbugtraq&m=102639521518942&w=2
(UNKNOWN)  NTBUGTRAQ  20020710 EEYE: Remote PGP Outlook Encryption Plug-in Vulnerability
http://www.iss.net/security_center/static/9525.php
(UNKNOWN)  XF  pgp-outlook-heap-overflow(9525)
http://www.kb.cert.org/vuls/id/821139
(UNKNOWN)  CERT-VN  VU#821139
http://www.securityfocus.com/bid/5202
(UNKNOWN)  BID  5202

- 漏洞信息

PGP Outlook Plug-In堆腐烂漏洞
高危 缓冲区溢出
2002-07-23 00:00:00 2006-09-22 00:00:00
远程  
        用于NAI PGP Desktop Security 7.0.4版本、Personal Security 7.0.3版本以及Freeware 7.0.3版本中的PGP Outlook Encryption Plug-In的消息译码功能存在基于堆的缓冲区溢出漏洞。远程攻击者可以借助一个超大的畸形邮件消息修改堆以及提升特权。

- 公告与补丁

        The vendor has released patches to address this issue:
        Network Associates PGP Freeware 7.0.3
        
        Network Associates Desktop Security 7.0.4
        

- 漏洞信息

4364
PGP Outlook Plug-in Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PGP Outlook plug-in contains a flaw that allows a remote attacker to execute arbitrary code. The issue is due to the plug-in message decoding function not properly sanitizing input allowing an attacker to overwrite portions of the system memory to execute arbitrary code. This can be exploited by sending a malicious email and does not require the user to open an attachment. Arbitrary code will be run with the privileges of the person who opens the mail.

- 时间线

2002-07-10 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Network Associates has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站