CVE-2002-0681
CVSS7.5
发布时间 :2002-07-23 00:00:00
修订时间 :2016-10-17 22:21:21
NMCOES    

[原文]Cross-site scripting vulnerability in GoAhead Web Server 2.1 allows remote attackers to execute script as other web users via script in a URL that generates a "404 not found" message, which does not quote the script.


[CNNVD]GoAhead WebServer出错页面绕过站点脚本漏洞(CNNVD-200207-088)

        GoAhead Web Server 2.1版本存在跨站脚本漏洞。远程攻击者可以像其他用户样借助产生"404 not found"消息的URL脚本执行脚本,该漏洞不引用脚本。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:goahead_software:goahead_webserver:2.1.3
cpe:/a:goahead_software:goahead_webserver:2.1.4
cpe:/a:goahead_software:goahead_webserver:2.1.1
cpe:/a:goahead_software:goahead_webserver:2.1.2
cpe:/a:goahead_software:goahead_webserver:2.1.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0681
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0681
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200207-088
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/vulnwatch/2002-q3/0013.html
(VENDOR_ADVISORY)  VULNWATCH  20020710 [VulnWatch] wp-02-0001: GoAhead Web Server Directory Traversal + Cross Site Scripting
http://marc.info/?l=bugtraq&m=102631742711795&w=2
(UNKNOWN)  BUGTRAQ  20020710 wp-02-0001: GoAhead Web Server Directory Traversal + Cross Site Scripting
http://www.iss.net/security_center/static/9518.php
(VENDOR_ADVISORY)  XF  goahead-error-msg-xss(9518)
http://www.securityfocus.com/bid/5198
(VENDOR_ADVISORY)  BID  5198

- 漏洞信息

GoAhead WebServer出错页面绕过站点脚本漏洞
高危 跨站脚本
2002-07-23 00:00:00 2005-10-20 00:00:00
远程  
        GoAhead Web Server 2.1版本存在跨站脚本漏洞。远程攻击者可以像其他用户样借助产生"404 not found"消息的URL脚本执行脚本,该漏洞不引用脚本。

- 公告与补丁

        An updated version of GoAhead WebServer has been released which addresses this issue. Users are advised to upgrade as soon as possible.
        GoAhead Software GoAhead WebServer 2.1
        
        GoAhead Software GoAhead WebServer 2.1.1
        
        GoAhead Software GoAhead WebServer 2.1.2
        
        GoAhead Software GoAhead WebServer 2.1.3
        
        GoAhead Software GoAhead WebServer 2.1.4
        
        GoAhead Software GoAhead WebServer 2.1.5
        

- 漏洞信息 (21608)

GoAhead WebServer 2.1.x Error Page Cross Site Scripting Vulnerability (EDBID:21608)
windows remote
2002-07-10 Verified
0 Matt Moore
N/A [点击下载]
source: http://www.securityfocus.com/bid/5198/info

A vulnerability has been reported for GoAhead WebServer 2.1. Reportedly, it is possible for attackers to launch cross site scripting attacks against vulnerable systems.

GoAhead WebServer includes unsanitized requested URLs when displaying a 404 error page. An attacker may be able to trick a user into following a link which includes malicious script code, and executing the attack. 

GoAhead-server/SCRIPTalert(document.domain)/SCRIPT 		

- 漏洞信息

6662
GoAhead WebServer Error Page XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

GoAhead WebServer contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate input variables upon submission to the error handling script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-07-10 Unknow
2002-07-10 Unknow

- 解决方案

Upgrade to version 2.1.8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

GoAhead WebServer Error Page Cross Site Scripting Vulnerability
Input Validation Error 5198
Yes No
2002-07-10 12:00:00 2009-07-11 02:56:00
Discovery credited to Matt Moore <matt@westpoint.ltd.uk>.

- 受影响的程序版本

GoAhead Software GoAhead Webserver (Windows) 2.1
- Microsoft Windows 98
- Microsoft Windows 98SE
- Microsoft Windows ME
GoAhead Software GoAhead WebServer 2.1.5
GoAhead Software GoAhead WebServer 2.1.4
GoAhead Software GoAhead WebServer 2.1.3
GoAhead Software GoAhead WebServer 2.1.2
GoAhead Software GoAhead WebServer 2.1.1
GoAhead Software GoAhead WebServer 2.1
- Linux kernel 2.3
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows CE 3.0
- Microsoft Windows CE 2.0
- Microsoft Windows NT 4.0
GoAhead Software GoAhead WebServer 2.1.6

- 不受影响的程序版本

GoAhead Software GoAhead WebServer 2.1.6

- 漏洞讨论

A vulnerability has been reported for GoAhead WebServer 2.1. Reportedly, it is possible for attackers to launch cross site scripting attacks against vulnerable systems.

GoAhead WebServer includes unsanitized requested URLs when displaying a 404 error page. An attacker may be able to trick a user into following a link which includes malicious script code, and executing the attack.

- 漏洞利用

The following proof of concept was provided by Matt Moore &lt;matt@westpoint.ltd.uk&gt;:
GoAhead-server/SCRIPTalert(document.domain)/SCRIPT

- 解决方案

An updated version of GoAhead WebServer has been released which addresses this issue. Users are advised to upgrade as soon as possible.


GoAhead Software GoAhead WebServer 2.1

GoAhead Software GoAhead WebServer 2.1.1

GoAhead Software GoAhead WebServer 2.1.2

GoAhead Software GoAhead WebServer 2.1.3

GoAhead Software GoAhead WebServer 2.1.4

GoAhead Software GoAhead WebServer 2.1.5

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站