发布时间 :2002-07-23 00:00:00
修订时间 :2008-09-10 15:12:41

[原文]Pingtel xpressa SIP-based voice-over-IP phone 1.2.5 through does not require administrative privileges to perform a firmware upgrade, which allows unauthorized users to upgrade the phone.

[CNNVD]Pingtel Expressa任意固件升级漏洞(CNNVD-200207-073)


- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  5223
(UNKNOWN)  XF  pingtel-xpressa-firmware-upgrade(9570)

- 漏洞信息

Pingtel Expressa任意固件升级漏洞
中危 设计错误
2002-07-23 00:00:00 2005-10-20 00:00:00

- 公告与补丁

        * 暂时没有合适的临时解决方法。
        Pingtel Expressa 1.2.5:
        Pingtel Upgrade v2.0.1

        Pingtel Expressa 1.2.7 .4:
        Pingtel Upgrade v2.0.1

- 漏洞信息

Pingtel xpressa Arbitrary Firmware Install
Local Access Required, Remote / Network Access Authentication Management
Loss of Integrity
Exploit Public

- 漏洞描述

Pingtel xpressa VoIP phones contain a flaw that may allow a malicious user to perform a firmware upgrade. The issue is due to the use of a default, resettable administrator password and/or weak remote authentication for administrative users. It is possible that the flaw may allow a malicious user to gain control of an xpressa phone at the software or firmware level, resulting in a loss of integrity.

- 时间线

2002-07-12 2002-05-28
2002-07-12 Unknow

- 解决方案

Immediately after installation, change all default install passwords to a unique and secure password. When possible, change default accounts to custom names as well. Upgrade to version 2.0.1 or higher, as it has been reported to resolve several related authentication issues. Pingtel has released a document which outlines best practices relating to the deployment of Pingtel phones. See references for further informatiion.

- 相关参考

- 漏洞作者

- 漏洞信息

Pingtel Expressa Arbitrary Firmware Upgrade Vulnerability
Design Error 5223
No Yes
2002-07-12 12:00:00 2009-07-11 02:56:00
Vulnerability discovery credited to Ofir Arkin <> and Josh Anderson <>.

- 受影响的程序版本

Pingtel Xpressa 1.2.7 .4
Pingtel Xpressa 1.2.5

- 漏洞讨论

Expressa is the Java-Based Voice-Over-IP phone developed and distributed by Pingtel.

It has been discovered that users may be able to arbitrarily upgrade phone firmware. Expressa phones allow users to upgrade firmware without first authenticating as an administrator.

- 漏洞利用

No exploit is required for this vulnerability.

- 解决方案

Pingtel has made two documents available to address the issues announced by AtStake:

Pingtel @Stake Advisory Response

Best Practices for Deploying Pingtel Phones

Pingtel has additionally made fixed versions of software available:

Pingtel Xpressa 1.2.5

Pingtel Xpressa 1.2.7 .4

- 相关参考