CVE-2002-0614
CVSS5.0
发布时间 :2002-06-18 00:00:00
修订时间 :2008-09-05 16:28:29
NMCOS    

[原文]PHP-Survey 20000615 and earlier stores the global.inc file under the web root, which allows remote attackers to obtain sensitive information, including database credentials, if .inc files are not preprocessed by the server.


[CNNVD]PHP-Survey Global.INC信息泄露漏洞(CNNVD-200206-030)

        
        PHP-Survey是一款基于WEB的调查引擎,由PHP编写并可以运行在Unix和Linux操作系统下,由Mysql数据库后台支持。
        PHP-Survey脚本在处理global.inc文件请求中存在漏洞,可导致远程攻击者获得系统敏感信息。
        远程攻击者可以通过浏览器直接请求global.inc文件,就可以获得此文件源代码,global.inc文件包含数据库信息和调查引擎的接口设置信息,攻击者可以通过这些信息进一步对系统进行攻击。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php-survey:php-survey:2000-06-14b
cpe:/a:php-survey:php-survey:prebeta2000-03-27
cpe:/a:php-survey:php-survey:2000-04-21
cpe:/a:php-survey:php-survey:2000-04-20
cpe:/a:php-survey:php-survey:2000-06-15
cpe:/a:php-survey:php-survey:2000-06-14

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0614
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0614
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200206-030
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4612
(VENDOR_ADVISORY)  BID  4612
http://www.iss.net/security_center/static/8950.php
(VENDOR_ADVISORY)  XF  phpsurvey-global-reveal-info(8950)
http://archives.neohapsis.com/archives/bugtraq/2002-04/0383.html
(VENDOR_ADVISORY)  BUGTRAQ  20020426 PHP-Survey Database Access Vulnerability

- 漏洞信息

PHP-Survey Global.INC信息泄露漏洞
中危 配置错误
2002-06-18 00:00:00 2005-10-20 00:00:00
远程  
        
        PHP-Survey是一款基于WEB的调查引擎,由PHP编写并可以运行在Unix和Linux操作系统下,由Mysql数据库后台支持。
        PHP-Survey脚本在处理global.inc文件请求中存在漏洞,可导致远程攻击者获得系统敏感信息。
        远程攻击者可以通过浏览器直接请求global.inc文件,就可以获得此文件源代码,global.inc文件包含数据库信息和调查引擎的接口设置信息,攻击者可以通过这些信息进一步对系统进行攻击。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 把'global.inc'改名为'global.inc.php'。
        * 对'global.inc'文件类型增加访问控制,如在Apache服务器上可以如下配置:
        
        Order allow,deny
        Deny from all
        

        厂商补丁:
        PHP-Survey
        ----------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://sourceforge.net/projects/phpsurvey/

- 漏洞信息

8103
PHP-Survey global.inc Information Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality Solution Unknown

- 漏洞描述

- 时间线

2002-04-26 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHP-Survey Global.INC Information Disclosure Vulnerability
Configuration Error 4612
Yes No
2002-04-26 12:00:00 2009-07-11 12:46:00
Discovery of this issue is credited to "MOD" <br014c1155@blueyonder.co.uk>.

- 受影响的程序版本

PHP-Survey PHP-Survey prebeta-20000327
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
PHP-Survey PHP-Survey 20000615
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
PHP-Survey PHP-Survey 20000614b
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
PHP-Survey PHP-Survey 20000614
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
PHP-Survey PHP-Survey 20000421
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
PHP-Survey PHP-Survey 20000420
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18

- 漏洞讨论

PHP-Survey is a web-based survey engine. It is written in PHP and will run on most Unix and Linux variants. It is back-ended by a MySQL database.

The PHP-Survey script 'global.inc' will not be interpreted if requested via HTTP. This may potentially expose sensitive information such as database credentials to remote attackers.

- 漏洞利用

This issue may be exploited with a web browser. The attacker simply makes a request for the 'global.inc' script.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站