发布时间 :2002-06-18 00:00:00
修订时间 :2008-09-05 16:28:29

[原文]Directory traversal vulnerability in FileSeek.cgi allows remote attackers to read arbitrary files via a ....// (modified dot dot) in the (1) head or (2) foot parameters, which are not properly filtered.

[CNNVD]FileSeek CGI脚本远程文件泄露漏洞(CNNVD-200206-040)

        FileSeek是一款由Craig Patchett编写用于查找和下载文件的脚本。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  fileseek-cgi-directory-traversal(8858)
(VENDOR_ADVISORY)  VULN-DEV  20020416 FileSeek cgi script advisory

- 漏洞信息

FileSeek CGI脚本远程文件泄露漏洞
中危 输入验证
2002-06-18 00:00:00 2005-10-20 00:00:00
        FileSeek是一款由Craig Patchett编写用于查找和下载文件的脚本。

- 公告与补丁

        * Thijs Bosschert (提供如下第三方补丁:
        if ($directory =~ /$DD\.\./) { $directory = '' }
        $ARGS{'head'} =~ s/(^$ALLOWED_DIR)|(^$DD)|(\.\.($DD|$))//g;
        $ARGS{'foot'} =~ s/(^$ALLOWED_DIR)|(^$DD)|(\.\.($DD|$))//g;
        if ($directory =~ /$DD\.\./) { $directory = '' }
        $ARGS{'head'} =~ s/(^$ALLOWED_DIR)|(^$DD)|(\.\.)//g;
        $ARGS{'foot'} =~ s/(^$ALLOWED_DIR)|(^$DD)|(\.\.)//g;
        Wiley Computer Publishing

- 漏洞信息

FileSeek FileSeek.cgi Arbitrary File Access
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality
Exploit Public

- 漏洞描述

FileSeek contains a flaw that allows a remote attacker to view arbitrary files outside of the web path. The issue is due to the FileSeek.cgi program not properly sanitizing directory traversal style attacks (../../) supplied via the "head" or "foot" variables.

- 时间线

2002-04-16 Unknow
2002-04-16 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, the vulnerability discoverer has released a patch in the advisory to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

FileSeek CGI Script File Disclosure Vulnerability
Input Validation Error 6784
Yes No
2002-04-16 12:00:00 2009-07-11 08:06:00
Discovery of this vulnerability has been credited to : Thijs Bosschert (

- 受影响的程序版本

Wiley Computer Publishing Craig Patchett FileSeek2.cgi
Wiley Computer Publishing Craig Patchett FileSeek.cgi

- 漏洞讨论

FileSeek is an example cgi-script from "The CGI/Perl Cookbook from John Wiley &
Sons". The script is written and maintained by Craig Patchett. It is mainly used to find and download files on a web server.

FileSeek.cgi and FileSeek2.cgi are prone to a file disclosure vulnerability. It is possible for a remote attacker to submit a maliciously crafted web request which is capable of breaking out of the wwwroot directory and browsing arbitrary web-readable files on a host running the vulnerable script.

- 漏洞利用

The following proof of concept code was provided by Thijs Bosschert (


- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考