CVE-2002-0587
CVSS7.5
发布时间 :2002-06-18 00:00:00
修订时间 :2008-09-05 16:28:25
NMCO    

[原文]Buffer overflow in Ns_PdLog function for the external database driver proxy daemon library (libnspd.a) of AOLServer 3.0 through 3.4.2 allows remote attackers to cause a denial of service or execute arbitrary code via the Error or Notice parameters.


[CNNVD]AOLServer缓冲区溢出漏洞(CNNVD-200206-005)

        AOLServer 3.0至3.4.2版本的外部数据库驱动程序代理守护进程库(libnspd.a)中的Ns_PdLog函数存在缓冲区溢出漏洞。远程攻击者借助Error或者Notice参数导致服务拒绝或者执行任意代码。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:aol:aol_server:3.0
cpe:/a:aol:aol_server:3.1
cpe:/a:aol:aol_server:3.4.1
cpe:/a:aol:aol_server:3.3
cpe:/a:aol:aol_server:3.4
cpe:/a:aol:aol_server:3.2
cpe:/a:aol:aol_server:3.4.2
cpe:/a:aol:aol_server:3.2.1
cpe:/a:aol:aol_server:3.3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0587
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0587
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200206-005
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/bugtraq/2002-04/0195.html
(VENDOR_ADVISORY)  BUGTRAQ  20020416 [CERT-intexxia] AOLServer DB Proxy Daemon Format String Vulnerability
http://sourceforge.net/tracker/index.php?func=detail&aid=533141&group_id=3152&atid=303152
(VENDOR_ADVISORY)  CONFIRM  http://sourceforge.net/tracker/index.php?func=detail&aid=533141&group_id=3152&atid=303152
http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/aolserver/aolserver/nspd/log.c.diff?r1=1.4&r2=1.4.6.1
(UNKNOWN)  CONFIRM  http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/aolserver/aolserver/nspd/log.c.diff?r1=1.4&r2=1.4.6.1

- 漏洞信息

AOLServer缓冲区溢出漏洞
高危 缓冲区溢出
2002-06-18 00:00:00 2005-10-20 00:00:00
远程  
        AOLServer 3.0至3.4.2版本的外部数据库驱动程序代理守护进程库(libnspd.a)中的Ns_PdLog函数存在缓冲区溢出漏洞。远程攻击者借助Error或者Notice参数导致服务拒绝或者执行任意代码。
        

- 公告与补丁

        

- 漏洞信息

11910
AOLServer libnspd.a Library Ns_PdLog Function Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-04-16 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站