CVE-2002-0575
CVSS7.5
发布时间 :2002-06-18 00:00:00
修订时间 :2016-10-17 22:20:45
NMCOE    

[原文]Buffer overflow in OpenSSH before 2.9.9, and 3.x before 3.2.1, with Kerberos/AFS support and KerberosTgtPassing or AFSTokenPassing enabled, allows remote and local authenticated users to gain privileges.


[CNNVD]OpenSSH Kerberos 4 TGT/AFS令牌缓冲区溢出漏洞(CNNVD-200206-029)

        
        OpenSSH是一种开放源码的SSH协议的实现,初始版本用于OpenBSD平台,现在已经被移植到多种Unix/Linux类操作系统下。
        OpenSSH服务器程序实现存在缓冲区溢出漏洞,远程或本地攻击者可以得到主机的root权限。
        问题在于程序对于客户端提交过来的Kerberos 4 TGT/AFS令牌处理有误,如果TGT令牌数据是畸形的,一个对边界不加检查的串拷贝会导致缓冲区溢出。要利用此漏洞,在2.9.9及以上版本的OpenSSH中,攻击者需要有效用户的登录认证,在2.9.9以下版本攻击者则不需要经过有效用户的认证。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:openbsd:openssh:2.1OpenBSD OpenSSH 2.1
cpe:/a:openbsd:openssh:3.0OpenBSD OpenSSH 3.0
cpe:/a:openbsd:openssh:2.2OpenBSD OpenSSH 2.2
cpe:/a:openbsd:openssh:2.9.9OpenBSD OpenSSH 2.9.9
cpe:/a:openbsd:openssh:3.1OpenBSD OpenSSH 3.1
cpe:/a:openbsd:openssh:3.0.1OpenBSD OpenSSH 3.0.1
cpe:/a:openbsd:openssh:2.3OpenBSD OpenSSH 2.3
cpe:/a:openbsd:openssh:3.2OpenBSD OpenSSH 3.2
cpe:/a:openbsd:openssh:2.5.2OpenBSD OpenSSH 2.5.2
cpe:/a:openbsd:openssh:2.9p1OpenBSD OpenSSH 2.9 p1
cpe:/a:openbsd:openssh:2.9p2OpenBSD OpenSSH 2.9 p2
cpe:/a:openbsd:openssh:2.5.1OpenBSD OpenSSH 2.5.1
cpe:/a:openbsd:openssh:2.1.1OpenBSD OpenSSH 2.1.1
cpe:/a:openbsd:openssh:2.9OpenBSD OpenSSH 2.9
cpe:/a:openbsd:openssh:3.0.2OpenBSD OpenSSH 3.0.2
cpe:/a:openbsd:openssh:2.5OpenBSD OpenSSH 2.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0575
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0575
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200206-029
(官方数据源) CNNVD

- 其它链接及资源

ftp://ftp.caldera.com/pub/security/OpenLinux/CSSA-2002-022.2.txt
(UNKNOWN)  CALDERA  CSSA-2002-022.2
http://archives.neohapsis.com/archives/bugtraq/2002-04/0298.html
(UNKNOWN)  BUGTRAQ  20020420 OpenSSH Security Advisory (adv.token)
http://archives.neohapsis.com/archives/bugtraq/2002-04/0394.html
(VENDOR_ADVISORY)  BUGTRAQ  20020429 TSLSA-2002-0047 - openssh
http://marc.info/?l=bugtraq&m=102167972421837&w=2
(UNKNOWN)  BUGTRAQ  20020517 OpenSSH 3.2.2 released (fwd)
http://marc.info/?l=vuln-dev&m=101924296115863&w=2
(UNKNOWN)  VULN-DEV  20020419 OpenSSH 2.2.0 - 3.1.0 server contains a locally exploitable buffer overflow
http://online.securityfocus.com/archive/1/268718
(UNKNOWN)  BUGTRAQ  20020419 OpenSSH 2.2.0 - 3.1.0 server contains a locally exploitable buffer overflow
http://online.securityfocus.com/archive/1/269701
(UNKNOWN)  BUGTRAQ  20020426 Revised OpenSSH Security Advisory (adv.token)
http://www.iss.net/security_center/static/8896.php
(VENDOR_ADVISORY)  XF  openssh-sshd-kerberos-bo(8896)
http://www.securityfocus.com/bid/4560
(VENDOR_ADVISORY)  BID  4560

- 漏洞信息

OpenSSH Kerberos 4 TGT/AFS令牌缓冲区溢出漏洞
高危 未知
2002-06-18 00:00:00 2006-03-28 00:00:00
远程  
        
        OpenSSH是一种开放源码的SSH协议的实现,初始版本用于OpenBSD平台,现在已经被移植到多种Unix/Linux类操作系统下。
        OpenSSH服务器程序实现存在缓冲区溢出漏洞,远程或本地攻击者可以得到主机的root权限。
        问题在于程序对于客户端提交过来的Kerberos 4 TGT/AFS令牌处理有误,如果TGT令牌数据是畸形的,一个对边界不加检查的串拷贝会导致缓冲区溢出。要利用此漏洞,在2.9.9及以上版本的OpenSSH中,攻击者需要有效用户的登录认证,在2.9.9以下版本攻击者则不需要经过有效用户的认证。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在漏洞修补之前暂时停止OpenSSH的使用。
        厂商补丁:
        OpenSSH
        -------
        OpenSSH已经发布了相应的安全补丁以修补这个漏洞,请到厂商的主页下载:
        
        http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/ssh/radix.c?rev=1.18

- 漏洞信息 (21402)

OpenSSH 2.x/3.x Kerberos 4 TGT/AFS Token Buffer Overflow Vulnerability (EDBID:21402)
linux remote
2002-04-19 Verified
0 Marcell Fodor
N/A [点击下载]
source: http://www.securityfocus.com/bid/4560/info

A buffer overflow condition exists in the OpenSSH server. The condition is exploitable by attackers with valid user credentials in versions 2.9.9 and higher. Exploitation does not require valid user credentials in versions prior to 2.9.9.

The vulnerability is related to the handling of Kerberos 4 TGT/AFS tokens passed by the client. An unbounded string copy operation may result in a stack overflow if the TGT/token data is malformed. 

http://www.exploit-db.com/sploits/21402.tar		

- 漏洞信息

781
OpenSSH Kerberos TGT/AFS Token Passing Remote Overflow
Local Access Required, Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

A remote and local overflow exists in OpenSSH. OpenSSH fails to clear counters from a buffer in the auth_krb4_tgt() function, resulting in a buffer overflow. With a specially crafted request, an attacker can cause stack variables to be overwritten and arbitrary code to be executed, resulting in a loss of confidentiality, integrity, and/or availability.

- 时间线

2003-05-22 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.2.2 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by applying the vendor-supplied patch, or by disabling Kerberos authentication.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站