CVE-2002-0550
CVSS7.5
发布时间 :2002-07-03 00:00:00
修订时间 :2008-09-05 16:28:19
NMCOS    

[原文]Dynamic Guestbook 3.0 allows remote attackers to execute arbitrary code via shell metacharacters in the gbdaten parameter.


[CNNVD]Dynamic Guestbook远程执行任意命令漏洞(CNNVD-200207-009)

        
        Dynamic Guestbook是一款基于WEB的客户留言版程序,可使用在Linux,Unix或者Microsoft Windows操作系统下。
        Dynamic Guestbook在处理用户提交的内容上过滤不充分,可导致远程攻击者可以以httpd进程的权限执行任意代码。
        Dynamic Guestbook没有在任意表单域充分检查用户输入的内容,如PHP代码等,攻击者可插入任意PHP代码到表单,导致攻击者以Guestbook进程的权限在目标系统上执行任意代码。
        问题存在与如下代码中:
        ###################### quote source ############################
        ##### ?ffnen der Datei um zu lesen #####
        open (GBDB, $in{gbdaten});
        @inhalt = ;
        close (GBDB);
        ##### Eintrag an den Anfang des Files schreiben #####
        chomp($date);
        open (GBDB, ">>$gbdaten") || print "Konnte nicht in $gbdaten schreiben";
        print GBDB
        "$in{name}:|:$in{mail}:|:$date:|:$ENV{'REMOTE_ADDR'}:|:$in{kommentar}\n";
        foreach $zeile (@inhalt) {
        print GBDB $zeile;
        }
        close (GBDB);
        ################### /quote ##########################
        这个用来写用户输入到一文件的脚本没有过滤任何字符。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0550
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0550
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200207-009
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4423
(VENDOR_ADVISORY)  BID  4423
http://www.iss.net/security_center/static/8762.php
(VENDOR_ADVISORY)  XF  dynamic-guestbook-command-execution(8762)
http://archives.neohapsis.com/archives/bugtraq/2002-04/0052.html
(VENDOR_ADVISORY)  BUGTRAQ  20020403 Dynamic Guestbook V3.0 Cross Site Scripting and Arbitrary Command Execution under certain circumstances

- 漏洞信息

Dynamic Guestbook远程执行任意命令漏洞
高危 输入验证
2002-07-03 00:00:00 2005-10-20 00:00:00
远程  
        
        Dynamic Guestbook是一款基于WEB的客户留言版程序,可使用在Linux,Unix或者Microsoft Windows操作系统下。
        Dynamic Guestbook在处理用户提交的内容上过滤不充分,可导致远程攻击者可以以httpd进程的权限执行任意代码。
        Dynamic Guestbook没有在任意表单域充分检查用户输入的内容,如PHP代码等,攻击者可插入任意PHP代码到表单,导致攻击者以Guestbook进程的权限在目标系统上执行任意代码。
        问题存在与如下代码中:
        ###################### quote source ############################
        ##### ?ffnen der Datei um zu lesen #####
        open (GBDB, $in{gbdaten});
        @inhalt = ;
        close (GBDB);
        ##### Eintrag an den Anfang des Files schreiben #####
        chomp($date);
        open (GBDB, ">>$gbdaten") || print "Konnte nicht in $gbdaten schreiben";
        print GBDB
        "$in{name}:|:$in{mail}:|:$date:|:$ENV{'REMOTE_ADDR'}:|:$in{kommentar}\n";
        foreach $zeile (@inhalt) {
        print GBDB $zeile;
        }
        close (GBDB);
        ################### /quote ##########################
        这个用来写用户输入到一文件的脚本没有过滤任何字符。
        

- 公告与补丁

        厂商补丁:
        Dynamic Guestbook
        -----------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.gcf.de/

- 漏洞信息

14418
Dynamic Guestbook gbdaten Parameter Arbitrary Code Execution
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-04-03 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Dynamic Guestbook Remote Command Execution Vulnerability
Input Validation Error 4423
Yes No
2002-04-03 12:00:00 2009-07-11 11:56:00
Discovery of this issue is credited to "Florian Hobelsberger / BlueScreen" <genius28@gmx.de>.

- 受影响的程序版本

Dynamic Guestbook Dynamic Guestbook 3.0

- 漏洞讨论

Dynamic Guestbook is freely available guestbook software. It should run on most Unix and Linux variants, as well as Microsoft Windows operating systems.

Dynamic Guestbook does not sufficiently sanitize potentially malicious characters from form fields. As a result, it may be possible for a remote attacker to execute commands with the privileges of the webserver process.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站