CVE-2002-0549
CVSS7.5
发布时间 :2002-07-03 00:00:00
修订时间 :2008-09-05 16:28:18
NMCOS    

[原文]Cross-site scripting vulnerabilities in Anthill allow remote attackers to execute script as other Anthill users.


[CNNVD]Anthill存在跨站脚本执行漏洞(CNNVD-200207-042)

        
        Anthill是一款基于PHP开发的程序缺陷跟踪系统,可使用在Linux,unix或者Microsoft windows操作系统下。
        Anthill系统对用户输入处理缺少充分的检查,可导致攻击者进行跨站脚本执行攻击。
        Anthill系统中几乎所有信息可提交处都没有过滤HTML,JavaScript标记,攻击者可以在任意地方提交恶意JavaScript代码,当浏览用户查看包含恶意代码的链接时,就可以导致恶意代码在浏览用户浏览器上执行,导致基于Cookie的认证信息被泄露等攻击。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0549
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0549
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200207-042
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4442
(VENDOR_ADVISORY)  BID  4442
http://www.iss.net/security_center/static/8770.php
(VENDOR_ADVISORY)  XF  anthill-bug-tracking-css(8770)
http://archives.neohapsis.com/archives/bugtraq/2002-04/0089.html
(VENDOR_ADVISORY)  BUGTRAQ  20020406 Anthill login and JavaScript vulnerabilities

- 漏洞信息

Anthill存在跨站脚本执行漏洞
高危 输入验证
2002-07-03 00:00:00 2005-10-20 00:00:00
远程  
        
        Anthill是一款基于PHP开发的程序缺陷跟踪系统,可使用在Linux,unix或者Microsoft windows操作系统下。
        Anthill系统对用户输入处理缺少充分的检查,可导致攻击者进行跨站脚本执行攻击。
        Anthill系统中几乎所有信息可提交处都没有过滤HTML,JavaScript标记,攻击者可以在任意地方提交恶意JavaScript代码,当浏览用户查看包含恶意代码的链接时,就可以导致恶意代码在浏览用户浏览器上执行,导致基于Cookie的认证信息被泄露等攻击。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 严格过滤用户输入的HTML标记。
        厂商补丁:
        Anthill
        -------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://anthill.vmlinuz.ca/

- 漏洞信息

9245
Anthill Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown

- 漏洞描述

- 时间线

2002-04-06 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Anthill Cross-Agent Scripting Vulnerability
Input Validation Error 4442
Yes No
2002-04-06 12:00:00 2009-07-11 11:56:00
Posted to BugTraq on April 6, 2002 by Ulf Harnhammar.

- 受影响的程序版本

Anthill Anthill 0.1.6 .1
- PHP PHP 4.0 0

- 漏洞讨论

Anthill is a PHP based bug tracking system.

Anthill version 0.1.6.1 (and prior) fails to sanitize user input, allowing HTML and script code to be entered by users into the bug tracking system. This code is then interpreted by other users' browsers when they view the affected pages.

Because AntHill uses cookies to authenticate users, this could be used by a malicious user to steal login information from other users.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站