发布时间 :2002-07-03 00:00:00
修订时间 :2008-09-05 16:28:16

[原文]PHPGroupware 0.9.12 and earlier, when running with the magic_quotes_gpc feature disabled, allows remote attackers to compromise the database via a SQL injection attack.



- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  phpgroupware-sql-injection(8755)
(VENDOR_ADVISORY)  BUGTRAQ  20020403 SQL injection in PHPGroupware
(UNKNOWN)  BUGTRAQ  20020411 Re: SQL injection in PHPGroupware

- 漏洞信息

高危 未知
2002-07-03 00:00:00 2005-05-02 00:00:00

- 公告与补丁

        * 使用.htaccess文件限制只有合法用户能访问登陆(login)表单。

- 漏洞信息 (21365)

PHPGroupWare 0.9.13 Debian Package Configuration Vulnerability (EDBID:21365)
linux remote
2002-04-03 Verified
0 Matthias Jordan
N/A [点击下载]

PHPGroupWare is a freely available, open source groupware system written in PHP. It is distributed and maintained by the PHPGroupWare project.

Debian packages of PHPGroupWare ship with an insecure default configuration. The PHP magic_quotes_gpc directive of the PHPGroupWare apache.conf file is disabled by default in Debian packages. This may enable remote attackers to make SQL injection attacks via PHPGroupWare.

Under normal circumstances, PHPGroupWare installs with the PHP magic_quotes_gpc directive enabled, to restrict the possibility of SQL injection attacks.

Additionally, this issue may also enable an attacker to exploit vulnerabilities that may exist in the underlying database. 

fubar'; CREATE TABLE thistableshouldnotexist (a int); -- 		

- 漏洞信息

phpGroupWare Login Page SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

phpGroupWare contains a flaw that will allow a remote attacker to inject arbitrary SQL code. The issue is triggered when accessing the login page and will allow a remote attacker to arbitrarily create and modify tables resulting in a loss of integrity.

- 时间线

2002-04-03 Unknow
2002-04-03 Unknow

- 解决方案

Upgrade to version 0.9.14 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者