CVE-2002-0535
CVSS5.0
发布时间 :2002-07-03 00:00:00
修订时间 :2008-09-05 16:28:16
NMCOES    

[原文]Cross-site scripting vulnerabilities in PostBoard 2.0.1 and earlier allows remote attackers to execute script as other users via (1) an [IMG] tag when BBCode is enabled, or (2) in a topic title.


[CNNVD]PostBoard IMG标记脚本执行漏洞(CNNVD-200207-056)

        
        PostBoard是一款免费开放源代码的PostNuke内容处理管理系统上的信息公告版模块,设计使用于Unix和Linux操作系统下。
        PostBoard对用户提交给IMG标记的数据未进行充分正确的过滤,可导致攻击者进行跨站脚本执行攻击。
        攻击者可以在IMG标记中嵌入恶意脚本代码,当其他浏览用户查看包含恶意脚本代码的链接时,就可以导致脚本代码在用户浏览器上执行,攻击者可能获得用户基于Cookie认证的敏感信息。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:postboard:postboard:2.0
cpe:/a:postnuke_software_foundation:postnuke:0.71
cpe:/a:postnuke_software_foundation:postnuke:0.70
cpe:/a:postboard:postboard:2.0.1
cpe:/a:postnuke_software_foundation:postnuke:0.64
cpe:/a:postnuke_software_foundation:postnuke:0.703

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0535
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0535
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200207-056
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4559
(VENDOR_ADVISORY)  BID  4559
http://online.securityfocus.com/archive/1/267936
(VENDOR_ADVISORY)  BUGTRAQ  20020416 Multiple Vulnerabilities in PostBoard
http://xforce.iss.net/xforce/xfdb/8884
(UNKNOWN)  XF  postboard-title-css(8884)
http://www.securityfocus.com/bid/4561
(UNKNOWN)  BID  4561
http://www.iss.net/security_center/static/8881.php
(VENDOR_ADVISORY)  XF  postboard-img-css(8881)

- 漏洞信息

PostBoard IMG标记脚本执行漏洞
中危 输入验证
2002-07-03 00:00:00 2006-04-07 00:00:00
远程  
        
        PostBoard是一款免费开放源代码的PostNuke内容处理管理系统上的信息公告版模块,设计使用于Unix和Linux操作系统下。
        PostBoard对用户提交给IMG标记的数据未进行充分正确的过滤,可导致攻击者进行跨站脚本执行攻击。
        攻击者可以在IMG标记中嵌入恶意脚本代码,当其他浏览用户查看包含恶意脚本代码的链接时,就可以导致脚本代码在用户浏览器上执行,攻击者可能获得用户基于Cookie认证的敏感信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在IMG中只允许由'
        http://'开始的URL。
        厂商补丁:
        PostBoard
        ---------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.nukeaddon.com

- 漏洞信息 (21401)

PostBoard 2.0 BBCode IMG Tag Script Injection Vulnerability (EDBID:21401)
php webapps
2002-04-19 Verified
0 gcsb
N/A [点击下载]
source: http://www.securityfocus.com/bid/4559/info

PostBoard is a freely available, open source message board module for the PostNuke content management system. It is designed for use on the Unix and Linux operating systems.

PostBoard does not sanitize code submitted to site between IMG tags. Due to this, a malicious user may be able to submit a post to the site with script code between two IMG tags. 

The following code is proof of concept:

[IMG]javascript:alert('give me cookies');[/IMG] 		

- 漏洞信息 (21403)

PostBoard 2.0 Topic Title Script Execution Vulnerability (EDBID:21403)
php webapps
2002-04-19 Verified
0 gcsb
N/A [点击下载]
source: http://www.securityfocus.com/bid/4561/info

PostBoard is a freely available, open source message board module for the PostNuke content management system. It is designed for use on the Unix and Linux operating systems.

PostBoard does not adequately sanitize input by board users. Because of this, it is possible for users of the board to insert script code in message titles.

The following code is proof of concept:

<script>alert('give me cookies');</script>		

- 漏洞信息

9247
PostBoard IMG Tag XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-04-16 Unknow
2002-04-16 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PostBoard Topic Title Script Execution Vulnerability
Input Validation Error 4561
Yes No
2002-04-19 12:00:00 2009-07-11 12:46:00
Vulnerability discovery credited to gcsb <gcsbnz@yahoo.com>.

- 受影响的程序版本

PostBoard PostBoard 2.0.1
- PostNuke Development Team PostNuke 0.703
- PostNuke Development Team PostNuke 0.71
- PostNuke Development Team PostNuke 0.70
- PostNuke Development Team PostNuke 0.64
PostBoard PostBoard 2.0
- PostNuke Development Team PostNuke 0.703
- PostNuke Development Team PostNuke 0.71
- PostNuke Development Team PostNuke 0.70
- PostNuke Development Team PostNuke 0.64

- 漏洞讨论

PostBoard is a freely available, open source message board module for the PostNuke content management system. It is designed for use on the Unix and Linux operating systems.

PostBoard does not adequately sanitize input by board users. Because of this, it is possible for users of the board to insert script code in message titles.

- 漏洞利用

This vulnerability may be exploited with a web browser.

The following code is proof of concept:

&lt;script&gt;alert('give me cookies');&lt;/script&gt;

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站