CVE-2002-0532
CVSS7.2
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:16
NMCO    

[原文]EMU Webmail allows local users to execute arbitrary programs via a .. (dot dot) in the HTTP Host header that points to a Trojan horse configuration file that contains a pageroot specifier that contains shell metacharacters.


[CNNVD]EMUMail HTTP HOST任意配置文件可装载漏洞(CNNVD-200208-166)

        Emumail是一款Emumail公司维护和发行的WEB邮件服务程序,可使用在Linux、Unix和Windows操作系统下。
        Emumail对环境变量'HTTP_HOST'处理存在漏洞,可导致本地用户获得httpd进程的权限。攻击者可以在本地系统上建立一个文件,通过连接WEB服务程序并提供特殊的HTTP HOST环境变量值给Emumail系统,可导致程序强迫打开攻击者指定的文件,造成文件以httpd进程的权限执行。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:emumail:emumail_red_hat_linux:5.0
cpe:/a:emumail:emumail_unix:5.0
cpe:/a:emumail:emumail:3.0
cpe:/a:emumail:emumail_red_hat_linux:5.1
cpe:/a:emumail:emumail_unix:5.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0532
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0532
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-166
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4488
(VENDOR_ADVISORY)  BID  4488
http://www.iss.net/security_center/static/8836.php
(VENDOR_ADVISORY)  XF  emumail-http-host-execute(8836)
http://online.securityfocus.com/archive/1/266930
(VENDOR_ADVISORY)  BUGTRAQ  20020410 Re: emumail.cgi, one more local vulnerability (not verified)
http://www.osvdb.org/5270
(UNKNOWN)  OSVDB  5270

- 漏洞信息

EMUMail HTTP HOST任意配置文件可装载漏洞
高危 未知
2002-08-12 00:00:00 2012-11-30 00:00:00
本地  
        Emumail是一款Emumail公司维护和发行的WEB邮件服务程序,可使用在Linux、Unix和Windows操作系统下。
        Emumail对环境变量'HTTP_HOST'处理存在漏洞,可导致本地用户获得httpd进程的权限。攻击者可以在本地系统上建立一个文件,通过连接WEB服务程序并提供特殊的HTTP HOST环境变量值给Emumail系统,可导致程序强迫打开攻击者指定的文件,造成文件以httpd进程的权限执行。

- 公告与补丁

        厂商补丁:
        EMUMail
        -------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.emumail.com/

- 漏洞信息

5270
EMU Webmail HTTP Host Header Execute Arbitrary Program
Local Access Required Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Upon connecting to the server and supplying a malicious HTTP Host value to emumail, it could be possible for a local user to force the program to open an arbitrary file with privileges equal to the HTTP server process. This could result in the execution of an arbitrary program, supplied by an attacker with local access to the host.

- 时间线

2002-04-10 2002-04-10
2002-04-10 Unknow

- 解决方案

Upgrade to version 5.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站