发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:14

[原文]Cross-site scripting vulnerability in functions-inc.asp for ASP-Nuke RC1 allows remote attackers to execute script as other ASP-Nuke users by embedding it within an IMG tag.



- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  aspnuke-image-css(8829)
(VENDOR_ADVISORY)  VULN-DEV  20020409 Security holes in ASP-Nuke

- 漏洞信息

高危 输入验证
2002-08-12 00:00:00 2005-10-20 00:00:00

- 公告与补丁

        * 在漏洞修复之前暂时关闭Image标记的使用。

- 漏洞信息

ASP-Nuke functions-inc.asp IMG Tag XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

ASP-Nuke contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the contents of [IMG] tags in message body text upon submission to the scripts which include functions-inc.asp. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-04-09 Unknow
2002-04-09 Unknow

- 解决方案

Upgrade to version RC3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

ASP-Nuke Image Tag User-Embedded Scripting Vulnerability
Input Validation Error 4475
Yes No
2002-04-09 12:00:00 2009-07-11 11:56:00
Discovered by frog frog <>. Vendor has acknowledged the existence of this issue.

- 受影响的程序版本

ASP-Nuke ASP-Nuke RC1
ASP-Nuke ASP-Nuke RC2

- 不受影响的程序版本

ASP-Nuke ASP-Nuke RC2

- 漏洞讨论

ASP-Nuke is a web based Portal system. It allows users to create accounts and contribute content to the site.

ASP-Nuke does not adequately filter script code from image tags. It is possible for an attacker to post a maliciously constructed forum message which contains arbitrary script code. Upon viewing the message, the script code will execute in the user's web browser.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: &lt;;.

- 解决方案

ASP-Nuke versions RC2 and higher are not vulnerable to this issue.

- 相关参考