CVE-2002-0508
CVSS10.0
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:12
NMCOS    

[原文]wwwisis 3.45 and earlier allows remote attackers to execute arbitrary commands and read files via the parameters (1) prolog or (2) epilog.


[CNNVD]WWWIsis远程执行任意命令漏洞(CNNVD-200208-037)

        
        WWWIsis是为访问ISIS数据库提供WEB接口的程序,运行在Unix和Linux系统下,也可以运行在Microsoft Windows操作系统下。
        WWWIsis在对用户输入缺少充分检查,可导致远程攻击者以httpd进程的权限在目标系统上执行任意命令。
        WWWIsis中的格式语言功能过于强大,攻击者可以通过更改PATH_INFO信息而导致以httpd进程的权限执行任意命令。
        此问题在Linux系统上测试成功,JavaISIS和其他基于WWWIsis的工具也存在此漏洞。
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:wwwisis:wwwisis:3.45
cpe:/a:wwwisis:wwwisis:3.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0508
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0508
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-037
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4384
(VENDOR_ADVISORY)  BID  4384
http://www.securityfocus.com/bid/4383
(UNKNOWN)  BID  4383
http://www.iss.net/security_center/static/8660.php
(UNKNOWN)  XF  wwwisis-remote-command-execution(8660)
http://www.bireme.br/security.htm
(UNKNOWN)  CONFIRM  http://www.bireme.br/security.htm
http://online.securityfocus.com/archive/1/265456
(VENDOR_ADVISORY)  BUGTRAQ  20020402 RE: [VulnWatch] vuln in wwwisis: remote command execution and get files
http://online.securityfocus.com/archive/1/264682
(VENDOR_ADVISORY)  BUGTRAQ  20020328 vuln in wwwisis: remote command execution and get files
http://archives.neohapsis.com/archives/vulnwatch/2002-q1/0077.html
(UNKNOWN)  VULNWATCH  20020328 [VulnWatch] vuln in wwwisis: remote command execution and get files

- 漏洞信息

WWWIsis远程执行任意命令漏洞
危急 输入验证
2002-08-12 00:00:00 2005-10-20 00:00:00
远程  
        
        WWWIsis是为访问ISIS数据库提供WEB接口的程序,运行在Unix和Linux系统下,也可以运行在Microsoft Windows操作系统下。
        WWWIsis在对用户输入缺少充分检查,可导致远程攻击者以httpd进程的权限在目标系统上执行任意命令。
        WWWIsis中的格式语言功能过于强大,攻击者可以通过更改PATH_INFO信息而导致以httpd进程的权限执行任意命令。
        此问题在Linux系统上测试成功,JavaISIS和其他基于WWWIsis的工具也存在此漏洞。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 对服务端口设置访问过滤,确信只有合法可信用户能够连接访问。
        厂商补丁:
        WWWIsis
        -------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.bireme.br/isis/I/wwwi.htm

- 漏洞信息

14413
WWWISIS Multiple Parameter Arbitrary Command Execution

- 漏洞描述

- 时间线

2002-03-28 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

WWWIsis File Disclosure Vulnerability
Input Validation Error 4384
Yes No
2002-03-28 12:00:00 2009-07-11 11:56:00
Discovery of this issue is credited to Klaus Ripke <krip@openisis.org>.

- 受影响的程序版本

WWWIsis WWWIsis 3.45
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
WWWIsis WWWIsis 3.3
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
WWWIsis WWWIsis 5.0
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
WWWIsis WWWIsis 4.0
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17

- 不受影响的程序版本

WWWIsis WWWIsis 5.0
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
WWWIsis WWWIsis 4.0
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.24
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.23
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17
- Apache Software Foundation Apache 1.3.17

- 漏洞讨论

WWWIsis provides a web interface for accessing ISIS databases. It will run on most Unix and Linux variants, as well as Microsoft Windows operating systems.

A file disclosure vulnerability exists in WWWIsis. This may enable a remote attacker to disclose the contents of arbitrary web-readable files. This is due to insufficient validation of user-supplied input.

This issue has been reported for 3.x versions. Other versions are not affected by this vulnerability. Additionally, JavaISIS and other tools based on WWWIsis may also be affected.

- 漏洞利用

This issue may be exploited with a web browser.

- 解决方案

This issue is not present in versions 4.0 and later. Those affected are advised to upgrade to the most recent version.


WWWIsis WWWIsis 3.3

WWWIsis WWWIsis 3.45

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站