CVE-2002-0504
CVSS7.5
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:12
NMCOES    

[原文]Cross-site scripting vulnerability in Citrix NFuse 1.6 and earlier does not quote results from the getLastError method, which allows remote attackers to execute script in other clients via the NFuse_Application parameter to (1) launch.jsp or (2) launch.asp.


[CNNVD]Citrix NFuse存在跨站脚本执行漏洞(CNNVD-200208-071)

        
        Citrix NFuse是一款应用构建服务程序,通过WEB浏览器提供任意应用程序的功能,NFuse需要与WEB服务器结合工作,运行在多种操作系统下,包括Unix、Linux、Windows。
        Citrix NFuse对用户输入过滤上存在漏洞,可使远程攻击者建立包含恶意代码的链接对其他浏览用户进行跨站脚本执行攻击。
        Citrix NFuse中的launch.asp和launch.jsp脚本代码没有过滤来自URL参数的脚本代码,攻击者可以建立包含恶意Javascript代码的链接,当其他浏览用户访问此链接的时候,导致恶意Javascript代码在浏览用户浏览器上执行。
        此漏洞可导致攻击者获取基于Cookie认证的敏感信息。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:citrix:nfuse:1.6Citrix Nfuse 1.6
cpe:/a:citrix:nfuse:1.51Citrix Nfuse 1.51

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0504
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0504
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-071
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4372
(UNKNOWN)  BID  4372
http://www.iss.net/security_center/static/8659.php
(UNKNOWN)  XF  nfuse-launch-css(8659)
http://archives.neohapsis.com/archives/bugtraq/2002-03/0334.html
(UNKNOWN)  BUGTRAQ  20020327 NFuse Cross Site Scripting vulnerability

- 漏洞信息

Citrix NFuse存在跨站脚本执行漏洞
高危 输入验证
2002-08-12 00:00:00 2006-12-27 00:00:00
远程  
        
        Citrix NFuse是一款应用构建服务程序,通过WEB浏览器提供任意应用程序的功能,NFuse需要与WEB服务器结合工作,运行在多种操作系统下,包括Unix、Linux、Windows。
        Citrix NFuse对用户输入过滤上存在漏洞,可使远程攻击者建立包含恶意代码的链接对其他浏览用户进行跨站脚本执行攻击。
        Citrix NFuse中的launch.asp和launch.jsp脚本代码没有过滤来自URL参数的脚本代码,攻击者可以建立包含恶意Javascript代码的链接,当其他浏览用户访问此链接的时候,导致恶意Javascript代码在浏览用户浏览器上执行。
        此漏洞可导致攻击者获取基于Cookie认证的敏感信息。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 使用访问控制限制launch.jsp脚本访问。
        厂商补丁:
        Citrix
        ------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.citrix.com/products/nfuse/default.asp

- 漏洞信息 (21355)

Citrix NFuse 1.51/1.6 Cross-Site Scripting Vulnerability (EDBID:21355)
jsp remote
2002-03-27 Verified
0 Eric Detoisien
N/A [点击下载]
source: http://www.securityfocus.com/bid/4372/info

Citrix NFuse is an application portal server meant to provide the functionality of any application on the server via a web browser. NFuse works in conjunction with a previously-installed webserver. NFuse is said to support almost any operating system, including Unix and Linux variants, as well as Microsoft Windows operating systems.

A cross-site scripting vulnerability exists in Citrix NFuse. The launch.asp and launch.jsp scripts do not filter script code from URL parameters. An attacker may create a malicious link to one of these scripts which includes script code, which will be executed in the browser of an arbitrary web user who visits the link, in the security context of the site running Citrix NFuse.

This may enable an attacker to steal cookie-based authentication credentials from legitimate users of the vulnerable software. 

http://my_nfuse_portal.com/launch.jsp?NFuse_Application=<script>alert(document.cookie);</script> 		

- 漏洞信息

9256
Citrix NFuse launch.jsp NFuse_Application Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Citrix NFuse contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate getLastError() variable upon submission to the launch.jsp script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2002-03-28 Unknow
2002-03-28 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Citrix NFuse Cross-Site Scripting Vulnerability
Input Validation Error 4372
Yes No
2002-03-27 12:00:00 2009-07-11 11:56:00
Discovery of this issue is credited to "Eric Detoisien" <eric.detoisien@global-secure.fr>.

- 受影响的程序版本

Citrix Nfuse 1.51
Citrix Nfuse 1.6

- 漏洞讨论

Citrix NFuse is an application portal server meant to provide the functionality of any application on the server via a web browser. NFuse works in conjunction with a previously-installed webserver. NFuse is said to support almost any operating system, including Unix and Linux variants, as well as Microsoft Windows operating systems.

A cross-site scripting vulnerability exists in Citrix NFuse. The launch.asp and launch.jsp scripts do not filter script code from URL parameters. An attacker may create a malicious link to one of these scripts which includes script code, which will be executed in the browser of an arbitrary web user who visits the link, in the security context of the site running Citrix NFuse.

This may enable an attacker to steal cookie-based authentication credentials from legitimate users of the vulnerable software.

- 漏洞利用

The following example was submitted:

http://my_nfuse_portal.com/launch.jsp?NFuse_Application=&lt;script&gt;alert(document.cookie);&lt;/script&gt;

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站