CVE-2002-0488
CVSS10.0
发布时间 :2002-08-12 00:00:00
修订时间 :2008-09-05 16:28:09
NMCO    

[原文]Linux Directory Penguin traceroute.pl CGI script 1.0 allows remote attackers to execute arbitrary code via shell metacharacters in the host parameter.


[CNNVD]Linux Directory Penguin Traceroute远程命令执行漏洞(CNNVD-200208-005)

        
        Penguin traceroute.pl是一款由perl语言实现在WEB接口下提供路由跟踪功能的程序,由Linux Directory开发和维护。
        Penguin traceroute.pl由于在执行traceroute程序时没有充分过滤输入,可导致攻击者以httpd权限执行任意命令。
        Penguin traceroute.pl没有对用户输入的内容进行充分过滤,攻击者可以输入元字符";"并再后面追加任意命令,可导致攻击者可以以httpd的权限执行任意命令。
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-0488
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2002-0488
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200208-005
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/4332
(VENDOR_ADVISORY)  BID  4332
http://www.iss.net/security_center/static/8600.php
(VENDOR_ADVISORY)  XF  penguin-traceroute-command-execution(8600)
http://www.securityfocus.com/archive/1/263285
(VENDOR_ADVISORY)  BUGTRAQ  20020321 PHP script: Penguin Traceroute, Remote Command Execution
http://www.linux-directory.com/scripts/traceroute.pl
(UNKNOWN)  CONFIRM  http://www.linux-directory.com/scripts/traceroute.pl

- 漏洞信息

Linux Directory Penguin Traceroute远程命令执行漏洞
危急 未知
2002-08-12 00:00:00 2006-09-22 00:00:00
远程  
        
        Penguin traceroute.pl是一款由perl语言实现在WEB接口下提供路由跟踪功能的程序,由Linux Directory开发和维护。
        Penguin traceroute.pl由于在执行traceroute程序时没有充分过滤输入,可导致攻击者以httpd权限执行任意命令。
        Penguin traceroute.pl没有对用户输入的内容进行充分过滤,攻击者可以输入元字符";"并再后面追加任意命令,可导致攻击者可以以httpd的权限执行任意命令。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 使用如下代码过滤元字符:
        "$host =~ s/[;<>\*\|'&\$!?#\(\)\[\]\{\}:'"\\]//g;"
        "$host = $q->param('host');"
        厂商补丁:
        Linux Directory
        ---------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.linux-directory.com/scripts/traceroute.shtml

- 漏洞信息

5286
Linux Directory Penguin Traceroute Host Parameter Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Penguin Traceroute contains a flaw that may allow a malicious user to execute arbitrary commands. The issue is triggered since shell metacharacters are not handled. It is possible that the flaw may allow an attacker to execute commands by passing a ';' or a '|' character in the URL resulting in a loss of integrity.

- 时间线

2002-03-21 Unknow
2002-03-21 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Paul Jenkins has released an unofficial patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站